Jump to content

  • 0

unable to update registry via sccm 2007


When trying to install and update an application via Task Sequence or normal application deploy with SCCM 2007, it doesn't update the registry properly. It is not updating HKLM/Software/Application/, only the /Software/Wow6432Node/Application/, the application requires the first part to have the correct values. Target is windows 7 SP1 64bit


When I run it locally it works (copy the files to the desktop and run from elevated command prompt). I see the update in regedit.


I understand this is because of 64bit registry protection, so I tried the Task sequence with disable 64bit filesystem redirection (does filesystem include registry?), didn't make a difference.


Currently I have 3 files in a folder on a share, install.cmd, snare.reg, and the application. yes DP is updated.

Package is set to execute install.cmd, install.cmd contains the following:


copy snare.reg %windir%

start /wait SnareForWindows- /verysilent

start /wait regedit.exe /s %windir%\snare.reg

net stop snare

net start snare


Also in the TS, I set a command line step "regedit.exe /s %windir%\snare.reg" (I have also tried "start /wait cmd /c reg import snare.reg"), set "Disable 64bit redirection", and set "Run this step as the following account" and input a local admin account (also tried with this unchecked).


getting errors 0x80070002 and 0x800700C1 on 2 different test systems, both fail the task sequence. The application installs fine, but registry doesn't update. The snare.reg file is successfully copied to the windows directory.


How should one deploy a reg update on a 64bit system? Am I running into some weird limitation in SCCM or a scripting issue with remote installs and SYSTEM? The application also has an option to set the settings via an INF file but that just updates the registry the same way. I don't have access to AD or GPOs. Tried psexec with no luck.


Struggling with this for days,

thanks !

Share this post

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Forgot to mention:

0x80070002 = file not found error, not sure why I'm getting that though because the file is there

0x800700C1 = because I somehow broke regedit on that machine. manually going to regedit32.exe still pulls up the registry though


Also, this application was tested and working on 32bit Vista, hasn't worked since our windows 64 bit roll out though.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.