Jump to content


griffindodd

Problems initiating unattanded application deployment

Recommended Posts

Hi all,

 

Thanks for the great information at this forum, it's helped me get up and running with my first ever test of SCCM.

 

I have managed to set up my main DP and import all of my computers and users from AD. Set up my boundaries, distribute my clients so pretty successful so far.

 

I'm trying to distribute Flash Player 10 ActiveX control across my local network as a test for application distribution. I am using an MSI and have set up the distribution following various threads of information I have found around these forums.

 

2 issues

 

1. - How do I distribute the software with zero user interaction required? At the moment the distribution stops at 'waiting for content in the 'In Progress' tab for that deployment. It shows up fine in software center on the client computers but the user has to choose 'install' to initiate the download and start the installation.

 

2 - On this particular deployment when the user does try and install the software it fails with the error 'The software change returned error code 0x643(1603).'

 

Windows application logs....

 

Beginning a Windows Installer transaction: C:\Windows\ccmcache\2\install_flash_player_10_active_x.msi. Client Process Id: 3420.

 

Product: Adobe Flash Player 10 ActiveX -- Error 1722.There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action NewCustomAction1, location: C:\Windows\TEMP\InstallAX.exe, command: -install activex -msi

 

Ending a Windows Installer transaction: C:\Windows\ccmcache\2\install_flash_player_10_active_x.msi. Client Process Id: 3420.

 

Application "Adobe Flash Player 10 ActiveX Control" failed with failure exit code of 1603.

User name: SYSTEM.

Share this post


Link to post
Share on other sites

Hi Griffin,

 

for 1, make the advertisement mandatory by assigning a schedule to it, or at least the "run as soon as possible" option.

 

for 2, i had the same problem with the msi package for flash player 10 ax, latest version, on some clients. The custom action inside the msi for InstallAX failed. Solution was to use the EXE Installers for flash player 10. The installation switch for the installer, to make it silent, is "-install".

Share this post


Link to post
Share on other sites

Thanks for your help.

 

I have tried choosing the 'required' option for the software and also choosing the 'run as soon as possible' option in the advertisement but it doesn't seem to make any difference.

 

I tried another stand alone MSI for a web plugin called 'Cortona 2D Viewer' making sure I chose 'as soon as possible' for the schedule. This time out of 50 computers, under the In Progress tab in deployments it is reporting that 17 computers are in the category of 'waiting for content' while the other 33 are in the category 'In progress' and this is where everything seems to be just hanging.

 

Update: Computers are slowly moving from waiting for content, to the 'In progress' category, but as yet I am not seeing any number changes in the 'success' tab. Also even the default deployment 'Configuration Manager Upgrade Package (Configuration Manager Client Upgrade Program)' shows nothing in the success tab and 174 machines in the 'In progess' tab showing 'Program Received' on all machines.

 

Something isn't right here

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...