Jump to content


PXE-E53: No boot filename received

Recommended Posts

Hi All,


I am trying to deploy my captured Win7 image to a VM as a test before I try it on a real PC. My setup is as follows:


Main SCCM server: Win 2008 R2, SCCM 2007 SP2 R3; Roles: Comp Svr, MP, DMP, DP, RP, SLP, Site server and system

SCCM PXE Server: Win 2008 R2; Roles: Comp Svr, PXE SP, SMP, and Site system

A Dist Server: Win 2008 R2; Roles: DP, Site system

Soft Update Server: Win 2008 R2; Roles: Comp Svr, FSP, SLP, SUP, site system


There are no errors in the system status. The PXE point worked fine when I did the image capture from a VM. That VM will still show that the PXE is interfacing but decline to PXE boot because of no advertisement. The smspxe.log shows that it was contacted but it declined a PXE boot due to no advertisement.


When I try the deploy I get PXE-E53: No boot filename received. I have gone through every trouble shooting tip I can find and still nothing. The wierd thing is that there is no entries at all in the smspxe.log except the normal testing stuff. I even created a second VM and brought it into the deployment collection and it did the same thing.


I am ready to pull my hair out...what little I have left. Can anyone help?



Share this post

Link to post
Share on other sites


Have you removed the PXE role and reinstalled it? Here is a great guide on how to do that:



It's probably the way to go.



Share this post

Link to post
Share on other sites

Hi Jorgen,


Yes, I did that once even though the it worked fine for my build and capture. The logs indicated that everything is good, but it will not PXE boot the new deployment package. I know the PXE is working because I used my Reference VM to PXE boot again under the Capture Task. So the PXE is working fine, just not for this deployment. I have confirmed that the boot images (86x & 64x) successfully installed in the PXE share SMSIMAGES$ and also on the two DPs. The install package is on one of the DPs. I imported two bare metal VMs using the Computer Association import single computers and assigned them to my Windows 7 Deployment collections. I have advertized to that collection. I confirmed that the two VMs in the collection show the advertisement being assigned to them. I used Trace32 to monitor the smspxe.log when I try the PXE boot and don't get anything showing up. I have really been through the information on this site and several others including MS Technet and I am at a loss. It is probably something stupid, but I am new to SCCM. Thanks for your response.



Share this post

Link to post
Share on other sites

I am an idiot! I was talking to my VMWare guy and he noticed I had the VMs on the wrong network, no wonder it didn't work. I changed networks and everything works like a champ! It is always the little stuff that messes you up. I poured over all the SCCM config settings thinking I did something wrong and it turns out to be an issue with the VM. Thanks for trying to help Jorgen.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...