guyver78

Management Point PXE Boot Error 80004005 After SP1 Upgrade



17 posts in this topic

Ok so i have 2 test lab sites and 1 production site and after upgrading Sccm 2012 to Sccm 2012 SP1 its completely killed my PXE Boot. after going thorugh SMSPXE.log i keep getting the following error:

 

RequestMPKeyInformation: Send() failed.

Failed to get information for MP: http://MYSCCMSERVER.com. 80004005.SMSPXE

PXE::MP_InitializeTransport failed; 0x80004005

PXE::MP_LookupDevice failed; 0x80004005

PXE Provider failed to initialize MP connection. Unspecified error (Error: 80004005; Source: Windows)

RequestMPKeyInformation: Send() failed.

Failed to get information for MP: http://MYSCCMSERVER.com. 80004005.

PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE

PXE::MP_ReportStatus failed; 0x80004005

PXE::CPolicyProvider::InitializeMPConnection failed; 0x80004005

 

I have seen similar errors around but none of the solutions have worked for me so far. Whats strange is prior to the SP1 Update everything worked perfectly so what could the service pack have done to cause this?

 

I have tried the following:

 

Removed WDS, Removed DP, Removed MP

Deleted RemoteInstall, SCCMCOntentLib, SMSPKG, SMSPKGE$, SMSPKGSIG, SMSSIG$

Re-added WDS, Re-added MP & DP.

Reconfigured DP etc etc

Re-Created Boot images with drivers and updated DP points countless times and still no go :(

 

Anyone else experience the same thing? Could this be permission issue? I have tried sooo many different things and nothing has resolved it so far? I dont know what else I can try since it was working perfectly 2 days ago prior to this SP1 update :(

 

 

Share this post


Link to post
Share on other sites


Same here. I'm stuck after 4 days searching articles on the internet... After entering my password during the pxe boot i got these errors ;

 

RequestMPKeyInformation: Send() failed. SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)
Failed to get information for MP: http://MYSCCMSERVER.com 80004005. SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)
PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)
PXE::MP_LookupDevice failed; 0x80004005 SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)
PXE Provider failed to initialize MP connection.
Unknown error (Error: 80004005; Source: Unknown) SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)
RequestMPKeyInformation: Send() failed. SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)
Failed to get information for MP: http://MYSCCMSERVER.com. 80004005. SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)
PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)
PXE::MP_ReportStatus failed; 0x80004005 SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)
PXE::CPolicyProvider::InitializeMPConnection failed; 0x80004005 SMSPXE 24/01/2013 20:43:23 1980 (0x07BC)

I did a cleane install with SP1 included. RTM version was working correctly before.

 

Then i rebooted my DNS/DHCP servers and it starting to working again....

Share this post


Link to post
Share on other sites

After SP1 we had the same/similar issues in our environment. Here are the steps I used to fix PXE on the DPs and get OSD running again:


  • untick the enable PXE checkbox on the distribution point. Answer yes that you want to remove the Windows Deployment service.
  • remove boot images from your distribution point
  • After 5 minutes delete %windir%\temp
  • check with server manager. If WDS is done uninstalling there is a reboot pending. Reboot.
  • check if the remoteinstall folder is located on your system. If it is delete it. If it fails to delete due to permission issues with the SMSTempBootFiles path, delete all folders except that one and then rename the remoteinstall folder something else.
  • reboot
  • Add the PXE point again by checking the box on the distribution point properties. Check the distrmgr.log and see if the remoteinstall folder reappears..
  • Replicate the boot image to the DP again. After they land you can try running an F12 and it should roll smoothly.

RE: the old remoterinstall permission issues, this seems to be the root cause of why PXE broke on all our DPs after SP1. As to why the permission error occurred, I cannot say but will continue looking for the root cause.

2 people like this

Share this post


Link to post
Share on other sites

Thanks Phazers,

 

 

had the same error on all distribution points this morning, after upgrading to SP1 last friday. Fixed it by following your steps except deleteing the temp directory.

If anyone knows a method to get rid of the (renamed) SMSTempBootFiles folder, please let us know.

Share this post


Link to post
Share on other sites

After SP1 we had the same/similar issues in our environment. Here are the steps I used to fix PXE on the DPs and get OSD running again:

  • untick the enable PXE checkbox on the distribution point. Answer yes that you want to remove the Windows Deployment service.
  • remove boot images from your distribution point
  • After 5 minutes delete %windir%\temp
  • check with server manager. If WDS is done uninstalling there is a reboot pending. Reboot.
  • check if the remoteinstall folder is located on your system. If it is delete it. If it fails to delete due to permission issues with the SMSTempBootFiles path, delete all folders except that one and then rename the remoteinstall folder something else.
  • reboot
  • Add the PXE point again by checking the box on the distribution point properties. Check the distrmgr.log and see if the remoteinstall folder reappears..
  • Replicate the boot image to the DP again. After they land you can try running an F12 and it should roll smoothly.

RE: the old remoterinstall permission issues, this seems to be the root cause of why PXE broke on all our DPs after SP1. As to why the permission error occurred, I cannot say but will continue looking for the root cause.

 

Thanks. This worked for me also. +1 :)

1 person likes this

Share this post


Link to post
Share on other sites

Thanks. This worked for me also. +1 :)

 

After SP1 we had the same/similar issues in our environment. Here are the steps I used to fix PXE on the DPs and get OSD running again:

  • untick the enable PXE checkbox on the distribution point. Answer yes that you want to remove the Windows Deployment service.
  • remove boot images from your distribution point
  • After 5 minutes delete %windir%\temp
  • check with server manager. If WDS is done uninstalling there is a reboot pending. Reboot.
  • check if the remoteinstall folder is located on your system. If it is delete it. If it fails to delete due to permission issues with the SMSTempBootFiles path, delete all folders except that one and then rename the remoteinstall folder something else.
  • reboot
  • Add the PXE point again by checking the box on the distribution point properties. Check the distrmgr.log and see if the remoteinstall folder reappears..
  • Replicate the boot image to the DP again. After they land you can try running an F12 and it should roll smoothly.

RE: the old remoterinstall permission issues, this seems to be the root cause of why PXE broke on all our DPs after SP1. As to why the permission error occurred, I cannot say but will continue looking for the root cause.

+1 here as well. This process worked for us too. Kudos to this, as I had spent all morning trying to fix this with other post suggestions on the interwebs. This was the magic bullet, thanks!

Share this post


Link to post
Share on other sites

Thanks Phazers,

 

 

had the same error on all distribution points this morning, after upgrading to SP1 last friday. Fixed it by following your steps except deleteing the temp directory.

If anyone knows a method to get rid of the (renamed) SMSTempBootFiles folder, please let us know.

 

Take ownership of the folder and then delete it

Share this post


Link to post
Share on other sites

Does not work for me, I have not upgraded to sp 1, it is a clean 2012 sp1 install.

 

 

RequestMPKeyInformation: Send() failed. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
Failed to get information for MP: http://DCM-SRV-SCCM-01.ulbsibiu.local. 80004005. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
PXE::MP_LookupDevice failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
PXE Provider failed to initialize MP connection.
Unspecified error (Error: 80004005; Source: Windows) SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
RequestMPKeyInformation: Send() failed. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
Failed to get information for MP: http://DCM-SRV-SCCM-01.ulbsibiu.local. 80004005. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
PXE::MP_ReportStatus failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
PXE::CPolicyProvider::InitializeMPConnection failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)

Share this post


Link to post
Share on other sites

Easier fix to try :


Stop WDS


Xcopy SourceGood G:\RemoteInstall\SMSBoot /s/e/v/o

Xcopy SourceGood G:\RemoteInstall\SMSTemp /s/e/v/o

Xcopy SourceGood G:\RemoteInstall\SMSTempBootFiles /s/e/v/o


Start WDS


This only works after SP1.

Share this post


Link to post
Share on other sites

Hi all hope some one can help.

 

Since running the SP1 update we've haven't been able to use the PXE boot. We get the "PXE:-E53: No boot filename received error" I've tired what you guys did above with no success. I was wondering if anyone had found another way of fixing it?

 

This is the error we get from SMSPXE.log

 

 

RequestMPKeyInformation: Send() failed. SMSPXE 22/03/2013 11:03:07 4908 (0x132C)
Failed to get information for MP: http://aa.bb.com. 80004005. SMSPXE 22/03/2013 11:03:07 4908 (0x132C)
PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 22/03/2013 11:03:07 4908 (0x132C)
PXE::MP_LookupDevice failed; 0x80004005 SMSPXE 22/03/2013 11:03:07 4908 (0x132C)
RequestMPKeyInformation: Send() failed. SMSPXE 22/03/2013 11:03:07 4908 (0x132C)
Failed to get information for MP: http://aa.bb.com. 80004005. SMSPXE 22/03/2013 11:03:07 4908 (0x132C)
PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 22/03/2013 11:03:07 4908 (0x132C)
PXE::MP_ReportStatus failed; 0x80004005 SMSPXE 22/03/2013 11:03:07 4908 (0x132C)
PXE Provider failed to process message.
Unspecified error (Error: 80004005; Source: Windows) SMSPXE 22/03/2013 11:03:07 4908 (0x132C)
Thanks.
Gav
Update, think i found out what causing my problems. I'm getting this when i view the MPsetup.log.
<03/22/13 14:04:45> Fatal MSI Error - mp.msi could not be installed. Anyone know why that would happen?

Share this post


Link to post
Share on other sites

Hi All,

All of the above methods were unsuccessful for me. It turns out that our issue was the distribution point attempting to perform the lookup against a Management Point in another forest; as the DP's computer account didn't have the correct access the lookups and PXE would fail with the symptoms shown above.

 

After a bit more digging I found that the Management Points are stored alphabetically in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\DP\ManagementPoints registry key on the distribution point and that the first DP it was attempting to hit was returning an access denied error to the DP. After adding the appropriate permissions on the MP the PXE boot proceeded without error. Removing the key for the offending server also worked temporarily until the DP's polling interval expired and the key was re-populated.

 

Hope this helps.

 

Cheers,

Hayden

Share this post


Link to post
Share on other sites

It wasn't a good practice for me either clean install Sccm 2012 SP1 with Datacenter 2012 all sort of site folder permission errors as well.

 

At the end I have decided to go back to my working system which is non SP1.

 

Infact it worked for the last 6 months no problems at all.

 

I thought SP1 would be better but I never guessed it would hurt this much what a pain in the neck.

 

Too bad I am going back to old NON SP1.

 

I know it works at least.

Share this post


Link to post
Share on other sites

I followed this and it didn't quite work, but I think it was necessary. I had isntalled WDS manually so I could get the RemoteInstall fodler on a particular volume. I wouldn't do that again.

 

The last piece of the puzzle was from this post http://social.technet.microsoft.com/Forums/en-US/configmanagerosd/thread/2e3d5d45-e9e2-4e8f-a306-ab331927e726/

 

I was running into cert errors because I was still using the self-signed cert on my PXE Distro point. I had already created a cert for the distro points, but hadn't installed it on this one again after I had re-installed the distro point.

 

Thanks for a great forum!

After SP1 we had the same/similar issues in our environment. Here are the steps I used to fix PXE on the DPs and get OSD running again:


  • untick the enable PXE checkbox on the distribution point. Answer yes that you want to remove the Windows Deployment service.
  • remove boot images from your distribution point
  • After 5 minutes delete %windir%\temp
  • check with server manager. If WDS is done uninstalling there is a reboot pending. Reboot.
  • check if the remoteinstall folder is located on your system. If it is delete it. If it fails to delete due to permission issues with the SMSTempBootFiles path, delete all folders except that one and then rename the remoteinstall folder something else.
  • reboot
  • Add the PXE point again by checking the box on the distribution point properties. Check the distrmgr.log and see if the remoteinstall folder reappears..
  • Replicate the boot image to the DP again. After they land you can try running an F12 and it should roll smoothly.

RE: the old remoterinstall permission issues, this seems to be the root cause of why PXE broke on all our DPs after SP1. As to why the permission error occurred, I cannot say but will continue looking for the root cause.

Share this post


Link to post
Share on other sites

In my case, after installing SP1, it changed to using a self-signed cert in the Distribution Point properties, but left the PKI cert on the management point/IIS site. I went into IIS, exported the cert, and imported it into the distribution point properties, and presto, back to normal.

Share this post


Link to post
Share on other sites

After SP1 we had the same/similar issues in our environment. Here are the steps I used to fix PXE on the DPs and get OSD running again:

  • untick the enable PXE checkbox on the distribution point. Answer yes that you want to remove the Windows Deployment service.
  • remove boot images from your distribution point
  • After 5 minutes delete %windir%\temp
  • check with server manager. If WDS is done uninstalling there is a reboot pending. Reboot.
  • check if the remoteinstall folder is located on your system. If it is delete it. If it fails to delete due to permission issues with the SMSTempBootFiles path, delete all folders except that one and then rename the remoteinstall folder something else.
  • reboot
  • Add the PXE point again by checking the box on the distribution point properties. Check the distrmgr.log and see if the remoteinstall folder reappears..
  • Replicate the boot image to the DP again. After they land you can try running an F12 and it should roll smoothly.

RE: the old remoterinstall permission issues, this seems to be the root cause of why PXE broke on all our DPs after SP1. As to why the permission error occurred, I cannot say but will continue looking for the root cause.

Thanks, I appreciate your time as this corrected my issue also. Never would have thought permissions. However all good now, Thanks!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now