Jump to content


Ioan Popovici

Established Members
  • Content Count

    13
  • Joined

  • Last visited

  • Days Won

    1

Ioan Popovici last won the day on March 18 2013

Ioan Popovici had the most liked content!

Community Reputation

1 Neutral

About Ioan Popovici

  • Rank
    Member

Profile Information

  • Gender
    Male
  1. Hi everybody, Can someone tell me how I can check if a computer is already in AD from the PE UDI? I've tried to modify various powershell and vbscripts to detect that but they only work on a computer that is already joined in the domain. I want to use the preflight checks and have something like this: Images: http://ioan.in/tp6G http://ioan.in/SZ8v vbscript: http://ioan.in/9hga Is this possible? The thing is that you have the option to check the password and username but not the computer name. This really sucks it should be implemented in UDI deployment.
  2. Hi all, I'm running System Center 2012 SP1 as Standalone Primary Site and in my humble opinion It's the most bug-ridden software that I've ever seen. It runs smoothly once you've got it up and running but getting there is exhausting. I'm trying to get the PXE component up and running for three days now. By the way if you have the sccm client installed the SMSPXE.log is unde %windir\CCM\Logs, don't get the logic... Anyway i get these errors in my SMSPXE.log: RequestMPKeyInformation: Send() failed. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) Failed to get information for MP: http://DCM-SRV-SCCM-01.ulbsibiu.local. 80004005. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::MP_LookupDevice failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE Provider failed to initialize MP connection. Unspecified error (Error: 80004005; Source: Windows) SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) RequestMPKeyInformation: Send() failed. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) Failed to get information for MP: http://DCM-SRV-SCCM-01.ulbsibiu.local. 80004005. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::MP_ReportStatus failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::CPolicyProvider::InitializeMPConnection failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) And these in my distmgr.log when I try to refresh the bootfiles on my DP: MsiEnumRelatedProducts failed SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:53 PM 5572 (0x15C4) FindProduct failed; 0x80070103 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:54 PM 5572 (0x15C4) MsiEnumRelatedProducts failed SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:54 PM 5572 (0x15C4) FindProduct failed; 0x80070103 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:54 PM 5572 (0x15C4) Found C:\Windows\system32\wimgapi.dll SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:54 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\EFI\bootmgfw.efi SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:54 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:55 PM 5572 (0x15C4) RemoveDirectoryW failed (0x80070091) for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\EFI SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:55 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\Fonts\segmono_boot.ttf SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:55 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:55 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\Fonts\segoen_slboot.ttf SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:55 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:55 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\Fonts\segoe_slboot.ttf SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:56 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:56 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\Fonts\wgl4_boot.ttf SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:56 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:56 PM 5572 (0x15C4) RemoveDirectoryW failed (0x80070091) for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\Fonts SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:57 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\PXE\abortpxe.com SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:57 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:57 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\PXE\bootmgr.exe SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:57 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\PXE\pxeboot.com SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\PXE\pxeboot.n12 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\PXE\wdsmgfw.efi SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) SetFileAttributesW failed for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\PXE\wdsnbp.com SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) RemoveFile failed; 0x80070005 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) RemoveDirectoryW failed (0x80070091) for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot\PXE SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) RemoveDirectoryW failed (0x80070091) for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows\Boot SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) RemoveDirectoryW failed (0x80070091) for D:\RemoteInstall\SMSTempBootFiles\ULB00002\Windows SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:58 PM 5572 (0x15C4) RemoveDirectoryW failed (0x80070091) for D:\RemoteInstall\SMSTempBootFiles\ULB00002 SMS_DISTRIBUTION_MANAGER 3/4/2013 1:38:59 PM 5572 (0x15C4) What I figured is that when these files get extracted the permissions are incorrectly set. They are owned by the "TrustedInstaller" account and only this account has full rights on the files. This is clearly a bug, and the permissions must be changed manually every time you update the boot files. This can be done using PS: takeown /f D:\RemoteInstall /R /D Y icacls D:\RemoteInstall /grant SYSTEM:F /t What I've tried: 1. Uninstalling the MP, PXE, WDS, DP 2. Take ownership of the RemoteInstall folder and reboot 3. Deleting the RemoteInstall folder, Installing the MP, DP, reboot 4. Adding PXE, distribute bootimages At this point I was getting the same errors and the WSUS service was not starting anymore. (service could not start error 193: 0x1) Rollback to last snapshot trying a different approach... I've tried to remove only the PXE service with the same result. (File permissions incorrect in the SMSTempBootFiles folder and RequestMPKeyInformation: Send() failed) I've tried various combinations of these actions in the last few days all ending with the same result. I'm at wits end but I do not want to start from scratch and reconfigure everything. My site is backed up using the Site Maintenance Task, Is there a way to install a fresh server and migrate Collections ADRs, AMPs, Packages and settings? I am running SCCM 2012 SP1 Standalone Primary Site Server on a VM hosted on VM-ware ESXi, with standard Network Interfaces (E1000) The database is hosted locally on SQL Server 2012 These are the all my logs: http://ioan.in/NJq6 - Program Files\Microsoft Configuration Manager\Logs http://ioan.in/NJgi - Windows\CCM\Logs I appreciate every bit of help, thank you and sorry for the long post
  3. Does not work for me, I have not upgraded to sp 1, it is a clean 2012 sp1 install. RequestMPKeyInformation: Send() failed. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) Failed to get information for MP: http://DCM-SRV-SCCM-01.ulbsibiu.local. 80004005. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::MP_LookupDevice failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE Provider failed to initialize MP connection. Unspecified error (Error: 80004005; Source: Windows) SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) RequestMPKeyInformation: Send() failed. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) Failed to get information for MP: http://DCM-SRV-SCCM-01.ulbsibiu.local. 80004005. SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::MP_ReportStatus failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60) PXE::CPolicyProvider::InitializeMPConnection failed; 0x80004005 SMSPXE 3/4/2013 9:23:45 PM 2912 (0x0B60)
  4. Same problem, but my site is not a custom site and it is running on port 80. This is driving me crazy, I don't care what everyone else is saying but this is not enterprise ready. It is not ready for production environment, it it the most bug-ridden software I have ever seen! ================= PXE Provider loaded. ===================== SMSPXE 3/4/2013 6:43:28 PM 2904 (0x0B58) Machine is running Windows Longhorn. (NTVersion=0X602, ServicePack=0) SMSPXE 3/4/2013 6:43:28 PM 2904 (0x0B58) Cannot read the registry value of MACIgnoreListFile (00000000) SMSPXE 3/4/2013 6:43:28 PM 2904 (0x0B58) MAC Ignore List Filename in registry is empty SMSPXE 3/4/2013 6:43:28 PM 2904 (0x0B58) Begin validation of Certificate [Thumbprint 752F483638472B40EDB63F389771B9F390BD45CA] issued to '9d0d15e3-2e15-4f84-8d54-29117f28e0a3' SMSPXE 3/4/2013 6:43:28 PM 2904 (0x0B58) Completed validation of Certificate [Thumbprint 752F483638472B40EDB63F389771B9F390BD45CA] issued to '9d0d15e3-2e15-4f84-8d54-29117f28e0a3' SMSPXE 3/4/2013 6:43:28 PM 2904 (0x0B58) Initializing PXEPerfObject. SMSPXE 3/4/2013 6:43:28 PM 2904 (0x0B58) Client is set to use HTTPS when available. The current state is 480. SMSPXE 3/4/2013 6:43:28 PM 2904 (0x0B58) RequestMPKeyInformation: Send() failed. SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) Failed to get information for MP: http://DCM-SRV-SCCM-01.ulbsibiu.local. 80004005. SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) PXE::MP_LookupDevice failed; 0x80004005 SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) PXE Provider failed to initialize MP connection. Unspecified error (Error: 80004005; Source: Windows) SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) RequestMPKeyInformation: Send() failed. SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) Failed to get information for MP: http://DCM-SRV-SCCM-01.ulbsibiu.local. 80004005. SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) PXE::MP_ReportStatus failed; 0x80004005 SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) PXE::CPolicyProvider::InitializeMPConnection failed; 0x80004005 SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) PXE::CBootImageInfo::CBootImageInfo: key= SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) PXE::CBootImageInfo::CBootImageInfo: key= SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) Adding ULB00002.7 SMSPXE 3/4/2013 6:43:29 PM 2904 (0x0B58) Adding ULB00005.5 SMSPXE 3/4/2013 6:43:33 PM 2904 (0x0B58) Found new image ULB00002 SMSPXE 3/4/2013 6:43:39 PM 2904 (0x0B58) Opening image file D:\RemoteInstall\SMSImages\ULB00002\boot.ULB00002.wim SMSPXE 3/4/2013 6:43:40 PM 2904 (0x0B58) Found Image file: D:\RemoteInstall\SMSImages\ULB00002\boot.ULB00002.wim PackageID: ULB00002 ProductName: Microsoft® Windows® Operating System Architecture: 0 Description: Microsoft Windows PE (x86) Version: Creator: SystemDir: WINDOWS SMSPXE 3/4/2013 6:43:40 PM 2904 (0x0B58) Closing image file D:\RemoteInstall\SMSImages\ULB00002\boot.ULB00002.wim SMSPXE 3/4/2013 6:43:40 PM 2904 (0x0B58) Found new image ULB00005 SMSPXE 3/4/2013 6:43:46 PM 2904 (0x0B58) Opening image file D:\RemoteInstall\SMSImages\ULB00005\boot.ULB00005.wim SMSPXE 3/4/2013 6:43:46 PM 2904 (0x0B58) Found Image file: D:\RemoteInstall\SMSImages\ULB00005\boot.ULB00005.wim PackageID: ULB00005 ProductName: Microsoft® Windows® Operating System Architecture: 9 Description: Microsoft Windows PE (x64) Version: Creator: SystemDir: WINDOWS SMSPXE 3/4/2013 6:43:46 PM 2904 (0x0B58) Closing image file D:\RemoteInstall\SMSImages\ULB00005\boot.ULB00005.wim SMSPXE 3/4/2013 6:43:46 PM 2904 (0x0B58) Begin validation of Certificate [Thumbprint 752F483638472B40EDB63F389771B9F390BD45CA] issued to '9d0d15e3-2e15-4f84-8d54-29117f28e0a3' SMSPXE 3/4/2013 6:43:54 PM 2904 (0x0B58) Completed validation of Certificate [Thumbprint 752F483638472B40EDB63F389771B9F390BD45CA] issued to '9d0d15e3-2e15-4f84-8d54-29117f28e0a3' SMSPXE 3/4/2013 6:43:54 PM 2904 (0x0B58) PXE Provider finished loading. SMSPXE 3/4/2013 6:43:54 PM 2904 (0x0B58) and then there are these errors: failed to copy D:\RemoteInstall\SMSTempBootFiles\ULB00005\WINDOWS\Boot\Fonts\segmono_boot.ttf to D:\RemoteInstall\Boot\Fonts\segmono_boot.ttf SMSPXE 3/1/2013 2:05:45 PM 4140 (0x102C) InstallBootFilesForImage failed. 0x80070003 SMSPXE 3/1/2013 2:05:45 PM 4140 (0x102C) Warning: Failed to copy the needed boot binaries from the boot image D:\RemoteInstall\SMSImages\ULB00005\boot.ULB00005.wim. The operation completed successfully. (Error: 00000000; Source: Windows) SMSPXE 3/1/2013 2:05:45 PM 4140 (0x102C) Failed adding image D:\RemoteInstall\SMSImages\ULB00005\boot.ULB00005.wim. Will Retry.. The system cannot find the path specified. (Error: 80070003; Source: Windows) SMSPXE 3/1/2013 2:05:45 PM 4140 (0x102C) It creates SMSTempBootFiles with Installer service having full access and everyone else with limited access including SYSTEM and Bultin\Administrator accounts. Then It screams that it cannot update these files using the SYSTEM account. Doooh! If you take ownership of these files and give the system account access to them, IT does the same thing over again locking itself out. Removing the PXE and WDS, and deleting the remote install folder does not help because it cannot reinstall WDS on its own once removed no matter how many restarts and workarounds your try. Error after error after error. Thank god i am running a vm and can take snapshots. It took me two days configuring everything and now I'm stuck on the deployment component for almost a week now. Ive tried just about everything except a clean install. If someone has any idea how to solve this please share. Thank you
  5. It's by design and no you can't change it. I know...it sucks...
  6. Hi everyone, I've solved the problem and wanted to share maybe it will help someone. On the client DataTransferService.log i got the error: Successfully sent location services HTTP failure message. Error sending DAV request. HTTP code 401, status 'Unauthorized' GetDirectoryList_HTTP('http://DCM-SRV-SCCM-01.ulbsibiu.local:80/SMS_DP_SMSPKG$/e1dc20b6-5536-4bd0-9b3b-e26fc09287d0') failed with code 0x80070005. The workaround is to check Allow clients to connect anonymously on the Distribution point Properties. Thank you all, especially anyweb for his amazing blog, keep up the good work.
  7. First of all, great job this is definitely the best SCCM blog I've found. I am having trouble with deploying updates, the clients deployment status shows this: Status: Failed to install update(s) Error Code:0x80070005 Error Description:Access is denied. Last Enforcement State: Failed to install update(s) Last Enforcement Error Code:0x80070005 http://ioan.in/N2EG I have a permission problem somewhere On the clients I get: Failed to download contents for update 1a571c03-31b3-440e-87ee-d4952f090d03. Bundle update "20b340d0-2c5e-4600-8095-f7a5e403f1a2" failed to get content for update "cb2c36a8-437a-4be5-9780-571301b7e53f". Please check the enforcement status of update "cb2c36a8-437a-4be5-9780-571301b7e53f" to get further details. Updates advance download job completed with failure for assignment {d1325882-d2d1-49c8-9e18-127f7cf51176}. Any hints on this are greatly apreciated
  8. Hi, I accidentally installed SCCM 2012 SP1 as a primary site server using the same site code as my old SCCM 2012. I do not plan to use the old SCCM 2012 because there is something wrong with the database and I want to start from scratch. I've already given permission to the System Management container and it seems the new server has overwritten the old server settings. Does anyone know what the implications are ? Should I uninstall the old server and the new server and start again? I would like to keep the old server running so I can manually migrate my packages and tasks. Thank you
  9. Thanks, I saw that on their site but I needed to hear it from some one else too. I'm going to try to install it with SQL Server 2012 SP1 anyway, and see how it goes. Has anyone tried it yet? Did they encounter any problems? Thank you again
  10. Hi Does SCCM 2012 SP1 support SQL Server 2012 SP1?
×
×
  • Create New...