Jump to content


Sign in to follow this  
bjsusol

Not detecting a new machine type

Recommended Posts

So I have been building my OS Task sequence. I currently have most of my machine types available for PXE boot and deployment. However, I just tried to add a new machine type to the list, and its failing at the post install gather/apply windows settings phase.

 

I added a line in the customsettings.ini for the X230 Laptop - see below. The problem is, it doesn't seem to be getting past this. When I look at the log folder, its clear that its not detecting the computer model properly because the name its trying to give the computer is %Computermodel%-PK0B1LZ (which is the serial number). That being said, I can open a command prompt right on the failed PXE boot and do a WMIC COMPUTERSYSTEM GET MODEL and see that the model type is correct. I can build all the other machine types no problem. Its just an issue with the X230...

 

Does anyone have any thoughts why this might be failing?

[4177Q5U]
ComputerModel=T420
[2320KKU]
ComputerModel=X230
[Default]
OSInstall=Y
OSDComputerName=%ComputerModel%-%ComputerSerialNumber%
MachineObjectOU=CN=Computers,DC=firm,DC=goulstonstorrs,DC=com
SLSHARE=\\firm.goulstonstorrs.com\sc\sccm\OSD\TSLogs$
;SLShareDynamicLogging=\\firm.goulstonstorrs.com\sc\sccm\OSD\DynLogs$\%OSDComputername%
TimeZoneName=Eastern Standard Time
UserLocale=en-us

 

Share this post


Link to post
Share on other sites


[Settings]
Priority=Default
Properties=ComputerModel

[Default]
OSInstall=Y
MachineObjectOU=CN=Computers,DC=firm,DC=goulstonstorrs,DC=com
SLSHARE=\\firm.goulstonstorrs.com\sc\sccm\OSD\TSLogs$
;SLShareDynamicLogging=\\firm.goulstonstorrs.com\sc\sccm\OSD\DynLogs$\%OSDComputername%
TimeZoneName=Eastern Standard Time
UserLocale=en-us
Subsection=#Left("%MODEL%",4)#
OSDComputerName=%ComputerModel%-#Replace("#Left("%SERIALNUMBER%",10)#"," ","")#

[4177]
ComputerModel=T420

[2320]
ComputerModel=X230

This should do the trick. For Lenovo, you have only to care about the first 4 characters of the model.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...