Jump to content


curns

Established Members
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About curns

  • Rank
    Member
  1. For the record this is what I had to do to get applications to install via task sequence. 1. In my build and capture task sequence I used packages instead of applications to install "fat" apps. (not joined to domain). 2. In my deploy task sequence I found that the machine must be joined to the domain, otherwise applications failed to install with the same download failed message. Cheers!
  2. yes certificates are configured. all existing clients are using PKI. This is the first time we've tried OSD. The build works fine until it gets to the installing applications step.
  3. Hi Peter, I'm seeing the following errors in LocationServices.log. Security settings update detected, restarting CcmExec. LocationServices 16/10/2013 11:09:41 AM 2976 (0x0BA0) Retrieved lookup MP [sCCM01.MYDOMAIN.COM] from Registry LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Attempting to retrieve lookup MP(s) from DNS LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) DNS Suffix not specified LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) No lookup MP(s) from DNS LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Attempting to retrieve site information from lookup MP(s) via HTTPS LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Attempting to retrieve site information from lookup MP(s) via HTTP LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Failed to send site information Location Request Message to SCCM01.MYDOMAIN.COM LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Failed to refresh security settings over MP with error 0x80004005. LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) No security settings update detected. LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Retrieved lookup MP [sCCM01.MYDOMAIN.COM] from Registry LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Attempting to retrieve lookup MP(s) from DNS LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) DNS Suffix not specified LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) No lookup MP(s) from DNS LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Attempting to retrieve site information from lookup MP(s) via HTTPS LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Attempting to retrieve site information from lookup MP(s) via HTTP LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Failed to send site information Location Request Message to SCCM01.MYDOMAIN.COM LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Failed to refresh Site Signing Certificate over MP with error 0x80004005. LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Refreshing Site Signing Certificate over HTTP LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) [CCMHTTP] ERROR: URL=http://SCCM01.MYDOMAIN.COM/SMS_MP/.sms_aut?SITESIGNCERT, Port=80, Options=480, Code=0, Text=CCM_E_BAD_HTTP_STATUS_CODE LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Raising event: instance of CCM_CcmHttp_Status { ClientID = "GUID:0FBC0056-688E-4002-BEC8-F8385A58D0A7"; DateTime = "20131016030946.999000+000"; HostName = "SCCM01.MYDOMAIN.COM"; HRESULT = "0x87d0027e"; ProcessID = 3008; StatusCode = 403; ThreadID = 280; }; LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Successfully sent security settings refresh message. LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Successfully sent location services HTTP failure message. LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Failed to refresh Site Signing Certificate over HTTP with error 0x87d0027e. LocationServices 16/10/2013 11:09:46 AM 280 (0x0118) Retrieved lookup MP [sCCM01.MYDOMAIN.COM] from Registry LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) Attempting to retrieve lookup MP(s) from DNS LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) DNS Suffix not specified LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) No lookup MP(s) from DNS LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) Attempting to retrieve default management points from lookup MP(s) via HTTPS LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) Attempting to retrieve default management points from lookup MP(s) via HTTP LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) Unable to retrieve AD site membership LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) Failed to send management point list Location Request Message to SCCM01.MYDOMAIN.COM LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) Failed to retrieve Default Management Points from lookup MP(s) LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) DNS Suffix not specified LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) Failed to retrieve Default Management Points from DNS LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) Attempting to retrieve NLB management point from WINS LocationServices 16/10/2013 11:09:47 AM 280 (0x0118) Failed to resolve 'NLB_ABC' from WINS LocationServices 16/10/2013 11:09:56 AM 280 (0x0118) No NLB management point is present, attempting to retrieve default management point from WINS LocationServices 16/10/2013 11:09:56 AM 280 (0x0118) Failed to resolve 'MP_ABC' from WINS LocationServices 16/10/2013 11:10:05 AM 280 (0x0118) Failed to retrieve MP through WINS. LocationServices 16/10/2013 11:10:05 AM 280 (0x0118) Failed to retrieve AMP for site code 'ABC' with error (0x80004005). Nulling existing entry in WMI LocationServices 16/10/2013 11:10:05 AM 280 (0x0118) Assigned MP changed from <SCCM01.MYDOMAIN.COM> to <>. LocationServices 16/10/2013 11:10:05 AM 280 (0x0118) Persisted Default Management Point Locations locally LocationServices 16/10/2013 11:10:05 AM 280 (0x0118) Attempting to retrieve local MPs from the assigned MP LocationServices 16/10/2013 11:10:05 AM 280 (0x0118) Unable to retrieve AD site membership LocationServices 16/10/2013 11:10:05 AM 280 (0x0118) Unable to retrieve AD site membership LocationServices 16/10/2013 11:10:05 AM 280 (0x0118) Executing Task LSRefreshSecuritySettingsTask LocationServices 16/10/2013 11:10:14 AM 1812 (0x0714) Executing Task LSRefreshSecuritySettingsTask LocationServices 16/10/2013 11:10:14 AM 280 (0x0118) Executing Task LSRefreshSecuritySettingsTask LocationServices 16/10/2013 11:10:14 AM 2976 (0x0BA0) Executing Task LSSiteRoleCycleTask LocationServices 16/10/2013 11:10:14 AM 1668 (0x0684) Executing Task LSSiteRoleCycleTask LocationServices 16/10/2013 11:10:14 AM 1612 (0x064C) A security settings update is already in progress. LocationServices 16/10/2013 11:10:14 AM 168 (0x00A8) A security settings update is already in progress. LocationServices 16/10/2013 11:10:14 AM 1812 (0x0714) Executing Task LSSiteRoleCycleTask LocationServices 16/10/2013 11:10:14 AM 1812 (0x0714) Executing Task LSRefreshSecuritySettingsTask LocationServices 16/10/2013 11:10:14 AM 2836 (0x0B14) A security settings update is already in progress. LocationServices 16/10/2013 11:10:14 AM 2280 (0x08E8) Executing Task LSSiteRoleCycleTask LocationServices 16/10/2013 11:10:14 AM 280 (0x0118) Retrieved lookup MP [sCCM01.MYDOMAIN.COM] from Registry LocationServices 16/10/2013 11:10:14 AM 2892 (0x0B4C) Attempting to retrieve lookup MP(s) from DNS LocationServices 16/10/2013 11:10:14 AM 2892 (0x0B4C) DNS Suffix not specified LocationServices 16/10/2013 11:10:14 AM 2892 (0x0B4C) No lookup MP(s) from DNS LocationServices 16/10/2013 11:10:14 AM 2892 (0x0B4C) Attempting to retrieve site information from lookup MP(s) via HTTPS LocationServices 16/10/2013 11:10:14 AM 2892 (0x0B4C) Attempting to retrieve site information from lookup MP(s) via HTTP LocationServices 16/10/2013 11:10:14 AM 2892 (0x0B4C) Executing Task LSRefreshSecuritySettingsTask LocationServices 16/10/2013 11:10:14 AM 2836 (0x0B14) A security settings update is already in progress. LocationServices 16/10/2013 11:10:14 AM 168 (0x00A8) Failed to send site information Location Request Message to SCCM01.MYDOMAIN.COM LocationServices 16/10/2013 11:10:14 AM 2892 (0x0B4C) Failed to refresh security settings over MP with error 0x80004005. LocationServices 16/10/2013 11:10:14 AM 2892 (0x0B4C) Executing Task LSSiteRoleCycleTask LocationServices 16/10/2013 11:10:14 AM 2976 (0x0BA0) No security settings update detected. LocationServices 16/10/2013 11:10:14 AM 2892 (0x0B4C) Seems like maybe a certificate issue? Some notes: - We are using HTTPS - In the 'Setup Windows & ConfigMgr' step I have entered "SMSMP=sccm01.mydomain.com" in the installation properties. - We don't use WINS. What am I missing? Thanks.
  4. Hi All, I have SCCM 2012 SP1 with CU3 installed and I'm having trouble installing applications during a build and capture task sequence. I have a single site, with the MP in a data center and a local DP / PXE server in the office. I only installed CU3 on the primary site server as I was under the impression it doesn't need to be installed on DP's (please correct me if I am wrong!) Below are some snippets from the smsts.log file. ... NotifyProgress received: 16 (Application failed to evaluate ) InstallApplication 15/10/2013 11:08:01 AM 596 (0x0254) ... Policy Evaluation failed, hr=0x87d00267 InstallApplication 15/10/2013 11:08:01 AM 2068 (0x0814) ... Install application action failed: '7-Zip'. Error Code 0x87d00267 InstallApplication 15/10/2013 11:08:01 AM 2068 (0x0814) ... Install Static Applications failed, hr=0x87d00267 InstallApplication 15/10/2013 11:08:01 AM 2068 (0x0814) ... Failed to run the action: Install Applications. Download failed (Error: 87D00267; Source: CCM) TSManager 15/10/2013 11:08:01 AM 1524 (0x05F4) ... The execution of the group (Build the Reference Machine) has failed and the execution has been aborted. An action failed. Operation aborted (Error: 80004004; Source: Windows) TSManager 15/10/2013 11:08:01 AM 1524 (0x05F4) Failed to run the last action: Install Applications. Execution of task sequence failed. Download failed (Error: 87D00267; Source: CCM) TSManager 15/10/2013 11:08:01 AM 1524 (0x05F4) ... I get the same error regardless of what application i choose. I have ticked the option "allow this application to be installed from the Install Application task sequence action without being deployed" Any help is appreciated!
  5. Sorry for late reply. I also ended up changing my SUP to sync more frequently. I also changed my ADR from 1 day to 12 hours. This seems to have resolved most of the issues. Thanks.
  6. Hi Niall, Thanks for your guides they have been a great help. I have a question about endpoint updates failing if there are multiple updates available. My ADR is set to check for updates released/revised in the last 1 day as per your guide. What happens is the first update is installed successfully and any subsequent updates fail to install. WUAHandler.log 1. Update (Missing): Definition Update for Microsoft Endpoint Protection - KB2461484 (Definition 1.149.1295.0) (bbf865e4-3ff0-40e5-b13e-df186cc63063, 200) WUAHandler 7/05/2013 4:52:32 AM 11048 (0x2B28) 2. Update (Missing): Definition Update for Microsoft Endpoint Protection - KB2461484 (Definition 1.149.1332.0) (f301ceba-a8d0-4429-9fc8-93342a234acd, 200) WUAHandler 7/05/2013 4:52:32 AM 11048 (0x2B28) Async installation of updates started. WUAHandler 7/05/2013 4:52:32 AM 11048 (0x2B28) Update 1 (bbf865e4-3ff0-40e5-b13e-df186cc63063) finished installing (0x00000000), Reboot Required? No WUAHandler 7/05/2013 4:52:40 AM 8860 (0x229C) Update 2 (f301ceba-a8d0-4429-9fc8-93342a234acd) finished installing (0x80070643), Reboot Required? No WUAHandler 7/05/2013 4:52:41 AM 9504 (0x2520) Async install completed. WUAHandler 7/05/2013 4:52:41 AM 9504 (0x2520) Installation of updates completed. WUAHandler 7/05/2013 4:52:41 AM 4236 (0x108C) WindowsUpdate.log 2013-05-07 04:52:32:422 1076 f94 Agent * Updates to install = 2 2013-05-07 04:52:32:423 1076 f94 Agent * Title = Definition Update for Microsoft Endpoint Protection - KB2461484 (Definition 1.149.1295.0) 2013-05-07 04:52:32:423 1076 f94 Agent * UpdateId = {BBF865E4-3FF0-40E5-B13E-DF186CC63063}.200 2013-05-07 04:52:32:423 1076 f94 Agent * Bundles 12 updates: 2013-05-07 04:52:32:423 1076 f94 Agent * {F31E6554-4C24-41F5-A8A5-208278248343}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {8C88FF64-9417-41F4-B246-8122584867A5}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {6B386754-D41B-4AAA-838B-D30D8FAF2B1C}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {8B643E13-DB55-4AA4-859B-F93E835E74FB}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {6B592150-B614-406A-B274-83482BC346CE}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {D1BD04C9-E57C-4807-A9F0-858B92696D5E}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {BAF05577-E3B4-4A3A-8634-681910527EBC}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {81B4C990-BBBB-45F9-B958-4AE27BCDC6F0}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {2B6ED6D2-F70B-432B-B3A0-FA7DA64BA52A}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {3C2FFBD1-FD4D-41D6-9BED-5C0050E4C282}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {2D9905CF-827E-4DA6-AB89-8E7AB2BFC25C}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {2122E472-E363-4990-9348-2B55C0980C14}.200 2013-05-07 04:52:32:423 1076 f94 Agent * Title = Definition Update for Microsoft Endpoint Protection - KB2461484 (Definition 1.149.1332.0) 2013-05-07 04:52:32:423 1076 f94 Agent * UpdateId = {F301CEBA-A8D0-4429-9FC8-93342A234ACD}.200 2013-05-07 04:52:32:423 1076 f94 Agent * Bundles 12 updates: 2013-05-07 04:52:32:423 1076 f94 Agent * {F31E6554-4C24-41F5-A8A5-208278248343}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {8C88FF64-9417-41F4-B246-8122584867A5}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {6B386754-D41B-4AAA-838B-D30D8FAF2B1C}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {8B643E13-DB55-4AA4-859B-F93E835E74FB}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {6B592150-B614-406A-B274-83482BC346CE}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {D1BD04C9-E57C-4807-A9F0-858B92696D5E}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {BAF05577-E3B4-4A3A-8634-681910527EBC}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {81B4C990-BBBB-45F9-B958-4AE27BCDC6F0}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {2B6ED6D2-F70B-432B-B3A0-FA7DA64BA52A}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {3C2FFBD1-FD4D-41D6-9BED-5C0050E4C282}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {2D9905CF-827E-4DA6-AB89-8E7AB2BFC25C}.200 2013-05-07 04:52:32:423 1076 f94 Agent * {4C3EE25D-4654-42E8-9406-2140775B9993}.200 2013-05-07 04:52:32:448 1076 f94 DnldMgr Preparing update for install, updateId = {2122E472-E363-4990-9348-2B55C0980C14}.200. 2013-05-07 04:52:32:453 2696 35c0 Misc =========== Logging initialized (build: 7.6.7600.256, tz: +0800) =========== 2013-05-07 04:52:32:453 2696 35c0 Misc = Process: C:\Windows\system32\wuauclt.exe 2013-05-07 04:52:32:453 2696 35c0 Misc = Module: C:\Windows\system32\wuaueng.dll 2013-05-07 04:52:32:453 2696 35c0 Handler ::::::::::::: 2013-05-07 04:52:32:453 2696 35c0 Handler :: START :: Handler: Command Line Install 2013-05-07 04:52:32:453 2696 35c0 Handler ::::::::: 2013-05-07 04:52:32:453 2696 35c0 Handler : Updates to install = 1 2013-05-07 04:52:40:562 2696 35c0 Handler : Command line install completed. Return code = 0x00000000, Result = Succeeded, Reboot required = false 2013-05-07 04:52:40:563 2696 35c0 Handler ::::::::: 2013-05-07 04:52:40:563 2696 35c0 Handler :: END :: Handler: Command Line Install 2013-05-07 04:52:40:563 2696 35c0 Handler ::::::::::::: 2013-05-07 04:52:40:567 1076 f94 DnldMgr Preparing update for install, updateId = {4C3EE25D-4654-42E8-9406-2140775B9993}.200. 2013-05-07 04:52:40:719 2696 35c0 Handler ::::::::::::: 2013-05-07 04:52:40:719 2696 35c0 Handler :: START :: Handler: Command Line Install 2013-05-07 04:52:40:719 2696 35c0 Handler ::::::::: 2013-05-07 04:52:40:719 2696 35c0 Handler : Updates to install = 1 2013-05-07 04:52:41:013 2696 35c0 Handler : WARNING: Command line install completed. Return code = 0x80070670, Result = Failed, Reboot required = false 2013-05-07 04:52:41:013 2696 35c0 Handler : WARNING: Exit code = 0x8024200B 2013-05-07 04:52:41:013 2696 35c0 Handler ::::::::: 2013-05-07 04:52:41:013 2696 35c0 Handler :: END :: Handler: Command Line Install 2013-05-07 04:52:41:013 2696 35c0 Handler ::::::::::::: 2013-05-07 04:52:41:016 1076 f94 Agent ********* 2013-05-07 04:52:41:016 1076 1070 AU Can not perform non-interactive scan if AU is interactive-only 2013-05-07 04:52:41:016 1076 f94 Agent ** END ** Agent: Installing updates [CallerId = CcmExec] 2013-05-07 04:52:41:016 1076 f94 Agent ************* 2013-05-07 04:52:41:016 3788 1200 COMAPI >>-- RESUMED -- COMAPI: Install [ClientId = CcmExec] 2013-05-07 04:52:41:016 3788 1200 COMAPI - Install call complete (succeeded = 1, succeeded with errors = 0, failed = 1, unaccounted = 0) 2013-05-07 04:52:41:016 3788 1200 COMAPI - Reboot required = No All my clients seem to have this problem. This means the deployment compliance is very low because of the installation errors. It also means the majority of my clients report the definition status as "up to 3 days old" Thanks, Curns.
  7. Hi Peter, Thanks for the reply. I understand that I can use AD groups and target the machines, however to use the application catalog website the application must be deployed to users, not devices. Thanks, Curns.
  8. Hi All, Please excuse my lack of understanding, I have a question regarding application deployment and removal using sccm 2012 sp1. I want to make available an application to all users, so if they want it, they can simply browse to the application catalog and install it. For example, Visio 2010. To do this, I know I can simply create a deployment to the all users collection. Lets say I have 100 Visio licenses, and after an audit we find there are 105 installs. I want to uninstall the application (using sccm) from 20 machines that don't need it anymore. So what I thought I could do was create a new collection called 'visio uninstall', and then manually add the machines to this collection. Create a new deployment and select the uninstall option and target it to this collection. When I tested this scenario the uninstall did not run because of "Rule is in conflict with other rules". It conflicts with my visio install deployment which is targeted at all users. So my question is, what is the best way to tackle this? Is it even possible? I would prefer to deploy to "users" rather than devices so they can use the application catalog. Am I better to deploy applications to devices only and create 2 collections, one for install and one for uninstall. The problem I have with this is every time a new machine is joined to the domain I have to add the machine to the collection, or have a membership rule which automatically adds it. But then I've gone full circle because it is a member of the install group Thanks, Curns.
  9. Just thought I would update this thread in case anyone else reads this. I think the issue is related to using https and it seems the windows update method was trying to use http for some reason. The log shows: HTTP is selected for Client. The current state is 0 I was able to manually install the client by running the command: C:\Windows\SoftwareDistribution\Download\Install>ccmsetup /usePKICert /mp:HTTPS://sccm-server01 SMSSITECODE=ABC I the end, I enabled the client push installation method and it successfully deployed to all my workstations (after applying a group policy to open file & print and WMI ports for windows firewall, see http://technet.microsoft.com/en-us/library/bb694088.aspx) Curns.
  10. Hi Again, I've tried ccmsetup /uninstall but it was not doing anything! So I ran the old ccmclean /all tool on the workstation. (I know it is not supported). The old client is now uninstalled. I renamed the softwareDistribution folder to .old and tried again. Getting the same error: Current directory 'C:\Windows\SoftwareDistribution\Download\Install' is not a valid source location. No valid source or MP locations could be identified to download content from. Ccmsetup.exe cannot continue. ccmsetup.log: ==========[ ccmsetup started in process 4748 ]========== ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Running on platform X64 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Updated security on object C:\Windows\ccmsetup\cache\. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Launch from folder C:\Windows\SoftwareDistribution\Download\Install\ ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CcmSetup version: 5.0.7804.1000 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Running on OS (6.1.7601). Service Pack (1.0). SuiteMask = 256. Product Type = 1 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Ccmsetup command line: "C:\Windows\SoftwareDistribution\Download\Install\ccmsetup.exe" ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Local Machine is joined to an AD domain ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Current AD forest name is contoso.com, domain name is contoso.com ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Domain joined client is in Intranet ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) DhcpGetOriginalSubnetMask entry point is supported. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Begin checking Alternate Network Configuration ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Finished checking Alternate Network Configuration ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Adapter {A686B2C1-EEF1-421E-9A82-4C887789A921} is DHCP enabled. Checking quarantine status. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Current AD site of machine is Site1 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Attempting to query AD for assigned site code ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Performing AD query: '(&(ObjectCategory=MSSMSRoamingBoundaryRange)(|(&(MSSMSRangedIPLow<=175768123)(MSSMSRangedIPHigh>=175768123))(&(MSSMSRangedIPLow<=3232249857)(MSSMSRangedIPHigh>=3232249857))))' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Performing AD query: '(&(ObjectCategory=mSSMSSite)(|(mSSMSRoamingBoundaries=10.122.0.0)(mSSMSRoamingBoundaries=192.168.56.0)(mSSMSRoamingBoundaries=Site1)(mSSMSSiteCode=ABC)))' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) LSIsSiteCompatible : Verifying Site Compatibility for <ABC> ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Current AD forest name is contoso.com, domain name is contoso.com ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Domain joined client is in Intranet ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) LSGetSiteVersionFromAD : Attempting to query AD for MPs for site 'ABC' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Performing AD query: '(&(ObjectCategory=mSSMSManagementPoint)(mSSMSSiteCode=ABC))' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) LSGetSiteVersionFromAD : Successfully retrieved version '5.00.7804.1000' for site 'ABC' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) LSIsSiteCompatible : Site Version = '5.00.7804.1000' Site Capabilities = <Capabilities SchemaVersion="1.0"><Property Name="SSL" Version="1"/><Property Name="SSLState" Value="63"/></Capabilities> ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) LSIsSiteVersionCompatible : Site Version '5.00.7804.1000' is compatible. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) LSIsSiteCompatible : Site <ABC> Version '5.00.7804.1000' is compatible. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) LSGetAssignedSiteFromAD : Trying to Assign to the Site <ABC> ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Got site code 'ABC' from AD. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Performing AD query: '(&(ObjectCategory=mSSMSManagementPoint)(mSSMSDefaultMP=TRUE)(mSSMSSiteCode=ABC))' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) OperationalXml '<ClientOperationalSettings><Version>5.00.7804.1000</Version><SecurityConfiguration><SecurityModeMask>63</SecurityModeMask><SecurityModeMaskEx>63</SecurityModeMaskEx><HTTPPort>80</HTTPPort><HTTPSPort>443</HTTPSPort><CertificateStoreName></CertificateStoreName><CertificateIssuers>CN=CA-SERVER; DC=contoso; DC=com</CertificateIssuers><CertificateSelectionCriteria></CertificateSelectionCriteria><CertificateSelectFirstFlag>1</CertificateSelectFirstFlag><SiteSigningCert>30820305308201EDA0030201020210150E25BC7002F1A54A175086DAB426CC300D06092A864886F70D01010B05003016311430120603550403130B53697465205365727665723020170D3133303231313232323933305A180F32313133303131393232323933305A3016311430120603550403130B536974652053657276657230820122300D06092A864886F70D01010105000382010F003082010A02820101009E00430F06414C5D35833448E88136BD66B9CFF2438D8356CCFFF23420507D697780208315A13E5CDDB5240AC4EF49A7AC72DBCB4E465166297DD61618AF9032F0B4B6D776D8E4FE2B44E7B55EEC3506AB04E056ED45DE1ED1B0AFB476412228E7325B54E51054FDD2DE64C866F4EF78332D2218B7C2EE2B03CCEE5A0E3B7BBCB16EC0A9717F77C65394925DA42CE1BA24760F5808E1C9DDAFAE97DE3AB87852F743B54F5D7253D869C4BEFCAB63F85BA83D0BA6B6825166C97CC115758CFECCFB20286E364F15255E868E727C9878BA9E9FBB1D72FD8C1A2A6719D97EF813F989E7D80FC3029664C28CB4F7A9B210B0DB6F53BC2E885A5CC7652685DC9FB9930203010001A34D304B30330603551D11042C302A82287072642D7065722D7363636D30312E617061632E62697263686D616E67726F75702E636F6D2E617530140603551D25040D300B06092B060104018237650B300D06092A864886F70D01010B05000382010100011B194CC1C20055DF958EC1AD5695D48791FACF786842AFC2219D434D0A0D6AD39B896B208E72D3DF9AB3159015BD2C3CCC4B82FD89D7FD9E16D0802E51D7EE7C35840629395F416EDF2FAFB8449780D73F083D269F1034CAC20BDF738A60A098D0463D271CADC3ED039CFAB59DED80497BE9D66F74074F395E712D59FC84E16ED147A00D73C7051CD05641592EB44BCE9408EBCF897FF287ABDECA7965FFA926FA9E71F3D9A47E2DCD1F50576397CDED204B722FF43E78BAC212200CE74E611FAC6F7E5B0E889DE4639224A0C274C00E47BFCB62ECE7C77CAEFB611653E8FCAC61E2FBBCBB84F72813BA4CF4D6AE50F82A0EA7D876FADE0939765A52EA90CD</SiteSigningCert></SecurityConfiguration><RootSiteCode>ABC</RootSiteCode><CCM> <CommandLine>SMSSITECODE=ABC</CommandLine> </CCM><FSP> <FSPServer>sccm-server01.contoso.com</FSPServer> </FSP><Capabilities SchemaVersion ="1.0"><Property Name="SSL" Version="1" /><Property Name="SSLState" Value="63" /></Capabilities><Domain Value="contoso.com" /><Forest Value="contoso.com" /></ClientOperationalSettings>' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) HTTP is selected for Client. The current state is 0. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) The MP name retrieved is 'sccm-server01.contoso.com' with version '7804' and capabilities '<Capabilities SchemaVersion="1.0"><Property Name="SSL" Version="1"/><Property Name="SSLState" Value="63"/></Capabilities>' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) MP 'sccm-server01.contoso.com' is not compatible ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Retrieved 0 MP records from AD for site 'ABC' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) FromAD: FSP = sccm-server01.contoso.com ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) FromAD: command line = SMSSITECODE=ABC ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Current AD forest name is contoso.com, domain name is contoso.com ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Domain joined client is in Intranet ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CMPInfoFromADCache requests are throttled for 00:59:59 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) SslState value: 255 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Ccmsetup was run without any user parameters specified. Running without registering ccmsetup as a service. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Detected sitecode 'ABC' from AD. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CCMHTTPPORT: 80 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CCMHTTPSPORT: 443 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CCMHTTPSSTATE: 255 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CCMHTTPSCERTNAME: ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) FSP: sccm-server01.contoso.com ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CCMCERTISSUERS: CN=CA-SERVER; DC=contoso; DC=com ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CCMFIRSTCERT: 1 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) No MP or source location has been explicitly specified. Trying to discover a valid content location... ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Looking for MPs from AD... ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CMPInfoFromADCache requests are throttled for 00:59:59 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) FromAD: FSP = sccm-server01.contoso.com ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) FromAD: command line = SMSSITECODE=ABC ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Current AD forest name is contoso.com, domain name is contoso.com ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Domain joined client is in Intranet ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) CMPInfoFromADCache requests are throttled for 00:59:59 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Current directory 'C:\Windows\SoftwareDistribution\Download\Install' is not a valid source location. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) No valid source or MP locations could be identified to download content from. Ccmsetup.exe cannot continue. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Failed to parse '"C:\Windows\SoftwareDistribution\Download\Install\ccmsetup.exe" ' with error 0x80004005 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Sending Fallback Status Point message to 'sccm-server01.contoso.com', STATEID='100'. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Failed to get client version for sending messages to FSP. Error 0x8004100e ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Params to send FSP message '5.0.7804.1000 Deployment ' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) State message with TopicType 800 and TopicId {1006FF85-C847-495B-80B1-DAC117FA53C7} has been sent to the FSP FSPStateMessage 21/02/2013 12:00:54 PM 2028 (0x07EC) Sending Fallback Status Point message to 'sccm-server01.contoso.com', STATEID='307'. ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Failed to get client version for sending messages to FSP. Error 0x8004100e ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) Params to send FSP message '5.0.7804.1000 Deployment "C:\Windows\SoftwareDistribution\Download\Install\ccmsetup.exe" ' ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) State message with TopicType 800 and TopicId {82D8AF65-E9AD-462A-9C76-0DB73E41BD2A} has been sent to the FSP FSPStateMessage 21/02/2013 12:00:54 PM 2028 (0x07EC) CcmSetup failed with error code 0x80004005 ccmsetup 21/02/2013 12:00:54 PM 2028 (0x07EC) I don't understand why it is not working. It works fine on newly built machines which have never had the client installed before. Thanks, curns.
  11. Hi All, Firstly, thanks for the guides they are a huge help. I've just set up a new Windows Server 2012 server and installed SCCM 2012 SP1 with all roles except SQL. I've enabled the Software Update-Based Client Installation and it successfully installs on my test clients. Everything was going well until I noticed the client is failing to install on a lot of workstations. It seems to be workstations that have already got an older version of the client installed. The ccmsetup.log shows: ... HTTP is selected for Client. The current state is 0. ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) The MP name retrieved is 'sccm-server01.contoso.com' with version '7804' and capabilities '<Capabilities SchemaVersion="1.0"><Property Name="SSL" Version="1"/><Property Name="SSLState" Value="63"/></Capabilities>' ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) MP 'sccm-server01.contoso.com' is not compatible ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Retrieved 0 MP records from AD for site 'ABC' ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) FromAD: command line = SMSSITECODE=ABC ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Current AD forest name is contoso.com, domain name is contoso.com ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Domain joined client is in Intranet ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CMPInfoFromADCache requests are throttled for 01:00:00 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) SslState value: 255 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Ccmsetup was run without any user parameters specified. Running without registering ccmsetup as a service. ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Detected sitecode 'ABC' from AD. ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CCMHTTPPORT: 80 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CCMHTTPSPORT: 443 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CCMHTTPSSTATE: 255 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CCMHTTPSCERTNAME: ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) FSP: ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CCMCERTISSUERS: CN=CA-SERVER; DC=contoso; DC=com ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CCMFIRSTCERT: 1 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) No MP or source location has been explicitly specified. Trying to discover a valid content location... ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Looking for MPs from AD... ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CMPInfoFromADCache requests are throttled for 01:00:00 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) FromAD: command line = SMSSITECODE=ABC ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Current AD forest name is contoso.com, domain name is contoso.com ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Domain joined client is in Intranet ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CMPInfoFromADCache requests are throttled for 01:00:00 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Current directory 'C:\Windows\SoftwareDistribution\Download\Install' is not a valid source location. ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) No valid source or MP locations could be identified to download content from. Ccmsetup.exe cannot continue. ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) Failed to parse '"C:\Windows\SoftwareDistribution\Download\Install\ccmsetup.exe" ' with error 0x80004005 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) A Fallback Status Point has not been specified. Message with STATEID='100' will not be sent. ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) A Fallback Status Point has not been specified. Message with STATEID='307' will not be sent. ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) CcmSetup failed with error code 0x80004005 ccmsetup 20/02/2013 9:35:31 PM 4732 (0x127C) My guess is the old 2007 client is some how causing the issue. The bit I've highlighted orange seems to suggest that. We had a 2007 sccm server on another domain. The workstations were migrated to a new domain and thus why I am setting up a new 2012 server. I tried running ccmsetup /uninstall and then let windows update attempt to install the new version but the same error occurs. Desperate for help! Thanks, Curns
×
×
  • Create New...