Jump to content


Gar

Reporting Subscriptions Failing

Recommended Posts

I posted this issue yesterday on Technet without much feedback that was of help, so i'm trying my luck here!

 

http://social.technet.microsoft.com/Forums/systemcenter/en-US/22a434c3-c5d9-4d93-824c-7b4b0d9bc87f/reporting-subscriptions-failing-failure-sending-mail-must-be-something-obvious?forum=configmanagergeneral&prof=required

 

To summarise, I've created a report subscription which constantly fails with the Client was not authenticated, here's what I have done to try and resolve this issue:

 

 

  • SCCM - Email Notification Component is configured correctly. The SMTP test works and I also receive alerts when one of my SCEP rules are triggered.
  • SQL Management Studio - DataBase Mail is configured; sending a test e-mail works. Using Basic Authentication with a network account specified.
  • Exchange 2010 has a Receiver Connector created to relay e-mails from the SCCM Server.
  • Reporting Services Configuration Manager - Email Section has been completed.
  • The SSRS Service is using a domain account with has an associated e-mail address and mailbox.
  • Tried using anonymous authentication set on the Database Mail and also on the Exchange Receiver Connector - this actually stops Database Mail from from working.

I'm under the impression that if SSRS can send out test e-mails successfully, then SCCM should also work, as SCCM just uses SSRS to fire off those reports i'm subscribing to?

I've attached the screenshots of the various configurations within SCCM and also SQL 2012.

 

I've been bashing my head on this one for hours without any progress, so any advice is welcome!

 

post-19781-0-31726700-1403696989_thumb.jpg

Share this post


Link to post
Share on other sites


Jason is right you are comparing apples and oranges.

 

SSRS does not use SQL mail

CM12 Alerts and SSRS report are not the same thing and doesn’t use the same method to send emails

This is clearly as Exchange issue.

 

Why do you think that SSRS can send test message, where did you do this action?

Have you review the Exchange server logs to see why the email has been rejected?

Share this post


Link to post
Share on other sites

Hi Garth,

 

Thanks for the response. I was under the impression that CM12 uses SSRS (and thus the SQL Mail configuration) to send out the Subscription Reports, if that is definitely not the case I can eliminate that part from my configuration all together.

 

So, to clarify:

 

CM12 Alerts have always been working fine - no issue here and I understand this is a different kettle of fish to SSRS.

 

Why do you think that SSRS can send test message, where did you do this action?

 

I actioned the "Send Test E-mail" option when you right-click on the Database Mail option within SQL2012. However, as you pointed out already, if this has absolutely nothing to do with the Subscription Reports configuration, then this is no longer relevant. If anything it just proves that e-mails can be sent via the Exchange server (using basic authentication).

 

Now, I guess, I just need to figure what within SSRS Configuration Manager is missing, my trouble is that there isn't any detailed settings I can configure and Exchange logs doesn't indicate anything that isn't already reported by SCCM:

 

2014-06-25T14:09:14.168Z,Exchange\SCCM01 - Subscription Reports Receiver,08D15B57A7508DA3,21,10.2.2.202:25,10.2.2.213:63905,>,530 5.7.1 Client was not authenticated,

post-19781-0-95192000-1403705913_thumb.jpg

Share this post


Link to post
Share on other sites

You need to setup "relaying" or unauthentic email sending on your Exchange server. Once that is done everything will work great.

Share this post


Link to post
Share on other sites

Someone else figured out my miconfiguration in the original technet thread, i've marked it as answered.

 

How have you configured the Receive Connector? For SSRS create a Receive Connector as follows:

In Network tab, add the IP address of the SSRS server

In Authentication tab, only select the option "Externally Secured".

In permission groups tab, select all items.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...