Jump to content




Sign in to follow this  
anyweb

Why do I get a winload.efi (Status: 0xc0000359 error) when using UEFI network boot in System Center 2012 R2 Configuration Manager ?



Recommended Posts

Introduction

More and more UEFI based hardware is being used in organizations and these UEFI based systems are being imaged via UEFI network boot via Configuration Manager 2012 R2.

Problem

Up until the introduction of UEFI hardware, most organizations use 32 bit (x86) boot images to deploy both 32bit and 64 bit operating systems. UEFI hardware however requires a 64 bit boot wim and if you UEFI network boot this hardware in an environment that responds with a 32bit boot image, you’ll see the following error

 

File: \Windows\System32\boot\winload.efi Status: 0xc0000359

 

 

as shown in the screenshot below

 

0xc0000359.png

Solution

There are a few solutions to this problem, but basically all involve the same thing, make sure that the task sequence that ‘answers’ your UEFI hardware, contains a 64 bit boot image as shown below

 

64-bit-boot-wim.png

 

 

In general, the task sequence that answers is the last task sequence deployed to the collection that your computer you are booting is a member of.

 

You can either add the computer in question (computer+mac address) to a collection that has a task sequence deployed to it with a 64bit boot image or re-deploy a task sequence with a 64 bit boot image to the collection that this computer is a member of, or change the current task sequence to use a 64 bit boot wim instead of a x86 bit boot wim.

 

TiP: If you cannot make a change to any of the UEFI Network deployments then another idea is to use usb or ISO based Standalone or boot media containing the 64bit boot image.

 

Be aware that changing the architecture of your boot wim may cause some executables to fail to run in Windows PE as the ‘subsystem’ in WinPE will have changed architecture from 32bit to 64bit. This also means that you can only install a 64 bit operating system using this boot image.

 

“To install Windows to an EFI-based computer, you must enable EFI mode in the computer’s firmware and boot with 64-bit pre-installation media. ” – source, Technet.

 

Once you’ve made the changes above, UEFI network boot a client computer again, and you should see it’s using the boot.wim file (package ID) that you attached to the task sequence, in this case it’s using a 64bit boot wim (P0100002.wim)

 

UEFI-network-boot.png

 

as you can see here…

 

P0100002.png

 

The end result, is a working UEFI network boot !

 

UEFI-network-boot-working.png

 

cheers

niall

 

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×