Jump to content


Application deployment fails on 1st attempt, successful on 2nd - Exit Code 16389

Recommended Posts


I'm looking for some advice on a problem I am having when trying to deploy an application that has dependencies on other applications. Please bear with me while I try to explain the problem.

I am trying to deploy an application called SAP, that has a dependency on 2 other applications - .net Framework and Visual C++ Redist. When the application is deployed, if it detects if one of the 2 other apps are missing and then it will automatically deploy those first.

If I deploy SAP to a client that has both dependencies, the deployment works fine. If i deploy to a client that does not have .net installed the deployment fails with exit code 16389.

After some research I discovered that i need to change the deployment setting to "run installation and uninstall program as 32-bit processes on 64-bit clients". This now seems to get further but is still failing.

I'm deploying SAP and using notifications in Software Centre to monitor the deployment. The packages are downloaded successfully, it detects that .net framework isn't installed, but as soon as it tries to deploy .net it fails again with exit code 16389. However, if i then click "retry" within Software Centre the entire deployment works fine - .net and SAP installation!

When I look through the appenforce.log file i can see both attempts at the deployment, the 1st with the error exit code, and the second one going through fine. The only differences that i can see between them in the log file are the session ID's:

The 1st attempt session ID is 4294967295

The 2nd attempt session ID is 1

Any idea why this would be happening? I've attached some screenshots if that helps at all.

Thanks in advance








Share this post

Link to post
Share on other sites

If I run the following manually it works fine:


NDP452-KB2901907-x86-x64-AllOS-ENU.exe /q /norestart /ChainingPackage ADMINDEPLOYMENT


Seems to be only via SCCM deployment thats having a problem.


I also get the same error if i deploy the application for .net only, and not as a dependency for SAP

Share this post

Link to post
Share on other sites

Notice something else now...


If i make the application available to the client, and then click install from software centre, the application deploys and installs ok


If I make it required, it fails, and then only works if i click retry in software centre

Share this post

Link to post
Share on other sites

Is there anything the netframework installation logs, normally there here:


“%temp%\Microsoft .NET Framework 4.5*.txt”

“%temp%\Microsoft .NET Framework 4.5*.html”
This might help you to see what's going on.

Share this post

Link to post
Share on other sites

I've tried a few options now:


  1. Expanding the .net package, and then re-zipping it as a self-extracting .exe. I then created a bat file to expand the file, install .net, and then delete the expanded files. This installed .net but SCCM returns a failed code
  2. Then I tried writing an AutoIT script to expand the files and install, but after it expands SCCM fails stating that an installation is already in progress
  3. Finally, i tried writing an AutoIT script that installs from the normal .net install file. Like above, this installed .net successfully but SCCM returns a failed code as it can't detect the installation after completion. I've double checked the Detection Rule is correct, and the registry key is in place after the installation, so I don't know why its not working

Any ideas?

Share this post

Link to post
Share on other sites

I've noticed that whenever i try any other install option other than the standard NDP452-KB2901907-x86-x64-AllOS.exe the installation is successful, but SCCM reports it as failed as it can't detect the program.


I thought that the detection method was only used before the installation takes place? I've double checked my detection rule and it seems to be correct, and indeed after the installation completes the registry that its looking for is in place.


Any other ideas?


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...