Jump to content


Task Sequence error running from USB Media

Recommended Posts

The MS Consultant who was on site a couple weeks ago, helped us create OS and boot images for several Windows OS's. We tested the image on a VM and it built just fine.


I downloaded the drivers for the Dell Optiplex 7040, 5040 and 3020 models and created task sequence media to install Windows 7 Enterprise on a Dell on USB and keep getting the following error when I try to use it to install an OS. The specific computer that I'm trying this on is the OptiPlex 7040.


"failed to find a valid network adapter......".


I followed technet article https://technet.microsoft.com/en-us/library/hh301101.aspx. I completed the following steps:


imported the drivers for the computer models in question,

created a driver package,

updated the distribution point with the drive package,

confirmed that the boot image has the drivers included in it

updated the distribution point for the boot image

created the Task Sequence Media for 'Bootable, site-based USB Media'.


I've repeated the process three or four times, all with the same result.


Any suggestions other than 'fall on your sword', would be GREATLY appreciated.



Share this post

Link to post
Share on other sites



You'll need the Windows 10 nic driver for this. Regardless of what OS you are deploying, as this is the WinPE version.


Download that from Dell and as a quick test, copy it to the usb boot media, then at the TS wizard screen press f8 for command prompt. You can then run drvload and point it to the nic driver you copied. It will then give you an IP address. Once confirmed it works add to sccm and your boot wim and recreate the boot media.

Share this post

Link to post
Share on other sites

As TK mentioned you need to add the NIC driver, I did a quick blog a while ago for doing it for 8.1 but obviously you'll need to update this for windows 10




dell do a winpe driver cab for os deployment which is what I'd look at adding



Share this post

Link to post
Share on other sites

Got it figured out. I downloaded the driver package from Dell for the model in question. However the Dell computer DID NOT like the Dell-provided re-branded network driver that 'should' have worked. So, I had to download Intel's native driver and that worked right out of the gate.



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...