Jump to content


Robbie Wallis

Issue with some clients not getting site code

Recommended Posts

have an issue whereby sometimes a deployment fails midway due to a mistake my end! and it seems that some clients are left unmanaged(no site code assigned). I can always fix the failed deployment by sending the remaining task sequence items to the PC's(or reimage if time) but with clients not assigned it makes more difficult(not the ideal situation but sometimes time is very short).

If I log onto the PC as an admin and click the find site button in the client control panel it finds it. If I leave it to its own devices or use console extensions it fails

 

I have checked locationservices.log and it appears things are failing(< ![LOG[hr = spSearch->GetFirstRow(hSearch), HRESULT=80072020). LDAP queries produce correct results if manually run against AD

 

<![LOG[Executing Location Service PreStartup task ***]LOG]!><time="11:11:49.312+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="5524" file="lsprestartuptask.cpp:110">
< ![LOG[Registered for event SiteRoleCycleEvent.]LOG]!><time="11:11:49.312+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="5524" file="lsprestartuptask.cpp:160">
< ![LOG[LSRefreshSiteCode]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="3952" file="lsad.cpp:3916">
< ![LOG[LSGetGPSiteCode]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="3952" file="lsad.cpp:5914">
< ![LOG[regKey.GetString( L"GPRequestedSiteAssignmentCode", sSiteCode ), HRESULT=80070002 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,5925)]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="3952" file="lsad.cpp:5925">
< ![LOG[LSGetGPSiteCode: Site Assignment Code not defined in Group Policy Registry key [software\Microsoft\SMS\Mobile Client] (80070002)]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="3952" file="lsad.cpp:5941">
< ![LOG[ProcessPendingSiteAssignment]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="3952" file="lsad.cpp:3758">
< ![LOG[No pending site assignments]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="3952" file="lsad.cpp:3768">
< ![LOG[LSGetAutoAssignFlagFromWMI]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="3952" file="lsad.cpp:4064">
< ![LOG[LSGetSiteCodeFromWMI]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="3952" file="lsad.cpp:1497">
< ![LOG[spEnum.Next(&spConfig) == S_OK, HRESULT=00000001 (e:\nts_sccm_release\sms\framework\smscore\smsutil.cpp,70)]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="3952" file="smsutil.cpp:70">
< ![LOG[sMS_Authority not configured]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="2" thread="3952" file="smsutil.cpp:70">
< ![LOG[LSGetSiteCodeFromWMI : Site code returned from WMI is <>]LOG]!><time="11:11:51.531+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="3952" file="lsad.cpp:1503">
< ![LOG[LSGetSiteCodeFromWMI]LOG]!><time="11:12:08.767+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="900" file="lsad.cpp:1497">
< ![LOG[spEnum.Next(&spConfig) == S_OK, HRESULT=00000001 (e:\nts_sccm_release\sms\framework\smscore\smsutil.cpp,70)]LOG]!><time="11:12:08.767+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="900" file="smsutil.cpp:70">
< ![LOG[sMS_Authority not configured]LOG]!><time="11:12:08.767+00" date="10-30-2016" component="LocationServices" context="" type="2" thread="900" file="smsutil.cpp:70">
< ![LOG[LSGetSiteCodeFromWMI : Site code returned from WMI is <>]LOG]!><time="11:12:08.767+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="900" file="lsad.cpp:1503">
< ![LOG[LSGetAssignedSiteFromDirectories]LOG]!><time="11:12:08.892+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:1978">
< ![LOG[LSGetGPSiteCode]LOG]!><time="11:12:08.892+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:5914">
< ![LOG[regKey.GetString( L"GPRequestedSiteAssignmentCode", sSiteCode ), HRESULT=80070002 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,5925)]LOG]!><time="11:12:08.892+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:5925">
< ![LOG[LSGetGPSiteCode: Site Assignment Code not defined in Group Policy Registry key [software\Microsoft\SMS\Mobile Client] (80070002)]LOG]!><time="11:12:08.892+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:5941">
< ![LOG[Attempting to get assigned site from lookup MP(s) via HTTPS]LOG]!><time="11:12:08.892+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lssecurity.cpp:6208">
< ![LOG[LSGetLookupMP]LOG]!><time="11:12:08.892+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2325">
< ![LOG[LSGetInternetMode]LOG]!><time="11:12:08.892+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:4964">
< ![LOG[LSGetInternetMode: In Intranet]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:5013">
< ![LOG[LSGetADForestAndDomainName]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:821">
< ![LOG[LSJoinedToADDomain]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:709">
< ![LOG[Local Machine is joined to an AD domain]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:732">
< ![LOG[Current AD forest name is empire.xxxx.ac.uk, domain name is empire.xxxx.ac.uk]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:860">
< ![LOG[LSGetHomeMPFromWMI]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:1627">
< ![LOG[spEnum.Next(&spObject) == WBEM_S_NO_ERROR, HRESULT=80004005 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,1641)]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:1641">
< ![LOG[LSGetLookupMPFromRegistry]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2540">
< ![LOG[0 < sManagementPoint.length(), HRESULT=80004005 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,2558)]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2558">
< ![LOG[LSGetLookupMPFromRegistry: Failed to get MP from Registry (80004005)]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:2568">
< ![LOG[Attempting to retrieve lookup MP(s) from AD]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:2379">
< ![LOG[LSGetManagementPointsForSiteFromAD]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:3192">
< ![LOG[CCMGetGlobalService(&spService), HRESULT=87d00219 (e:\cm1606_rtm\sms\framework\core\ccmcore\ccmconditions.cpp,39)]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="ccmconditions.cpp:39">
< ![LOG[LSGetADForestAndDomainName]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:821">
< ![LOG[Current AD forest name is empire.xxxx.ac.uk, domain name is empire.xxxx.ac.uk]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:860">
< ![LOG[Domain joined client is in Intranet]LOG]!><time="11:12:08.907+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:1089">
< ![LOG[Performing AD query: '(&(ObjectCategory=mSSMSManagementPoint)(mSSMSDefaultMP=TRUE)(mSSMSVersion>=8200))']LOG]!><time="11:12:08.923+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:674">
< ![LOG[hr = spSearch->GetFirstRow(hSearch), HRESULT=80072020 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,3216)]LOG]!><time="11:12:08.923+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:3216">
< ![LOG[No lookup MP(s) from AD]LOG]!><time="11:12:08.923+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:2411">
< ![LOG[LSWinsResolveSMSNameEx]LOG]!><time="11:12:08.923+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lswins.cpp:433">
< ![LOG[HTTP is selected for Client. The current state is 0.]LOG]!><time="11:12:08.923+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="ccmutillib.cpp:438">
< ![LOG[using WSAEnumProtocols to get all active LANAs
]LOG]!><time="11:12:08.923+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lswins.cpp:157">
< ![LOG[Attempting to resolve 'SMS_SLP' with 25 suffix from WINS]LOG]!><time="11:12:08.923+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lswins.cpp:382">
< ![LOG[Attempting to find 'SMS_SLP' with 25 suffix on LANA 2 from WINS]LOG]!><time="11:12:08.923+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lswins.cpp:386">
< ![LOG[Failed to resolve 'SMS_SLP' from WINS]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="2" thread="4560" file="lswins.cpp:472">
< ![LOG[No lookup MP(s) from WINS]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:2472">
< ![LOG[unable to find lookup MP(s) in Registry, AD, DNS and WINS]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="3" thread="4560" file="lsad.cpp:2484">
< ![LOG[((HRESULT) (((unsigned long)(1)<<31) | ((unsigned long)(0x7D0)<<16) | ((unsigned long)(0x0301))) ), HRESULT=87d00301 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,2485)]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2485">
< ![LOG[LSGetLookupMP(L"", saMPList, bTriedAD, managementPointRecordArrayFromAD), HRESULT=87d00301 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lssecurity.cpp,6212)]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lssecurity.cpp:6212">
< ![LOG[CCMGetGlobalService(&spService), HRESULT=87d00219 (e:\cm1606_rtm\sms\framework\core\ccmcore\ccmconditions.cpp,39)]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="ccmconditions.cpp:39">
< ![LOG[LSGetADForestAndDomainName]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:821">
< ![LOG[Current AD forest name is empire.xxxx.ac.uk, domain name is empire.xxxx.ac.uk]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:860">
< ![LOG[Domain joined client is in Intranet]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:1089">
< ![LOG[LSGetAssignedSiteFromAD]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2080">
< ![LOG[DhcpGetOriginalSubnetMask entry point is supported.]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="ccmiputil.cpp:117">
< ![LOG[begin checking Alternate Network Configuration]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="ccmiputil.cpp:1095">
< ![LOG[Finished checking Alternate Network Configuration]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="ccmiputil.cpp:1172">
< ![LOG[Adapter {6587E23E-E4CB-409E-BBC6-16012ABD786A} is DHCP enabled. Checking quarantine status.]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="ccmiputil.cpp:436">
< ![LOG[LSGetADSiteName]LOG]!><time="11:12:13.423+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:772">
< ![LOG[Current AD site of machine is Rochford]LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:788">
< ![LOG[Attempting to query AD for assigned site code]LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2099">
< ![LOG[Performing AD query: '(&(ObjectCategory=MSSMSRoamingBoundaryRange)(|(&(MSSMSRangedIPLow<=2886732516)(MSSMSRangedIPHigh>=2886732516))))']LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:674">
< ![LOG[hr = spSearch->GetFirstRow(hSearch), HRESULT=80072020 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,2110)]LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2110">
< ![LOG[Attempting to get assigned site from lookup MP(s) via HTTP]LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lssecurity.cpp:6208">
< ![LOG[LSGetLookupMP]LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2325">
< ![LOG[LSGetInternetMode]LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:4964">
< ![LOG[LSGetInternetMode: In Intranet]LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:5013">
< ![LOG[LSGetADForestAndDomainName]LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:821">
< ![LOG[LSGetHomeMPFromWMI]LOG]!><time="11:12:13.548+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:1627">
< ![LOG[spEnum.Next(&spObject) == WBEM_S_NO_ERROR, HRESULT=80004005 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,1641)]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:1641">
< ![LOG[LSGetLookupMPFromRegistry]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2540">
< ![LOG[0 < sManagementPoint.length(), HRESULT=80004005 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,2558)]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2558">
< ![LOG[LSGetLookupMPFromRegistry: Failed to get MP from Registry (80004005)]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:2568">
< ![LOG[Attempting to retrieve lookup MP(s) from AD]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:2379">
< ![LOG[LSGetManagementPointsForSiteFromAD]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:3192">
< ![LOG[CCMGetGlobalService(&spService), HRESULT=87d00219 (e:\cm1606_rtm\sms\framework\core\ccmcore\ccmconditions.cpp,39)]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="ccmconditions.cpp:39">
< ![LOG[LSGetADForestAndDomainName]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:821">
< ![LOG[Current AD forest name is empire.xxxx.ac.uk, domain name is empire.xxxx.ac.uk]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:860">
< ![LOG[Domain joined client is in Intranet]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:1089">
< ![LOG[Performing AD query: '(&(ObjectCategory=mSSMSManagementPoint)(mSSMSDefaultMP=TRUE)(mSSMSVersion>=8200))']LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:674">
< ![LOG[hr = spSearch->GetFirstRow(hSearch), HRESULT=80072020 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,3216)]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:3216">
< ![LOG[No lookup MP(s) from AD]LOG]!><time="11:12:13.564+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:2411">
< ![LOG[LSWinsResolveSMSNameEx]LOG]!><time="11:12:13.579+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lswins.cpp:433">
< ![LOG[using WSAEnumProtocols to get all active LANAs
]LOG]!><time="11:12:13.579+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lswins.cpp:157">
< ![LOG[Attempting to resolve 'SMS_SLP' with 25 suffix from WINS]LOG]!><time="11:12:13.579+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lswins.cpp:382">
< ![LOG[Attempting to find 'SMS_SLP' with 25 suffix on LANA 2 from WINS]LOG]!><time="11:12:13.579+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lswins.cpp:386">
< ![LOG[Failed to resolve 'SMS_SLP' from WINS]LOG]!><time="11:12:18.080+00" date="10-30-2016" component="LocationServices" context="" type="2" thread="4560" file="lswins.cpp:472">
< ![LOG[No lookup MP(s) from WINS]LOG]!><time="11:12:18.080+00" date="10-30-2016" component="LocationServices" context="" type="1" thread="4560" file="lsad.cpp:2472">
< ![LOG[unable to find lookup MP(s) in Registry, AD, DNS and WINS]LOG]!><time="11:12:18.080+00" date="10-30-2016" component="LocationServices" context="" type="3" thread="4560" file="lsad.cpp:2484">
< ![LOG[((HRESULT) (((unsigned long)(1)<<31) | ((unsigned long)(0x7D0)<<16) | ((unsigned long)(0x0301))) ), HRESULT=87d00301 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,2485)]LOG]!><time="11:12:18.080+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2485">
< ![LOG[LSGetLookupMP(L"", saMPList, bTriedAD, managementPointRecordArrayFromAD), HRESULT=87d00301 (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lssecurity.cpp,6212)]LOG]!><time="11:12:18.080+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lssecurity.cpp:6212">
< ![LOG[3 == sSMSAssignedSite.length(), HRESULT=8000ffff (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsad.cpp,2022)]LOG]!><time="11:12:18.080+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsad.cpp:2022">
< ![LOG[CCM::LocationServices::LSGetAssignedSiteFromDirectories( sSmsSite), HRESULT=8000ffff (e:\nts_sccm_release\sms\framework\locationservices\lsutilities\lsexports.cpp,142)]LOG]!><time="11:12:18.080+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="4560" file="lsexports.cpp:142">
< ![LOG[LSGetSiteCodeFromWMI]LOG]!><time="11:12:18.267+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="900" file="lsad.cpp:1497">
< ![LOG[spEnum.Next(&spConfig) == S_OK, HRESULT=00000001 (e:\nts_sccm_release\sms\framework\smscore\smsutil.cpp,70)]LOG]!><time="11:12:18.267+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="900" file="smsutil.cpp:70">
< ![LOG[sMS_Authority not configured]LOG]!><time="11:12:18.267+00" date="10-30-2016" component="LocationServices" context="" type="2" thread="900" file="smsutil.cpp:70">
< ![LOG[LSGetSiteCodeFromWMI : Site code returned from WMI is <>]LOG]!><time="11:12:18.267+00" date="10-30-2016" component="LocationServices" context="" type="0" thread="900" file="lsad.cpp:1503">

 

DNS Record exists

 

 

System Management record exists

 

 

Boundaries are set as AD sites, IP Range and subnet

 

Any ideas?

 

Robbie

 

post-4196-0-50841600-1477835254.png

post-4196-0-98644300-1477835261.png

Share this post


Link to post
Share on other sites


When you re-push them do you tell the client what site to be assigned to? 90% of the time it is a boundary issue. are you using IP Ranges only? if not exactly what is the IP and subnet mask of the client and What boundaries are you using and which one do you think it should be assigned too?

Share this post


Link to post
Share on other sites

I tell AD Discovery to create the boundaries which is AD Site and IP Range(I've done away with subnet for now)

 

IP Is 172.16.12.228

 

Boundary is 172.16.0.1-255.255

 

On a re-push I tell what site should be assigned. I should really be doing this in the task sequence but guess I overlooked(it set to auto)

 

I find it odd that if you click "find" in the client control panel it finds the site straightaway

 

Also if you run the AD queries they return the correct information

(&(ObjectCategory=mSSMSManagementPoint)(mSSMSDefaultMP=TRUE)(mSSMSVersion>=8200))

(&(ObjectCategory=MSSMSRoamingBoundaryRange)(|(&(MSSMSRangedIPLow<=2886732516)(MSSMSRangedIPHigh>=2886732516))))

 

This seems to say to me the AD query isn't running from the client. PErmission denied?

spSearch->GetFirstRow(hSearch), HRESULT=80072020 <---

Share this post


Link to post
Share on other sites

I found an uninstall of the client and reinstall now specifying site works fine as does sending a repair command to client. Looking for a way where this isn't needed though as with 1200 devices it not easy to keep track!

 

If it comes to it I might have to go the GPO method of setting the site code however I feel MS is missing a trick a little bit. I see by the logs that the domain/forest is correctly guessed. From this a DNS lookup could easy be done but does try it

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...