Jump to content


SCCM 1702 - Reporting services data source

Recommended Posts

We have recently reinstalled our SCCM environment and migrated from the old environment to the new one.

The problem is that it seems some of the reporting services datasources were also migrated to the new server and is now causing some issues in reporting services.
reports sometimes fail because they are looking at a broken datasource that doesn't connect.
Stupid thing is, the old environment has the exact same data sources and the same one is also broken there but isnt causing issues.

The one starting with 5C works fine but the one with 39 just doesn't connect.

We have tried:

  • changing connection string (it works but sccm just replaces the string again causing it to break again)
  • Removing data source (sccm will just recreate it and break all the reports)
  • Reinstalling report point (sccm will just recreate all the reports and the broken data source)
  • reinstalling ssrs (threw database and files away but result is the same)

Now I'm guessing that SCCM just creates the datasources based on something that is in his database but how do we get rid of this?

Thanks in advance guys!



Share this post

Link to post
Share on other sites

Well I'm not trying to change anything, these 2 data sources are created by sccm every time the reporting point is installed by SCCM, one of them works and the other one doesn't.
This is a fresh installation of SSRS on the same machine that is running the new SCCM installation, it is in no way connected to the old environment. 

Basically what I'm trying to do is to get rid of the broken Data source so that my reports will stop failing 50% of the time. 

Share this post

Link to post
Share on other sites

all reports 50% of the time, you then have to refresh the page to get them to work. 

the datawarehouse reports don't work at all, not even after a refresh and these are the only reports that this broken data source has dependent items for.
You can also see that the connection string for this data source is not correct, I can change it but sccm just changes it back after I press apply.



Share this post

Link to post
Share on other sites

I faced a similar issue when trying to change the service account used for SQL Service Reporting Services (SSRS). This might help future readers who come across this post:

Scenario: In my situation, we were trying to change the service account being used for SSRS. I changed the account used in ConfigMgr and tried changing the account used in Reporting Services Config Manager 2016 (RSCM). The account change in ConfigMgr stuck while the account change in Reporting Services Configuration Manager 2016 didn't and all our ConfigMgr Reports broke.

Encryption Keys: Backup the Encryption Keys before doing anything. Then, once you change the account - restore the Encryption Keys you backed up earlier. Because we didn't do this, we had to select the Delete option and assigned the new service account. As a result, we lost all of our custom reports (.RDL files) which could have been backed up easily.


- Ensure that the Reporting Services service account (sa_sccm_rs) you're referencing is in the Service Account tab of the Reporting Services Configuration Manager. You will get errors if you are trying to assign a service account while running the Reporting Services Config Manager without appropriate SQL permissions. Ask your DBA to help or give yourself SysAdmin permissions in SQL if it's a LAB environment.

- Ensure that the account used in ConfigMgr for the Reporting Services Point is using the same account (sa_sccm_rs) you've configured in Reporting Services Configuration Manager.

- Ensure that your service account (sa_sccm_rs) has RSExecRole permissions on the ReportServer and ReportServerTempDB databases.

What's funny is my issue led me to Garth's post to verify I had setup everything correctly:

And to the following link which described exactly what I was doing and where I went wrong:

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.