Jump to content


Sign in to follow this  
anyweb

New Hotfix available: KB977203 - User state migration fails on a SCCM 2007 SP1 or SP2 client

Recommended Posts

Consider the following scenario:

 

* You install the System Center Configuration Manager 2007 Service Pack 1 (SP1) client or the System Center Configuration Manager 2007 Service Pack 2 (SP2) client.

* You install security update 974571 on this computer.

* A SCCM task sequence runs on this client. This task sequence includes the Capture User State task sequence step and the Restore User State task sequence step.

 

In this scenario, user state migration fails. At the same time, the following error message is logged in the Ccmexec.log file:

 

Failed to import the client certificate store (0x80092024) OSDSMPClient

 

This issue occurs because an embedded NULL character is in the Friendly name property of a certificate. The security update 974571 prevents the action that imports the certificate when its Friendly name property has an embedded NULL character. Therefore, the certificate cannot be imported.

 

For all the details including a download link to the hotfix see the following new Knowledge Base article:

 

KB977203- User state migration fails on a SCCM 2007 SP1 client or on a SCCM 2007 SP2 client after you install security update 974571

 

J.C. Hornbeck | System Center Knowledge Engineer

Share this post


Link to post
Share on other sites


Thanks for the post. This has been one of the biggest fuster-clucks that I've seen Microsoft pull in a while. It totally wrecked one of the coolest features of SCCM and OSD.

 

Anyway, I'm trying to figure out how to deploy this hotfix and was wanting some feedback. I'm running SCCM R2 on a Server 2008 R2 machine. When I download the hotfixes, it shows me two hotfixes for SCCM SP1 (one is x86 and one is x64) but it only shows one hotfix for SP2 (an x86 hotfix). My question is this:

 

Where is the hotfix for SP2 x64?? Am I missing something?

 

I assumed that the x86/x64 refers to the host OS, since SCCM is still only an x86 program, correct?

 

Any guidance on this would be much appreciated, as I'd really like to get the USMT back up and running.

 

Thanks1

Share this post


Link to post
Share on other sites

Thanks for the post. This has been one of the biggest fuster-clucks that I've seen Microsoft pull in a while. It totally wrecked one of the coolest features of SCCM and OSD.

 

Anyway, I'm trying to figure out how to deploy this hotfix and was wanting some feedback. I'm running SCCM R2 on a Server 2008 R2 machine. When I download the hotfixes, it shows me two hotfixes for SCCM SP1 (one is x86 and one is x64) but it only shows one hotfix for SP2 (an x86 hotfix). My question is this:

 

Where is the hotfix for SP2 x64?? Am I missing something?

 

I assumed that the x86/x64 refers to the host OS, since SCCM is still only an x86 program, correct?

 

Any guidance on this would be much appreciated, as I'd really like to get the USMT back up and running.

 

Thanks1

 

 

I'm in the same boat as you. I'm on W2K8R2 (hence x64) and SCCM 2007 R2 SP2, there a re no download forthat platform. Weird...

Share this post


Link to post
Share on other sites

yes, there are no other platform vailable except x64.

but when i extracted i found .msp file for x86 plateform...i think CCMCertFix.exe would manage while installing....

 

hope this information can help...

 

Cheers!!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...