Jump to content


George

Allow domain users to connect shared printers

Recommended Posts

Hello!

 

In our organization any user can connect and print on any shared printer. In Windows XP they just doing right click on shared printer and chooses connect from the menu. Our users don’t have any special permission like Power User on their stations, they just Users.

In Windows 7 if they do the same they got Access Denied message. I did some tests and I figured out that the message appears only when they trying to install printer driver. If the same printer was connected before by Administrator account everything working well.

How I can fix it? Is there any option in GPO maybe?

 

Thanks! :rolleyes:

Share this post


Link to post
Share on other sites


Found this that might help:

 

Go to Control Panel. Choose printer. Then choose Add Printer.

 

ChooseAdd a local printer. Click on Create a new port. The default in the drop down box is Local Port. Do not change that. Click Next.

 

A dialogue box will appear asking for you to enter a port name. Type in the \\computer name\printer name ie. My computer's name is basement and the printer name is EpsonSty so I typed in \\basement\epsonsty

 

Yahoo! It worked. Go figure! I guess Microsoft thinks printers on a intranet are local.

 

Hope this helps someone else so they don't spend the hours I did on it!

 

http://forums.techguy.org/windows-vista/541278-solved-access-denied-network-printers.html

 

Hope it works out!

Share this post


Link to post
Share on other sites

Found this that might help:

 

Go to Control Panel. Choose printer. Then choose Add Printer.

 

ChooseAdd a local printer. Click on Create a new port. The default in the drop down box is Local Port. Do not change that. Click Next.

 

A dialogue box will appear asking for you to enter a port name. Type in the \\computer name\printer name ie. My computer's name is basement and the printer name is EpsonSty so I typed in \\basement\epsonsty

 

Yahoo! It worked. Go figure! I guess Microsoft thinks printers on a intranet are local.

 

Hope this helps someone else so they don't spend the hours I did on it!

 

http://forums.techguy.org/windows-vista/541278-solved-access-denied-network-printers.html

 

Hope it works out!

 

No, this method is not good for me. It require drivers and exact printer names.

We have 1000+ users and 50+ printers, too much work for helpdesk to explain to each one which printer to connect and which driver to install.

 

Thanks for your help!

Share this post


Link to post
Share on other sites

No, this method is not good for me. It require drivers and exact printer names.

We have 1000+ users and 50+ printers, too much work for helpdesk to explain to each one which printer to connect and which driver to install.

 

Thanks for your help!

 

this may help you out. I found that my users did not have permission to network'd printers. So I made the following change to allow them add printers that I have made available from my print server. Good luck

 

There is a setting Computer Configuration/Administrative Templates/Printers called “Point and Print Restrictions”

1. Set it to “Enabled”

2. Put a check box in “Users can only point and print to these servers:”

3. Enter your print server name in the box “servername.domainname.com”

4. Security Prompts – set both to “Do not show”

Now your users should be able to add printers from your print server

Share this post


Link to post
Share on other sites

To follow up on teh previous post, this was our solution as well, but I had found a little bit more info. The following can be set locally within the image or using GP:

 

• There are TWO "Point and Print Restrictions" settings

• Computer Configuration/Policies/Administrative Templates/Printers/Point and Print Restrictions

• User Configuration/Policies/Administrative Templates/Control Panel/Printers/Point and Print Restrictions

 

Of these two, the one under Computer Configuration seems to be the important one. But the original Server 2008 doesn't include this setting in the list -- you need Server 2008R2 for this setting to show up. If you download the administrative templates from Server 2008 R2, extract, and copy the PolicyDefinitions folder to C:\Windows\sysvol\domain\Policies\PolicyDefinitions, this missing policy will show up magically in Group Policy Management Editor. Of course, the ADMX files from Server 2008 R2 causes Group Policy Management Editor from Server 2008 tocomplain about parse errors, but it works just fine to click "OK".

Once you've installed the proper ADMX files, for this to work in Windows 7, configure both of these "Point and Print Restrictions" settings to:

• Enabled

• Security Prompts, When Installing Drivers for a new connection = Do not show warning or elevation prompt

• Security Prompts, When Installing Drivers for a new connection = Do not show warning or elevation prompt

 

Also, don't forget to make sure the users have permission to install printer drivers, since you're not even going to try to use Admin privileges any more:

• Computer Configuration\Policies\Administrative Templates\System\Driver Installation

• The setting is called "Allow non-administrators to install drivers for these devices setup classes".

• You will need to add the device class GUID of printers: {4d36e979-e325-11ce-bfc1-08002be10318}

 

Don't forget to update the computer policy on the workstation by running "gpupdate /force".

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...