Jump to content


Anmol06

SCCM Current Branch 1910 Upgrade Prereq check fails with sysadmin rights issue

Recommended Posts

 

SCCM Infrastructure:
SCCM CB v1910
Standalone Primary Site

 

Issue :
Prerequisite Check for SCCM Upgrade from 1910 to 2010 fails with this error in Prereqcheck.log
 
ERROR: Failed to retrieve next row. $$<Configuration Manager Prereq><05-21-2021 11:00:09.190+420><thread=2760 (0xAC8)>
<FQDN OF PRIMARY SITE SERVER>; SQL Server sysadmin rights; Error; Either the user account running Configuration Manager Setup or NT AUTHORITY\SYSTEM does not have sysadmin SQL Server role permissions on the SQL Server instance selected for site database installation, or the SQL Server instance could not be contacted to verify permissions. Setup cannot continue. $$<Configuration Manager Prereq><05-21-2021 11:00:09.191+420><thread=2760 (0xAC8)>
ERROR: The current user does not have administrative rights on computer: <FQDN OF PRIMARY SITE SERVER>. $$<Configuration Manager Prereq><05-21-2021 11:00:09.198+420><thread=2760 (0xAC8)>
The service account through which this check is run has sysadmin rights on the SQL Database.
It will be really helpful if anyone here can point me in the right direction to fix this error.

Share this post


Link to post
Share on other sites

what about this ?

ERROR: The current user does not have administrative rights on computer: <FQDN OF PRIMARY SITE SERVER>

Share this post


Link to post
Share on other sites

@anywebThe current user is the Service Account and it is part of Local Administrators on the Primary Site Server. So this Service Account should have the administrative rights on the Primary SIte Server.

Share this post


Link to post
Share on other sites

ok well something is not right, is SQL remote in this case ?

Share this post


Link to post
Share on other sites

ok back to the first error, are you specifying the sql server instance correctly ? what is it and what are you entering ?

on the server in question, logged on with that service account if you open device manager does it tell you you are a standard user ?

Share this post


Link to post
Share on other sites

are you specifying the sql server instance correctly ? what is it and what are you entering ?---->Where it should be specified?

on the server in question, logged on with that service account if you open device manager does it tell you you are a standard user ?------->Device Manager shows all the hardware details. what else do I need to check in Device Manager?

Share this post


Link to post
Share on other sites

Thanks for the assistance so far.

After granting sysadmin rights to the computer account of the Primary Site Server, the Pre-req check fails with the same error mentioned in the initial issue description. What to do in order to fix this issue?

Share this post


Link to post
Share on other sites

so what errors are you seeing now, to be clear

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...