Jump to content


swiss_morpheus

SCCM 2012 RC2 - Error occurred while importing the selected driver

Recommended Posts

Hello together

We have an issue in our LAB, when we try to import any driver into SCCM 2012 RC2 Console. It doesnt matter which driver we try to import, it always fail with following error:

"An error occureed while importing the selected driver"

I had a look into the SmsAdminUI.log and what I found there, seems a bit strange

 

:[6, PID:5604][03/19/2012 15:34:30] :Microsoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlQueryException\r\nThe SMS Provider reported an error.\r\n   at Microsoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlResultObject.Put(ReportProgress progressReport)   at Microsoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlResultObject.Put()   at Microsoft.ConfigurationManagement.AdminConsole.DesiredConfigurationManagement.ConsoleDcmConnection.Microsoft.ConfigurationManagement.DesiredConfigurationManagement.IDcmStoreConnection.StoreNewItem(ConfigurationItem item)   at Microsoft.ConfigurationManagement.DesiredConfigurationManagement.ConfigurationItem.Persist(Object existingStoreItem)   at Microsoft.ConfigurationManagement.AdminConsole.Driver.ImportDriverWizardForm.PutDriverObject(SmsDialogData pageData, IResultObject selectedObject, DriverConfigurationItemInfo driverInfo, List`1 allDriversInfoToRefreshDP, Boolean& hasValidDriver, Boolean& hasErrorDriver, PropertyDataUpdateAction& updateAction)\r\nConfigMgr Error Object:instance of SMS_ExtendedStatus{	CauseInfo = "";	Description = "SQL command failed:  if (object_id('tempdb..#sp_setupci_resultstr') IS NOT NULL)  drop table #sp_setupci_resultstr;";	ErrorCode = 2168851714;	File = "e:\\nts_sccm_release\\sms\\siteserver\\sdk_provider\\smsprov\\ssputility.cpp";	Line = 2105;	ObjectInfo = "Please check SMS Provider log file for details of the SQL errors";	Operation = "PutInstance";	ParameterInfo = "";	ProviderName = "ExtnProv";	SQLMessage = "[24000][0][Microsoft][sql Server Native Client 10.0]Invalid cursor state";	SQLSeverity = 0;	SQLStatus = 0;	StatusCode = 2147749889;};

 

We use SCCM 2012 with only a Primary Site and SQL Server 2008 R2 SP 1 CU4.

May somebody experienced the same problem?

Thank you for your help

Best wishes

Share this post


Link to post
Share on other sites

Have been able to solve this problem. It is a known bug in SCCM RC1 and also Final. Microsoft Beta Engineer got a solution for me:

 

As soon as you dettach an reattach the sccm database in sql, two properties are changed, and sccm isn't able to do certain operations, as importing drivers, or applications.

 

Run this query against you db: ALTER DATABASE CM_SAG SET TRUSTWORTHY ON

 

Also verify, that SA is still the owner of the database. And that was it!

 

Thanks anyway

Share this post


Link to post
Share on other sites

Have been able to solve this problem. It is a known bug in SCCM RC1 and also Final. Microsoft Beta Engineer got a solution for me:

 

As soon as you dettach an reattach the sccm database in sql, two properties are changed, and sccm isn't able to do certain operations, as importing drivers, or applications.

 

Run this query against you db: ALTER DATABASE CM_SAG SET TRUSTWORTHY ON

 

Also verify, that SA is still the owner of the database. And that was it!

 

Thanks anyway

 

Works a treat!!

 

Thanks a million!

Share this post


Link to post
Share on other sites

Hello,

 

im using SCCM 2012 Final.

I get an error when i import drivers.

 

ALTER DATABASE CM_"SiteCode" SET TRUSTWORTHY ON didnt work. SA ist Owner

Import packages works.

 

Do you have any Ideas to solve the problem?

Share this post


Link to post
Share on other sites

Nobody there to answer the question when ALTER DATABASE CM_"SiteCode" SET TRUSTWORTHY ON didnt work. SA ist Owner dosnt work?

Share this post


Link to post
Share on other sites

yes, you need to do 3 things:

 

1)

ALTER DATABASE CM_<SiteCode>" SET TRUSTWORTHY ON

 

2)

ALTER DATABASE CM_<SiteCode>

SET ALLOW_SNAPSHOT_ISOLATION ON

ALTER DATABASE CM_<SiteCode>

SET READ_COMMITTED_SNAPSHOT ON

 

3)

run against the configmgr database (CM_<SiteCode>)

sp_changedbowner 'sa'

 

h2h

 

 

source:

http://support.microsoft.com/kb/2709082

Share this post


Link to post
Share on other sites

Noob to the site:

 

Appreciate it's an old post.... Sometimes the simple things trip us up:

We have a hierarchy running 2012 R2.

 

"Import drivers" on the CAS gives the errors as described.

There is no warning given that you can't or shouldn't run the import on the CAS. If you try to import drivers and there is no DriverCatalog.log file, then you need to move to a primary server and try again. I haven't confirmed what service / role the server requires to import drivers but I would like to think the CAS would allow importing drivers into the hierarchy....

 

Importing the drivers on the first Primary server works fine. I'll have to check whether this flows to the second Primary when it comes online.

 

1 extra "gotcha": You may receive errors when importing drivers. Check the DriverCatalog.log file. You may find they're simply warnings that there are duplicate drivers. I believe these are incorrectly recorded as failures. They should be categorised as warnings only.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...