Jump to content


lensterman

Automatically configure Language Settings for Task Sequence

Recommended Posts

I am aiming to deploy via SCCM 2007, Windows 7 64 bit with the Japanese language pack pre installed in the image. I would like the Task Sequence to set the user interface and regional settings to be Japanese in computers that are a member of a certain collection.

 

I have created a simple Task Sequence with the following tasks:

 

Format and Partition Disk

Apply Operating System (Uses unattended file)

Apply Windows Settings

Apply Network Settings

Setup windows and ConfigMgr

 

On the Collection which the target PC is a member of I have configured the following Variables:

  • OSDSystemLocale: ja-JP
  • OSDInputLocale: ja-JP
  • OSDUserLocale: ja-JP
  • OSDUILanguage: ja-JP
  • OSDUILanguageFallback: ja-JP

The unattend.xml that is referenced in the Apply image section references the Collection variables as below:

<InputLocale>%OSDSystemLocale%</InputLocale>

<SystemLocale>%OSDInputLocale%</SystemLocale>

<UILanguage>%OSDUserLocale%</UILanguage>

<UILanguageFallback>%OSDUILanguage%</UILanguageFallback>

<UserLocale>%OSDUILanguageFallback%</UserLocale>

Just before the Setup Windows and Configmgr reboots the PC I checked the contents of the unattend.xml file (in C\Windows\Panther\Unattend) and it was evident that the regional and language settings had been set to the value of the Collection variables as below:

<SystemLocale>ja-JP</SystemLocale>

<UserLocale>ja-JP</UserLocale>

<UILanguage>ja-JP</UILanguage>

<InputLocale>ja-JP</InputLocale>

<UILanguageFallback>ja-JP</UILanguageFallback>

 

However when the PC went into the Windows setup mode I had to manually select Japanese as the UI Language (English was the other option). In addition the system locale was not set to Japanese either.

Would anyone be able to point me in the right direction as to how to make the PC automatically choose Japanese as the UI language as well as set the other regional settings (locale etc)?

Share this post


Link to post
Share on other sites


I had the same problems when doing this. I found that you had to add an unattend.xml file to the OS section of the task sequence. In the XML, make sure you have the following lines:

 

<SystemLocale>%OSDSystemLocale%</SystemLocale>

<UserLocale>%OSDUserLocale%/UserLocale>

<UILanguage>%OSDUILanguage%</UILanguage>

<UILanguageFallback>%OSDUILanguageFallback%</UILanguageFallback> If I recall correctlyI

<InputLocale>%OSDInputLocale%</InputLocale>

 

If I recall correctly, the InputLocale uses the older WinXP type values. e.g. 0409:00000409 for English.

 

I hope this helps.

Con

Share this post


Link to post
Share on other sites

also you have %OSDSystemLocale% and OSDInputLocale are swapped (in the wrong place) see below

 

The unattend.xml that is referenced in the Apply image section references the Collection variables as below:

<InputLocale>%OSDSystemLocale%</InputLocale>

<SystemLocale>%OSDInputLocale%</SystemLocale>

<UILanguage>%OSDUserLocale%</UILanguage>

<UILanguageFallback>%OSDUILanguage%</UILanguageFallback>

<UserLocale>%OSDUILanguageFallback%</UserLocale>

 

 

Share this post


Link to post
Share on other sites

Hi Experts,

Sorry about digging an old thread. Only recently, we found a bug with our Windows 8.1 Image. We have configured the TS to allow user choose the language while TS is executed. The selected language works fine on the Welcome Page and even on the login page where the user is prompted for user id and password. However, once logged in the start menu, desktop and icons appear in the English US. I have tested logging in using both administrator account as well as a standard user with the same results.

I am using the below in the unattend.xml:

<InputLocale>%Keyboardlocale%</InputLocale>

<SystemLocale>%Systemlocale%</SystemLocale>
<UILanguage>%UILanguage%</UILanguage>
<UserLocale>%UserLocale%</UserLocale>

 

and tried the below:

<InputLocale>%OSDInputLocale%</InputLocale>

<SystemLocale>%OSDSystemLocale%</SystemLocale>
<UILanguage>%OSDUILanguage%</UILanguage>

Without any results.
Any help will be much appreciated.

BR,
Hooligan88

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...