Jump to content


Sign in to follow this  
anyweb

how can I edit the EULA, FullName and Organization using Windows SIM

Recommended Posts

startup Windows SIM and add the Microsoft-Windows-Setup\UserData\ component to the Windows PE configuration pass.

 

userdata.jpg

 

configure the AcceptEULA, Fullname and Organization name as follows:

 

userdata_added.jpg

 

click on the Validate icon to check your answer file

Share this post


Link to post
Share on other sites


Hi,




Kindly help me on this issue. Am struggling for a week to create a answer file for the below criteria:-



I want the an answer file to prompt for the Credentials to join the domain and for computer name or it should be taken automatically from the guid.



Kindly help me ...


Share this post


Link to post
Share on other sites

hi.

firstly thank u for all helps and tricks. great work.

 

i have some problem with "windows-shell-setup" component setting unattend file creating.

 

Time Zone

i set time zone to "Azerbaijan Standart Time" (UTC (GMT)+04:00 Baku) and when installing os this setting not work.asking me set time zone (at specialize properties.). i wrote windows shell setup neuteral component at specialize time zone value only "Azerbaijan Standart Time".

at oobe windows shell setup neuteral wrote too "Azerbaijn Standart Time". but it not working.where i did wrong?

and i want 24 hour clock time not 12 hour am/pm.can i set this option?

 

Computer Name

When i set computer name value at specialize properties an (*) that setting works and automatically sets computer name.

but when i write to this value a name then when installing windows an error occured that at specialize setting problem.

how can i set a name manually?

 

Additional components

can i add an additional components like a language,an update pack and ect.?

 

here some pics of my wsim settings and a .xml file

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <servicing>
        <package action="configure">
            <assemblyIdentity name="Package_for_KB976902" version="6.1.1.17514" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="" />
        </package>
    </servicing>
    <settings pass="windowsPE">
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SetupUILanguage>
                <UILanguage>en-us</UILanguage>
            </SetupUILanguage>
            <InputLocale>en-US</InputLocale>
            <SystemLocale>en-US</SystemLocale>
            <UILanguage>en-US</UILanguage>
        </component>
        <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <DiskConfiguration>
                <WillShowUI>OnError</WillShowUI>
                <Disk wcm:action="add">
                    <CreatePartitions>
                        <CreatePartition wcm:action="add">
                            <Order>1</Order>
                            <Size>30000</Size>
                            <Type>Primary</Type>
                            <Extend>false</Extend>
                        </CreatePartition>
                        <CreatePartition wcm:action="add">
                            <Order>2</Order>
                            <Type>Primary</Type>
                            <Extend>false</Extend>
                            <Size>20000</Size>
                        </CreatePartition>
                    </CreatePartitions>
                    <ModifyPartitions>
                        <ModifyPartition wcm:action="add">
                            <Active>true</Active>
                            <Format>NTFS</Format>
                            <Label>Windows</Label>
                            <Letter>C</Letter>
                            <Order>1</Order>
                            <PartitionID>1</PartitionID>
                            <TypeID>1</TypeID>
                        </ModifyPartition>
                        <ModifyPartition wcm:action="add">
                            <Active>false</Active>
                            <Format>NTFS</Format>
                            <Label>DATA</Label>
                            <Letter>D</Letter>
                            <Order>2</Order>
                            <PartitionID>2</PartitionID>
                            <TypeID>2</TypeID>
                        </ModifyPartition>
                    </ModifyPartitions>
                    <DiskID>0</DiskID>
                    <WillWipeDisk>true</WillWipeDisk>
                </Disk>
            </DiskConfiguration>
            <ImageInstall>
                <OSImage>
                    <InstallTo>
                        <DiskID>0</DiskID>
                        <PartitionID>1</PartitionID>
                    </InstallTo>
                    <InstallToAvailablePartition>false</InstallToAvailablePartition>
                    <WillShowUI>OnError</WillShowUI>
                </OSImage>
            </ImageInstall>
            <Display>
                <HorizontalResolution>1024</HorizontalResolution>
                <VerticalResolution>768</VerticalResolution>
            </Display>
            <UserData>
                <AcceptEula>true</AcceptEula>
                <FullName>nemo test</FullName>
                <Organization>nemo inc</Organization>
            </UserData>
            <EnableFirewall>false</EnableFirewall>
            <UseConfigurationSet>true</UseConfigurationSet>
            <EnableNetwork>true</EnableNetwork>
        </component>
    </settings>
    <settings pass="oobeSystem">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <UserAccounts>
                <AdministratorPassword>
                    <Value>MQAyADMANAA1ADYANgA3ADgAQQBkAG0AaQBuAGkAcwB0AHIAYQB0AG8AcgBQAGEAcwBzAHcAbwByAGQA</Value>
                    <PlainText>false</PlainText>
                </AdministratorPassword>
                <LocalAccounts>
                    <LocalAccount wcm:action="add">
                        <Password>
                            <Value>MQAyADMANAA1ADYANwA4AFAAYQBzAHMAdwBvAHIAZAA=</Value>
                            <PlainText>false</PlainText>
                        </Password>
                        <DisplayName>Nemo</DisplayName>
                        <Group>Administrators</Group>
                        <Name>N3M0</Name>
                    </LocalAccount>
                </LocalAccounts>
            </UserAccounts>
            <BluetoothTaskbarIconEnabled>true</BluetoothTaskbarIconEnabled>
            <DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
            <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
            <ShowWindowsLive>false</ShowWindowsLive>
            <TimeZone>Azerbaijan Standart Time</TimeZone>
        </component>
    </settings>
    <settings pass="specialize">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <TimeZone>Azerbaijan Standart Time</TimeZone>
            <ComputerName>*</ComputerName>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="catalog://nautilius/share/images/win 7 ult orig/sources/install_windows 7 ultimate.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

post-24968-0-52639600-1400597548_thumb.jpg

post-24968-0-04993500-1400597551_thumb.jpg

post-24968-0-52834400-1400597553_thumb.jpg

autounattend.xml

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...