Jump to content


shifty

Build and Capture OSD Failing

Recommended Posts

Hey guys, I've visited this site a lot for the guides and its been a huge help throughout our SCCM 2012 install and setup. Unfortunately, while I had our implementation of it working (pretty well) at one point - I've had to go through the setup process again on another server and am running into some issues I haven't seen before.

 

So, I'm hoping someone here can give me some guidance. I'm basically running a build and capture for Windows 7 x64 on a Hyper-V VM, once it hits the Configure OS / Setup Windows and Configuration Manager client task the sequence errors out.

 

An investigation of the SMSTS log yields hundreds of lines with the following error:

 

"Failed to open Software\Microsoft\Sms\Mobile Client\Software Distribution registry key. The client should not get checked for RWH OpLock Type"

 

I've found a couple of online topics referencing a problem with it pulling/applying an activation key - however, every time I've run this task I have not embedded an activation key. Not 100% sure where to go from here, first time I've seen an error like this while running a TS, really.

 

For everyone's convenience, I've attached the full SMSTS.log. Let me know if I need to provide any more detail :)

 

Thanks in advance!

smsts-20120801-024746.log

Share this post


Link to post
Share on other sites

hmm does it actually pop up an error at this point or does it just sit there forever logging the same line ? do you also have a copy of any other logs ? check x:\windows\temp\smstslog\

Share this post


Link to post
Share on other sites

Yeah, I guess that wasn't quite the right log file I posted originally. This one actually shows a proper error (attached).

 

But again, I haven't been using an activate key in any of my task sequences (which is the common solution to the error being thrown, it seems).

 

Anyway, I've also attached a screenshot of the failed sequence and its relatively generic error code.

post-16523-0-62580100-1344008825_thumb.png

smsts.log

Share this post


Link to post
Share on other sites

Seems to me it cant access the sourcefiles for the config mgr client. Is the client a member or the right boundary group? and try to make a new package "from definition" for the client package. Dont forget to update DPs :)

Share this post


Link to post
Share on other sites

I was so excited to see someone finally have the same error as me. I have ripped through permissions, logs, set up all new packages, and even started from scratch and followed the guide here step by step (with some slight adjusting for the official release). I just can't seem to get past this though!

 

I have three smsts.log files that I found on the PC (C:\SMSTSLog (2), X:\SMSTSLog) that I have attached. I have as well tried applying a serial key, and toying with the drivers (although I don't think this is an issue in hyper-v?).

 

Hyper-V Environment

SCCM 2012 SP1 with all updates

SQL 2008 R2 SP2

Build and Capture Windows 7 x64 Enterprise

 

Any help would be greatly appreciated!

smsts_c.log

smsts_x.log

smsts-20130401-230057.log

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...