Jump to content

  • 0

Applications stuck on "Waiting to Install" - Stumped!


Hello all -

I have a very strange problem that I can't seem to find an answer to. We recently upgraded our server from 2008 to 2012, and then to R2 and SCCM 2012 to R2 as well. Previously, we would deploy an image to a computer, and the Client would automatically install, and within about 45min - 1.5 hours all of the software would install automatically.


After the R2 install, we had a new computer that needed to be imaged. No changes to the workflow were made since this process last worked. I installed the image, and came back the next day to find no software was installed. Everything was sitting at "Downloading 0%".


I messed around with some settings in my IIS (I originally couldn't reach the application website, and thought that may be part of the problem), uninstalled and reinstalled the client a few times, and suddenly everything started installing again. It all worked perfectly.


However, I decided to try imaging a test machine to see if I could replicate the problem. Sure enough, as soon as the client installs and finds applications, they are stuck at "Waiting to Install". I've dug through the logs, and can't seem to find much, although there are quite a few logs to look through. Even weirder - if I uninstall the client and reinstall it, and then wait for a while (usually overnight), I'll come back to all of the applications installed normally!


I've redistributed all of the applications (90+) to our distribution server. No errors there.


I've turned off pre-staged content in the distribution settings. We had it on, but were not using it (we only have one server, which is also the distribution point). No change.


I even went so far as to make a new image, completely devoid of any installed programs. No Change.


I made a new copy of the Configuration Manager Client and deployed the new version with the clean image. No change.


If I open C:\Windows\CCMCache, I can see all of the programs, files, and installers listed there. It seems like it's downloaded everything and ready to go, but it's waiting for something to finish before starting to install. But what, I don't know.


I do not use SCCM for Windows Updates, so it's not waiting for software updates. I've tried restarting a few times, no change.


I came back to the machine this morning after letting it sit overnight, and everything was on "past due - will be installed". When I clicked on a program and selected "install", it worked just fine. A number of other programs worked as well. I tried deleting and redeploying an application that was previously on "waiting to install" (today it was "past due"), and the machine picked it up and installed it immediately.


I forgot to mention - I don't have any maintenance windows created (that I know about).


Any ideas? Everything just used to install almost immediately.


Where should I look? What logs?


Share this post

Link to post
Share on other sites

Recommended Posts

  • 0

Just upgraded to 2012 R2 CU4 from SP1 and having the same issue. Task Sequence won't finish and doesn't error out after the SCCM Client install step. It doesn't even try any steps afterward but any new image machine will stay stuck in "Waiting to Install" with all the files already downloaded in the cache. Not sure what it's waiting for. No Maintenance window set on any collection. I've found another post from mshaboboo with no answer to this problem as well. Anyone ever get this resolved. Not seeing any errors in any logs that seem relevant.

Share this post

Link to post
Share on other sites

  • 0

Having checked my client settings. We have a BITS throttling window set from 9am - 3pm. I then noticed that Allow BITS downloads outside the throttling window was set to NO. Changed it to yes and my software is installing.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.