Jump to content


Sign in to follow this  
hadi

scom 2012 exchange monitoring

Recommended Posts

hi I have a scom2012 r2 installed and exchange 2013 management pack imported .after installing agent on the exchange server agent , scom discovered components and .... . accourding to this article I've realized that I should change StorageLogicalDriveSpaceMonitor threshold , so I did that . But it doesnt show me mailbox database size as it was showing at the beginning of installing exchange mp .

 

at first it was showing exchange mailbox count .but Now its not .

 

whats the solution ?

Share this post


Link to post
Share on other sites


Can you provide more details as to which Monitor or Rule you modified for the "exchange mailbox threshold"?

 

According to the MP documentation, there is a Performance metric called Exchange 2013 Organization Synthetic: Mailbox Database Size (MB).

 

Exchange 2013 Organization Synthetic: Mailbox Database Size (MB)

Displays the amount of space used by mailbox database, in megabytes. This performance collection rule collects multiple instances – one instance per mailbox database. Calculated as average value for each active database copy in organization. If no active database exists, then first found is used.

 

Share this post


Link to post
Share on other sites

Can you provide more details as to which Monitor or Rule you modified for the "exchange mailbox threshold"?

 

According to the MP documentation, there is a Performance metric called Exchange 2013 Organization Synthetic: Mailbox Database Size (MB).

 

sorry because of my writing fault in my question .I correct that .

Share this post


Link to post
Share on other sites

OK, first off.... That article you reference is about Exchange 2010 and not 2013. There is no reference to 2013 at all in it.

 

Second, the article does not reference the StorageLogicalDriveSpace Monitor threshold, that you are mentioning. So I don't know where you're coming up with that.

 

Third, the article is about Mailbox provisioning being disabled by SCOM, which has nothing to do with reporting on mailbox sizes.

 

Please ensure that you have the Exchange 2013 Management Pack installed, and ensure that it is the latest version as there have been some changes to it. Also refer to the accompanying documentation for information on Monitors, Rules, and Thresholds. You can find it here: http://www.microsoft.com/en-us/download/details.aspx?id=39039

Share this post


Link to post
Share on other sites

For the Mailbox Database Copy showing as Not Monitored, note the following from the MP documentation.

 

Exchange 2013 Mailbox Database Copy

The object of this class represents the physical copy of Exchange Mailbox Database. The physical mailbox database copy is always hosted on a given Mailbox Server.

Exchange 2013 Mailbox Database Copy - Discoveries Exchange 2013: Discover Microsoft Exchange Organization and Server objects

This discovery rule discovers Exchange 2013 Organizations, Servers, AD Sites, Database Availability Groups, Health Sets, Windows Services, IIS Application Pools, Mailbox Database Copies, and all other related objects. It discovers all relevant relationships as well.

 

The table within the documentation shows that this discovery rule is NOT enabled by default. Can you confirm that you have enabled this Discovery Rule?

 

Can you also confirm that the server(s) running Exchange are being monitored correctly (i.e. from the OS level)?

Share this post


Link to post
Share on other sites

For the Mailbox Database Copy showing as Not Monitored, note the following from the MP documentation.

 

 

The table within the documentation shows that this discovery rule is NOT enabled by default. Can you confirm that you have enabled this Discovery Rule?

 

Can you also confirm that the server(s) running Exchange are being monitored correctly (i.e. from the OS level)?

Hello,

I'm on SCOM 2012 R2 and have the Exchange 2013 MP (version 15.0.665.19). I am having the same issue where the following are not being monitored:

  • Mailbox Database Copy
  • Exchange IIS Application Pool

You and the documentation mention that the discovery rule is not enabled by default. However it appears that all the discovery rules are enabled by default in my version.

 

I can post pics if that would help.

Share this post


Link to post
Share on other sites

Can you confirm that the OS of the Exchange servers are being monitored successfully? I want to confirm that the SCOM Agent itself is functioning correctly.

Share this post


Link to post
Share on other sites

Can you confirm that the OS of the Exchange servers are being monitored successfully? I want to confirm that the SCOM Agent itself is functioning correctly.

The Exchange 2013 servers are Windows Server 2012 R2 and monitored just fine. The only things not monitored are the Database Mailbox Copy and the IIS Exhange App Pool.

 

It seems like the newest version of the Exchange MP that I have has the Discovery Rule enabled by default but it still doesn't work.

Share this post


Link to post
Share on other sites

The Exchange 2013 servers are Windows Server 2012 R2 and monitored just fine. The only things not monitored are the Database Mailbox Copy and the IIS Exhange App Pool.

 

It seems like the newest version of the Exchange MP that I have has the Discovery Rule enabled by default but it still doesn't work.

I'm getting exactly the same issue - SCOM 2012 R2 server with Exchange Server 2013 MP (15.0.665.19). Windows monitoring works fine on the Exchange servers and the agent is in a healthy state. I receive monitoring information for everything except for Server Components > Exchange IIS Application Pool and Server Components Mailbox Database Copy. The monitors are both enabled by default. Does anyone have a resolution for this? Thanks in advance...

Share this post


Link to post
Share on other sites

I haven't worked with the Exchange management pack myself, but I have heard there are a lot of challenges with it.

 

That being said, some MPs don't monitor some of their underlying technologies. For example, the Service Manager (SCSM) MP does not monitor IIS, SQL, etc. even though those techs are dependents for SCSM. Have you confirmed that the IIS MP and SQL MP are also imported into SCOM (and discovery the various App Pools and Databases)?

 

Also, take a look at this series which goes in depth on monitoring Exchange with SCOM: http://www.msexchange.org/articles-tutorials/exchange-server-2013/monitoring-operations/monitoring-exchange-2013-scom-2012-part1.html

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...