Jump to content


Windows 10 OSD Task Sequence not installing drivers

Recommended Posts

Good afternoon,


I have a windows 10 task sequence that lays down the OS nicely, installs all drivers, and activates windows/etc. We have kept fairly strict on standardizing the models of laptops/desktops that we purchase for our school district. We have a group of Lenovo T420 laptops that images perfectly with Windows 7 x86, but we just received a new batch and we're going to push Win10 x64 Professional to them. When getting the first one imaged, I noticed there were 4 or 5 drivers the task sequence did not take care of. I manually downloaded them, some of them only listed compatible with Windows 7 x64, but they worked fine with Win 10 x64, no issues whatsoever.


I added those drivers to my sccm server, added them to my "x64 Lenovo Laptops" Driver Package, and updated them on my distribution point. I noticed when I right click the driver and go to the "Applicability" tab, it only had Windows 7 (64-bit) checked. I made sure Windows 10 Professional/Enterprise and higher (64-bit) was selected and even did 32-bit as well, applied, updated my distribution points, and I reran my OSD task sequence.


Two drivers remain uninstalled after running the task sequence.

1) Base System Device, which is Ricoh PCIe SDXC/MMC Host Controller and

2) Intel® Active Management Technology - SOL


I've double checked, readded the drivers to the packages/server, updated my distribution points and it does the same thing, only those two drivers WILL not install.


What am I missing?


Any help is appreciated, thank you!

Share this post

Link to post
Share on other sites

Also, i'm very sure they're the right drivers. Once the task sequence is over, i just point the unknown device to the folder I saved all my drivers to (where I uploaded them to the SCCM server/packages) and it installs with no issues at all.


Not sure what's going on. I've never had any problems updating driver packages and then them not installing correctly in the OSD.

Share this post

Link to post
Share on other sites

i am having the same issue here with DELL optiplex 5040, it is not installing the network drivers during OSD. After bringing the system up i can put the same drivers on a stick and it will install them and work, but fails on deployment. I have injected the DELL drivers for boot image also. At the beginning it wouldn't start the task sequence because of drivers, so i injected them on the boot.wim but now it is not installing them on OSD.


I have also extracted a newer version from intel prowim64 and put them on a package and send them for OSD and still nothing :-( very frustaded.


Forgot to mention i am running SCCM 2012 SP2 CU3

Share this post

Link to post
Share on other sites



If you change the applicability then make sure you have updated the distribution point for those driver packages.


If that still doesn't work then use applications or packages to install them.


AMT drivers often don't want to play on any OS. Install them with an application later in the TS using the supplied setup.exe


If the SD card driver is definitely Windows 10 but won't install, again use an application or package later in the TS using dpinst64 to point at the .INF file.


I have at least 15 driver installs done like this in my Window 10 TS for ones that will not auto detect.


@Alewoodrum - you're a bit stuck with no NIC driver in Windows. Are you sure it's the NDIS 6.5 driver you have?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...