Jump to content

  • 0

Frontend configuration help



I am a new forum member and also fairly new to SCCM, MDT and Frontends etc as well.
First I want to say that I am very thankful for all the great How-to´s and other information that can be found in here. It has helped me a lot, to say the least. :-) Thank you!

I am installing a Lab environment just to catch up things faster with the real SCCM environment at work.
The servers in Lab environment are one DC and one CM server. CM server has MDT installed.
MDT is working fine, that means that I can take reference images the way I want and then implement them to SCCM.
SCCM is also working just fine, I have made task sequences for win7 and win10 and with the help of PXE boot I am able to install new operating systems. All services seems ok. Pretty happy with that but it´s all thanks to this forum! :-)

But of course I want to learn more...so now I want to implement Pretty Good Frontend as well! I think it is a really good feature to have in an environment. But....it´s not that easy it seems.
Been reading a lot of information about it and has come to the point that I feel I really don´t have a clue what to do or what steps to take. I would really like to get a Step-by-step How-to guide that will explain everything about getting it in place. The How-to´s I´ve found is the instructions found documented for Pretty Good Frontend but I am stuck. Actually it feels like my head will explode any second because of days of extensive searching about it. Maybe I am looking at the wrong places, I don´t know.

As you can see on the picture I want the frontend to look just as it is but I want it to fetch AD information and present it in the HTA. Also I want the system to add computer name suffix where it always starts with either Laptop or Workstation and then adds the serial number or anything that will separate them in the system. For example: Laptop+Serialnr would be "Laptop-12345678"
I want to be able to put the computer in any OU I want if needed and I want to be able to choose what OS Image to be installed.

So what I am asking is if any of you guys can guide me to simple hands-on information that will just get me through the steps that has to be taken to get all of these things working? If so I would be more than happy!

If there isn´t such a thing as a Step-by-step guide to be found elsewhere that shows each step in a very simple way I want to ask if anyone in this forum is keen on making one? For me this seems to be extremely complex and I can´t get the things I am reading about it transformed to anything I understand.


Share this post

Link to post
Share on other sites

Recommended Posts

  • 0

hi and welcome

take a look at these posts they should get you started, you'll need to incorporate web services to get that functionality


it's all covered in the windows-noob OSD book in great details by the way



Share this post

Link to post
Share on other sites

  • 0


Thank you very, very much! I will immediately dig into the links and I will definitely order Windows-noob OSD Book! At a first quick look it seems to be EXACTLY what I was looking for!

I can´t thank you enough for this! :-)

Share this post

Link to post
Share on other sites

  • 0
Hello again.

I rebuilt my Lab Environment to start over from scratch and now I´m back to the point when I wanted to implement Pretty Good Frontend.
The installation of the Web services is done and tested like it says in your book "The Windows-Noob OSD...". All seems fine but when I added the files to the Wim file it still ends up with the same results as I had last time, (please see screendump from my first post).

When i test the weblink; "http://cm01/deploymentwebservice/ad.asmx"it looks alright and "GetADsites" presents My domain controller, subnets and sites as well.

When testing something in the MDT "module" "http://cm01/deploymentwebservice/mdt.asmx"it doesn´t look like it´s working correctly. The link presents all the Functions like AddComputer etc but when I try for example AddRole it gives me back a zero as a result which tells me that it wasn´t successful, am I right? What can possibly be wrong?

The sccm.asmx seems to be working when I for example do a SearchComputerByName. Entered searchstring "DC" and entered my sitecode "PS1" and clicked Invoke. It found my DC01 server....all fine there it looks like.
So this leaves me with a faulty connection to MDT I suppose?

When I set up the MDT environment it was pretty straight forward but obviously I am missing some very important information here, but what?
The chapter 14 in the Windows-Noob book you talk about Bitlocker and I don´t want that in my Lab environment so my question is: Can I follow the steps in Chapter 14 but skip the parts about Bitlocker? Also, is the steps in this chapter necessary just to add Pretty Good Frontend?

One more question: how do I test Frontend.hta when I changed something in the file "Customsettings.ini" without insert the file into the .wim file and make a deployment? Right now I´m just starting the .hta file and hope for the best result. :) It always gets me the same Script error:
Error: The parameter is incorrect
Code: 0
URL: xxxxx/xxxx/xxxx/Scripts/ZtiDataAccess.vbs

It is this line from ZTiDataAccess.vbs:

If UCase(sMethod) = "POST" then
oLogging.CreateEntry "About to execute web service call using method " & sMethod & " to " & sURL & ": " & sEnvelope, LogTypeVerbose
-> oHTTP.open "POST", sURL, False, sUserID, sPassword
oHTTP.setRequestHeader "Content-Type", "application/x-www-form-urlencoded"
On Error Resume Next
oHTTP.send sEnvelope

I have the credentials specified in "Customsettings.ini". Also in IIS Webservices/application.

Share this post

Link to post
Share on other sites

  • 0

No I didn´t. Just added the WinPE-MDAC.
I am sure I have to read more about the steps in chapter 14 because now I am jumping around between the steps and doing wild guesses sometimes - which I know I shouldn´t do.

After adding WinPE-MDAC to the Boot Image the first try it just rebooted after I added some text in the Description field and pressed OK.
Did another try, added som text and pressed OK - nothing happens so I managed to get to view the logs.

It´s all a bit messy when doing like I do but I feel I am almost there. Never gotten so far before so it´s a big step forward. I just need to get the bits and pieces together to understand what I am actually doing. :-)

Here´s the recent error log.


Share this post

Link to post
Share on other sites

  • 0

Noticed a couple of things:

1. It reboots after adding text in HTA and pressed OK (as described in previous post) - but still adds the computer directly to SCCM. Without removing it from SCCM I tried once again and then it works.
2. The task sequence I have deployed is NOT an MDT Client Task Sequence....but instead a SCCM TS. That must be why it wont add computers to the MDT database?

Share this post

Link to post
Share on other sites

  • 0

The frontend now gives me a PC name based on whether it is a virtual machine, laptop or workstation and then adds a serial/tag number to it. In my case when testing with virtual machines it gives me a computer name like: VM-1234567
The computer adds in both SCCM and MDT so I am really happy about that. BUT.....still there seems to be a problem with my task sequences. It seems like I just have one last thing that I can´t figure out before I can say that I managed to get it working 100%. :-)
It says I don´t have any Task Sequence available to this computer. I have tried numerous different virtual computers but end up with the same result.

This time I really have no clue what to do.
I made new Task Sequences but it did not help. The one i had I changed the scheduling back 2 or 3 days but no luck.
Question, shouldn´t the TS show even if it´s done in wrong? I deployed the new TS to a Device collection and that shows up and is available in the Frontend. But when I click "OK" it givs the error about no TS available for this computer.
I checked that I didn´t lost my connection but all seems fine there.

Can you please advice? Where should I start looking?

Thanks! :-)




Share this post

Link to post
Share on other sites

  • 0

would you like me to do a teamviewer session with you, if so pm me your details and a time frame and i'll connect and have a look


but based on your error are you sure the computer is actually in a collection (and not obsolete) that is targeted with the deployment ?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.