Jump to content


anyweb

Configuring BitLocker in Intune - Part 3 testing the scripts

Recommended Posts

You may have already seen Part 2 of this series where you can automate BitLocker encryption in Intune using supplied MSI's, which contain logging, reboot prompt and other features.

I've put together this video to show you how you can test the PowerShell scripts contained within the two MSI's here. This allows you to test the scripts outside of Intune, and when you are happy with the results you can re-package them and deploy the MSI via Intune.

The video shows you how to use Psexec to start a process (in this example it's CMD.EXE) as SYSTEM.

psexec.exe /s /i cmd.exe

After starting the cmd prompt as SYSTEM, you can launch powershell. Next, browse to the folder where the scripts are, by default it's C:\Program Files (x86)\BitLockerTrigger and launch Enable_BitLocker.ps1.

image.png

After the TriggerBitlocker msi is installed by Intune on a Windows AutoPilot enrolled device, the PowerShell script will run via the Scheduled Task as SYSTEM, so this method of testing is a valid way to verify any changes you add to the PowerShell script before repackaging it as an MSI.

To see the video click below, have a look and happy troubleshooting.

cheers

niall

 

 

Share this post


Link to post
Share on other sites


Hi,

I'm  a bit new to all this... :)

I'm trying to run BitlockerTriggerUser on 2 Danish Windows 10 1803 installations, one on a Dell laptop and the other on a vm in Vmware Fusion with TPM enabled.
Both using Autopilot with the user not admin.

On the Dell laptop BitlockerTriggerUser runs fine, the HD gets Bitlocked.

But on the vm, nothing happens 😕
In c:\windows\temp there's no log-file, but in scheduled tasks MoveKeyToOD4B is set to run at 14:00

If I try manuel run the script with PsExec, as in the video, the script can't be run, because running scripts is disabled on this system.
If I run Set-ExecutionPolicy Unrestricted, the script runs fine. 

But why? 😕

Edit:

Just tried on Hyper-V, the same thing happens, as on VMware Fusion 😕

Edited by DimZen
New info

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...