Jump to content


Hasnat

SCCM 2007 OSD Issue with Cisco Catalyst 6509 DHCP across Vlans

Recommended Posts

I have SCCM 2007 Server, which is under VLAN15, i am using Catalyst 6509E as my DHCP with several VLANs. i have tested by creating a test dhcp pool range within same VLAN where my SCCM 2007 server resides, OSD (operating system deployment) deployment is successful without any errors. Across the VLANs i get errors while OSD deployment. under test DHCP pool i have added option 66, 67 plus i have also tried ip helper address under vlan interface but didnt help. Find my configuration for Servers VLAN and Client VLAN below.

 

By Client computer BIOS option are to boot from NIC.

 

 

 

Servers VLAN

 

----------------------------------------------------------

 

interface Vlan15

description SERVERS

ip address 172.20.15.1 255.255.255.0

 

 

 

Client VLAN

 

----------------------------------------------------------

 

interface Vlan30

ip address 172.30.10.20 255.255.255.0

ip helper-address 172.20.15.34

 

Note: 172.20.15.34 is my SCCM 2007 Server, i have also tried 172.20.15.1 as ip helper didnt help as well

 

 

 

Client DHCP Excluded Range

 

---------------------------------------------------------

 

ip dhcp excluded-address 172.30.10.20 172.30.10.50

 

 

 

Client DHCP Pool

 

--------------------------------------------------------

 

ip dhcp pool sccm

network 172.30.10.0 255.255.255.0

bootfile pxeboot

default-router 172.30.10.20

domain-name aou.edu.kw

dns-server 172.20.15.31 172.20.15.30

option 66 ip 172.20.15.34

option 150 ip 172.20.15.34

option 43 ip 172.20.15.34

option 67 ip 172.20.15.34

 

Note: 172.20.15.34 is SCCM 2007 Server

 

 

 

Errors:

 

If i remove ip helper from interface VLAN of client, Client takes IP address across VLAN but dont start OS deployment. i recieve below error.

 

PXE-E32: TFTP Open Timeout

 

 

 

If i provide ip helper address (SCCM 2007 Server ip address 172.20.15.34) under client VLAN i recieve below error.

 

PXE-T04: Access Violation

 

PXE-E36: Error Recieved from TFTP Server

 

PXE-M0F: Exiting Intel Boot Agent

Share this post


Link to post
Share on other sites

How can i check the pxe logs. can you kindly send me some links for checking pxe logs.

I have made a double check, boundaries are also added there. i have issue for deploying OSD across VLANs. under same VLAN OS deployment is fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...