Jump to content


Windows 11 22H2 OSD task sequence going to sleep on Dell Optiplex 7000

Recommended Posts

I have a OSD Task Sequence for Windows 11 22H2 being deployed to new Dell Optiplex 7000's. The Dell's are going to sleep during the "Setup Windows and Configuration Manager" step of the Task sequence. I have checked the "Run as high performance power plan" box in the more options tab, but the PC still goes to sleep. I have also tried using a run command to set the power plan to high performance "PowerCfg.exe /s 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c". The run command works fine in Windows PE, but doesn't persist when the task sequence boots into Windows to start the setup phase. I tried adding the run command right before the setup phase and right after the setup phase. No matter where I put the run command it doesn't seem to matter. If I don't touch the mouse or keyboard before the PC goes to sleep the TS halts. Once I shake the mouse it will continue where it left off. 

If I put the run command just above the "Setup Windows and Configuration Manager" It runs fine and if I hit F8 and run "powercfg /getactivescheme" it shows that the system is in high performance mode, but then when the system reboots into the installed OS the powerscheme has reset to balanced. If I put the run command after the "Setup Windows and Configuration Manager" step, then the pc goes to sleep because it runs after the fact. I guess I am asking how to set the powerscheme to high performance once the PC has booted into the installed OS but before the "Setup Windows and Configuration Manager" portion starts to run.

I saw some posts from years ago on Reddit talking about connected standby and using a registry setting to change it to disabled, however I still don't know where to put the reg tweak in my TS and it seems like the adition of the "Run as high performance power plan" option was supposed to fix this. Thanks

Share this post

Link to post
Share on other sites

I fixed the issue. I'll leave my solution here for anyone that might have the same issue in the future. 


I ended up running my Windows 11 build and capture task sequence over again but this time I added a step after the Setup Windows and Configuration Manager to set the power plan to High performance in my base image. Then I used the new base image with the High Performance power plan in an OSD task sequence. The PC stayed awake through the whole TS so I just added a step at the very end of the TS to set the power plan back to balanced. I use SCCM to control the Power settings of all devices so I am not sure if it was necessary to manually set the PC back to balanced, but at any rate my issue is solved. Thanks

  • Like 1

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.