Jump to content


emmathews83

How to create a Driver Package

Recommended Posts

Hello Everyone,

 

I am trying to create one image for multiple laptops, but now I'm getting stuck on the part that applies the driver package and was wondering if someone could give me a hand on how they did it. Here is what I did:

 

-First I copied the driver folders over from one of the Dell's that I am testing, it's an E6510: Now I copied over the folders that start with an R but the rest were created when I created the Driver package.:

 

post-6472-12816965226294_thumb.jpg,

 

-Next I imported the drivers into SCCM and created a package called Dell E6510 Drivers XP.

 

-After I did this I created a Task Sequence to install the Base Image with the drivers. I added the WMI Query to the step, but I was also trying to use the check box to select a Mass Storage driver but it will not find anything.

 

post-6472-12816965350489_thumb.jpg

 

Please help :huh:

 

 

Share this post


Link to post
Share on other sites


Hi,

 

Have you seen our docs on www.delltechcenter.com?? Specifically, take a look here: http://www.delltechcenter.com/page/Dell+Business+Client+Operating+System+Deployment

 

Hit the "Download the CAB Files" link to download drivers for the E6410.

 

Also from that page, you'll see that we have an XP WalkThrough as well as a "Vista WalkThrough" (this Vista Example is very similar to win7).

 

Dealing with Mass storage on XP is a bit of a pain, but if you follow the walk through, you should be able to handle it.

 

hope that helps,

 

Greg

Share this post


Link to post
Share on other sites

I followed the directions from the following site: My link

 

I download the cab file for the XP E6510 extracted the files like it said and created a Driver package, updated the distribution point twice.

 

Added the two Driver sequences to my Task Sequence, for both I added the WMI Query

SELECT * FROM Win32_ComputerSystem WHERE Model LIKE '%Latitude E6510%'

 

post-6472-12820508157226_thumb.jpg

 

post-6472-12820508356849_thumb.jpg

 

It went through the image install, but most of the drivers didn't install.

 

post-6472-12820508711206_thumb.jpg

 

Is there something else I'm doing wrong or have to do?

Share this post


Link to post
Share on other sites

ok assuming you have added ALL those drivers into the package as per the link (had to re-read your post, sorry) do you see the drivers listed anywhere on c:\drivers\?

 

i'll try and do a test here in my lab but it may be tomorrow before I post a result

Share this post


Link to post
Share on other sites

can you post the smsts*.log files please ?

Share this post


Link to post
Share on other sites

hmm i simply used the IRRT step (instead of both) and it installed all drivers perfectly on a Dell E4200 here

 

irrt.jpg

 

device manager

 

e4200.JPG

 

i didn't do Jason's step but it may help you, i don't have the same hardware as you so cannot test that model.

 

during the install a c:\_SMSTasksequence folder is created as normal and in there was drivers, along with several other folders number 1 to 31 or so, in addition there was a TEXTMODE folder with some iastor drivers *inf sys etc* and a TextSetup.OEM file which contained the following text

 

[Disks]

d1 = "OS Deployment Disk", \txtsetup.oem, \

 

[Defaults]

scsi = iaStor_ICH8MEICH9ME

 

[scsi]

iaStor_ICH8MEICH9ME = "Intel® ICH8M-E/ICH9M-E SATA RAID Controller"

 

[Config.iaStor]

value = "", tag, REG_DWORD, 1b

value = "", ErrorControl, REG_DWORD, 1

value = "", Group, REG_SZ, "SCSI Miniport"

value = "", Start, REG_DWORD, 0

value = "", Type, REG_DWORD, 1

 

[HardwareIds.scsi.iaStor_ICH8MEICH9ME]

id = "PCI\VEN_8086&DEV_282A&CC_0104", "iaStor"

 

[Files.scsi.iaStor_ICH8MEICH9ME]

driver = d1, iaStor.sys, iaStor

inf = d1, iaStor.inf

catalog = d1, iaStor.cat

 

Share this post


Link to post
Share on other sites

I tried doing what you did and got the same results, then I tried doing it the way Jason did it with running the extra command and it worked with one error.

 

While it's running the command it gives me the following error, I didn't get the screen shot of it while it was uploading the image, but was able to recreate the error trying to run the command in Windows when I tried it your way.

 

post-6472-12821418648245_thumb.jpg

 

Now when I hit cancel, it asks me if I want to continue setup without coping this file, I click Yes and it goes ahead and install the driver. Then I do a restart and everything is installed with no error messages in Device Manager

 

post-6472-12821422792854_thumb.jpg

 

 

Now I looked to see what driver it was and found out it was the video driver.

 

Also, when I restarted the computer it pops up the following boxes:

post-6472-12821423760378_thumb.png

 

post-6472-128214245092_thumb.png

 

post-6472-12821426357267_thumb.jpg

 

I click run on all fiive of these popups and everything seems fine till the computer restarts then it pops up those boxes again to run.

Share this post


Link to post
Share on other sites

maybe the files themselves are blocked (exe's) to unblock them right click and choose unblock or copy all the drivers to a FAT file system then back to the drivers folder and then repackage them.

 

there is one other option, in the Apply Drivers package step, select 'Do unattended installation of unsigned drivers on Versions of Windows where this is allowed@

 

but at least you are getting somewhere,

Share this post


Link to post
Share on other sites

I went in and edited the install file for the driver now it doesn't give me the copy error it give me the message saying this isn't a trusted driver do you want to continute the install or stop the install. So I click continute the install and it works fine. I still get the popups after I can login to windows, but I will give it a try with checking the 'Do unattended installation of unsigned drivers on Versions of Windows where this is allowed'

 

By the way thanks for all your help so far. :D

Share this post


Link to post
Share on other sites

What model system did you use to capture the .wim file? If that original capture contained any of the same drivers that are on the target hardware, you need to have an entry in sysprep.

 

 

UpdateInstalledDrivers=Yes

 

This goes into the Unattend section of sysprep.inf. See here for more information. http://support.microsoft.com/kb/302577

 

You can dynamically apply this during your task sequence, in the "Apply Operating System" step.

Share this post


Link to post
Share on other sites

I created the image on a E6510, but what I did was only install the ethernet driver. Then I updated everything I wanted for the image. When that was complete, I removed the ethernet driver and deleted the Dell Driver folder that it created when I installed the ethernet driver. This way it was just the windows image with the programs I want, but no drivers. When I did the capture I just saved the .wim file to the C: drive of that machine, then I copied it to the server.

Share this post


Link to post
Share on other sites

Is this your first attempt using OSD, or are you deploying others successfuly? For the record, Deploying XP is harder than vista and win7 :(.

 

Looking at your first image in this post, I see you have GUIDS, as well as R numbers. That driver package source directory should not look like that.

 

If you're in a test environment, I recommend you (from the admin console, delete all drivers, and all driver packages, and start over, then walk through the steps I referenced from delltechcenter - if we can get back to that basic, we should be able to help you better. Use the .CAB download for XP on the 6410 on delltechcenter, and follow that process to import them - don't add anything to the driver package source.

 

oh yea, side note - I would still include this entry in sysprep.inf: UpdateInstalledDrivers=Yes . . . . for me, better safe than sorry.

Share this post


Link to post
Share on other sites

This is my first time using SMS/SCCM 2007 in my life.

 

The driver package has been changed, it looks like this now.

 

post-6472-12823069426721_thumb.jpg

 

That is what is created when I created the driver package. The drivers are from that website, but I downloaded the E6510 package instead of the E6410 package.

 

This is what the TS looks like now also.

 

post-6472-12823071059431_thumb.jpg

 

Now I run the RunDLL32.exe command because if I don't it will not apply the drivers. But this is also where I get the saying "this isn't a trusted driver do you want to continute the install or stop the install" but I click continue and it installs fine. Then once you login to windows is where I get the popups and I did find out as long as I uncheck the box that says "Always ask before running this file" and click run they don't show up after the restart anymore.

 

post-6472-12823073429327_thumb.jpg

Share this post


Link to post
Share on other sites

If i don't run the task RunDll32.exe it won't auto install the drivers. I will update the sysprep file and give that a try.

 

Below is a copy of it, is there anything else you think i should add to it?

 

sysprep2.txt

Share this post


Link to post
Share on other sites

give it a try, Greg's advice is great :)

Share this post


Link to post
Share on other sites

Ok since i changed the sysprep file in my image and took out the RunDll32.exe command it does not ask me to click anything anymore for the video driver for the E6510, I added the E6410 and E6500 and that's fine also. The only problem yet is after you login to Windows for the first time I still get these pop ups.

 

post-6472-12825937634719_thumb.png

 

(One side note I did add the E6410 and E6500 Driver package to my TS last Friday and it never gave me an issue with the video drive like the E6510)

 

I changed the Driver Singing Options to Ignore and Make that the default action and it still has them popup.

 

I found that from this website:

 

Driver Signing

 

 

In the above website I found this:

 

To disable the warning start the Group Policy Editor (Start > Run, type

-gpedit.msc- and press OK) and go to:

 

-User Configuration > Administrative Templates > Windows Components >

Attachment Manager- then set -Inclusion list for low file types- to

Enabled and enter the file types you don't want to be warned about in

the box (for example: -.htm;.exe-).

 

I'm just not sure that's a good ideal or is it? I mean if a virus gets in with a .exe won't it just run it. It works, but I would rather have the user's click the extra step.

Share this post


Link to post
Share on other sites

doesn't matter if the post is old, whats your query ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...