Jump to content


Error “The WebDAV server extension is either not installed or not configured properly” in Configuration Manager 2007

Recommended Posts

We have seen couple of cases on this issue here in product support recently and since I didn't see the information documented on our site anywhere I thought it would be worth a mention here.




The SMS Site Component Manager fails to install the SMS_MP_CONTROL_MANAGER component on the on server. The error is as follows:


The WebDAV server extension is either not installed or not configured properly.

Solution: Make sure WebDAV is installed and enabled. Make sure there is an authoring rule that allow “All users” read access to “All content”. Make sure the WebDAV settings “Allow anonymous property queries” and “Allow property queries with infinite depth” are set to “true” and “Allow Custom Properties” is set to false.


If you go to the IIS management console, connect to the local server and open the “WebDAV Authoring Rules” option you will find everything enabled but it still doesn't seem to recognize it.




This can occur if the settings for the WebDAV Authoring Rules become out of sync with the WebDAV_schema.xml file.




We need to go the location of the configuration file of Webdav which is C:\Windows\System32\inetsrv\config\schema\WebDAV_schema.xml. After opening this file you may notice that the settings in this file were different from the settings that were configured in the IIS Manager. The settings were configured as:


<attribute name=”allowAnonymousPropfind” type=”bool” defaultValue=”false” />

<attribute name=”allowInfinitePropfindDepth” type=”bool” defaultValue=”false” />

<attribute name=”allowCustomProperties” type=”bool” defaultValue=”true” />


However they should be:


<attribute name=”allowAnonymousPropfind” type=”bool” defaultValue=”true” />

<attribute name=”allowInfinitePropfindDepth” type=”bool” defaultValue=”true” />

<attribute name=”allowCustomProperties” type=”bool” defaultValue=”false” />


After correcting these settings (remember we have to take ownership of the file to be able to change it) and restarting the World Wide Web Publishing Service and the SMS_SITE_COMPONENT_MANAGER the Management Point should install correctly. You can check if the installation is successful in the log file MPSetup.log in your SCCM\Logs directory. If successful the log should have entries similar to this:



<04-01-2010 13:15:58> ======== Completed Installion of Pre Reqs for Role SMSMP ========

<04-01-2010 13:15:58> Installing the SMSMP

<04-01-2010 13:15:58> Passed OS version check.

<04-01-2010 13:15:58> IIS Service is installed.

<04-01-2010 13:15:58> checking WebDAV configuraitons

<04-01-2010 13:15:58> WebDAV is configured

<04-01-2010 13:15:58> No versions of SMSMP are installed. Installing new SMSMP.

<04-01-2010 13:15:58> Enabling MSI logging. mp.msi will log to E:\SCCM\logs\mpMSI.log


<04-01-2010 13:16:32> mp.msi exited with return code: 0

<04-01-2010 13:16:32> Verifying CCM_CLIENT virtual directory.

<04-01-2010 13:16:32> Website path is IIS://LocalHost/W3SVC/1.

<04-01-2010 13:16:32> Connecting to IIS.

<04-01-2010 13:16:32> CCM_CLIENT is currently E:\SCCM\Client.

<04-01-2010 13:16:32> Installation was successful.


Note: As you do any time you modify an XML file, please make a backup of WebDAV_schema.xml before making changes to it.


Hope this helps!


Ankur Srivastava


see also > http://www.windows-noob.com/forums/index.php?/topic/1513-install-webdav-in-server-2008-r2-for-sccm-2007/


via > http://blogs.technet.com/b/configurationmgr/archive/2010/10/26/error-the-webdav-server-extension-is-either-not-installed-or-not-configured-properly-in-configuration-manager-2007.aspx

Share this post

Link to post
Share on other sites

Hi, Same problem here, so I manually made the changes and restarted services (and eventually the server) with no success. When pushing to clients or running ccmsetup.exe locally I also see this message:


Failed to successfully complete HTTP request. (StatusCode at WinHttpQueryHeaders: 404)


Which I'm assuming is related.


Per the other suggestion on removing the MP after making the change I tried that too. I just deleted the MP and re-created. Watching MPSetup.log I see it says WebDAV is not setup appropriately (and notes the 4 settings that should be changed).


Some additional info that may or may not be of use:


This is a site restore, moved it from Server 2003 to Server 2008 R2 and there were no issues prior to the move.


Any advice would be really appreciated.




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...