Jump to content




Sign in to follow this  
anyweb

How can I install a Web Service ?



Recommended Posts

In this example we will install Maik Kosters excellent web services (7.2) on our SCCM server (which is already running IIS).

 

 

Installing the Web Service

 

Step 1. Download the files from this codeplex site

 

Step 2. Extract the content of the zip file into a folder on your Webserver

 

downloaded fils.jpg

 

Step 3. Copy the contents to your webserver root, rename the folder to something like NEWWebservice

 

newebservice.jpg

 

Step 4. Add the folder as a new Application to IIS (Step by Step Guide IIS 6 | Step by Step Guide IIS 7), Start IIS manager, expand Sites, right click on Default Web Site and choose Add Application.

 

add application.jpg

 

Step 5. Specify an "Alias" (the name you would like to use to access the Webservice, lets call it NewWebService) and the physical path to the extracted content of the webservice eg: c:\inetpub\wwwroot\NEWWebService

 

physical path.jpg

 

At this point the webservice is accesible (in internet explorer http://sccm/newwebservice/sccm.asmx ) but you cannot do anything with it (as it doesn’t know how to communicate with your SCCM site…) until you’ve done some final configuration…

Share this post


Link to post
Share on other sites


Step 6. Refresh Default Web Site

 

Right click on Default Web Site, click Refresh (if you don’t do this the New web Service will still appear as a folder in IIS instead of as an Application.

 

refresh.jpg

 

Step 7. Add Application Pool

 

In IIS Manager, locate Application Pools, right click and choose Add Application Pool,

 

add application poool.jpg

 

give it a name such as New Web Service and click ok

 

new web.jpg

 

Step 8. Configure Application Pool

 

Now you can configure this Application Pool to use a Different User Account for running your Webservice. To do this Open IIS Manager, expand your Webserver Node and click on Application Pools. Right click your Application Pool on the right side and choose Advanced Settings... In the Process Model area click in the Identity field and then click on the ... Button

 

configure app.jpg

 

Choose Custom account and click on Set...

 

custom account.jpg

 

 

Step 9. Configure the Webservice to use the application Pool

 

Open IIS Manager, expand your Webserver node and Sites node, expand your Default Web Site node, Right click on the NewWebService folder and choose Manage Application - Advanced Settings...

 

advanced.jpg

 

In the General area click into the Application Pool field and then click on the ... Button

 

deaultapppool.jpg

 

choose the appropiate Application Pool (called New Web Service) click OK, OK

 

ok ok.jpg

Share this post


Link to post
Share on other sites

Step 10. Configure Application Settings

Next we need to configure the application settings (Step by Step Guide) , failure to do so will mean the webservice cannot do anything.

Open IIS Manager, expand the Webserver Node, expand the Sites Node, expand your Default Web Site, click on the Deployment Webservice Folder/Application (NewWebService) and then double click on the Application Settings Icon on the right side.

app settings.jpg

And enter the appropriate details…

app settings entered.jpg

The following are configurable:-

By default, the webservice will use the configured application pool user for authentication. It requires only a couple of Application Settings to be set:

RootServer - The SCCM Root Server
SLPServer - One SCCM Server with the SLP Role
RootSiteCode - The Root site code

For Access to the MDT Database you need to configure at least

MDTDBServer - The MDT Database server (with Instance if necessary)
MDTDBName - The MDT Database name
MDTDBIntegratedSecurity - Set to "True" if you want to use the application pool account for authentication. If set to "False" you need to supply the following two settings
MDTDBUser - Username to access the MDT Database
MDTDBPassword - Password to access the MDT Database

For Active Directory access, you can optionally configure the following Application Settings. This is only necessary, if the application pool user account does not have enough permissions to do execute the required functions, and/or if you need to access a different domain as the application pool User is member of:

ADDomain - Domain to query (use either "domain.com" or "DC=Domain,DC=COM" format)
ADUsername - Username for authentication
ADPassword - Password for authentication

You will note i didn't configure any of the MDTDB settings as I'm not using them currently in my environment.



Step 11. Test the New Web Service

You should now be able to use the Webservice. To test the functionality just open your favourite Browser and point it to

http://sccm/NewWebService/ad.asmx- For Active Directory related functions
http://sccm/NewWebService/mdt.asmx- For MDT related functions
http://sccm/NewWebService/sccm.asmx- for SCCM related functions.

web services in ie.jpg

 

Troubleshooting

 

To troubleshoot when things are not working, browse to the LOGS folder of where you installed the Web Service, and you should see Trace, Debug and Info logs, open them in CMTrace to review.

Share this post


Link to post
Share on other sites

What permissions did you assign to your Application Pool identity? WMI permissions?

 

When i did the installation I had to use local system account to be able to make queries.

Share this post


Link to post
Share on other sites

are you clicking on NewWebservice in IIS ? yes you can post images here using the Image icon when you post

Share this post


Link to post
Share on other sites

Yes, i think i have everything correct. I have been trying for a while and always got stock at this step.

When i try to post a pic, i need to point to URL? sorry for the questions, but dont know where/how i can upload a pic.

Share this post


Link to post
Share on other sites

I got it. Sorry for multiple post. If anyone else is havign same issue here is the fix:

If you don't see the expected version of ASP.NET listed under "Web Service Extensions", it's typically because IIS was installed after .NET. You can run the aspnet_regiis.exe utility to remedy this:


  • Get to a command prompt, e.g. Start>Run "cmd".

  • Enter "CD /D C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322" or "CD /D C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727" depending on which version of ASP.NET.

  • Enter "aspnet_regiis.exe -i".

  • Wait for the finished message; "Start installing ASP.NET (1.1.4322.0)" or "Start installing ASP.NET (2.0.50727.0)" depending on which version of ASP.NET.

  • Follow the previous set of steps to enabled ASP.NET in Web Service Extensions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×