Jump to content


MattW

SCCM2012 OSD "NoReply"

Recommended Posts

Hi folks,

 

Been trying out the new version of SCCM and run into a bit of a brick wall. I have SCCM2012 installed on one VM (2008 R2, which is also the mini-lab DC) and a seperate VM running SQL 2008. I`ve installed the WDS role (both bits) and enabled PXE on the DP, made both boot images available for PXE and distributed them to the DP (and the DP Group for good measure). Next, I installed the DHCP role on the SQL box, added option 66 & 67 so it knows where to go (pointing at boot\x86\wdsnbp.com (tried smsboot too)), added my Win7 image and knocked up a basic deploy task sequence.

 

Now when I make a 3rd VM (all this is in VMware Workstation btw) and try to network boot it fails when trying to contact SCCM then goes into pxeboot.com and eventually dies. In the SMSPXE.log file I see the following :

 

<![LOG[reply from server is 'NoReply']LOG]!><time="17:45:32.414-60" date="05-04-2011" component="SMSPXE" context="" type="3" thread="4228" file="libsmsmessaging.cpp:2108">

<![LOG[PXE::DB_LookupDevice failed; 0x80004005]LOG]!><time="17:45:32.414-60" date="05-04-2011" component="SMSPXE" context="" type="3" thread="4228" file="database.cpp:187">

<![LOG[PXE Provider failed to process message.

Unspecified error (Error: 80004005; Source: Windows)]LOG]!><time="17:45:32.420-60" date="05-04-2011" component="SMSPXE" context="" type="3" thread="4228" file="pxehandler.cpp:1364">

 

After several hours messing about with PXE, installing certificates and poking into every nook and cranny of SCCM I then remembered I was being an idiot, and could just use the TS Media ISO to test this. So I created one of those, pointed it at my MP and fired up the 3rd VM again. That didnt go so well either, and the SMSTS.log file shows this :

 

<![LOG[Requesting client identity]LOG]!><time="17:14:20.171+480" date="05-04-2011" component="TSMBootstrap" context="" type="1" thread="1112" file="libsmsmessaging.cpp:5700">

<![LOG[CLibSMSMessageWinHttpTransport::Send: URL: DC2008SCCM2012.BETA.HOME.LOCAL:80 CCM_POST /ccm_system/request]LOG]!><time="17:14:20.171+480" date="05-04-2011" component="TSMBootstrap" context="" type="1" thread="1112" file="libsmsmessaging.cpp:8720">

<![LOG[Request was succesful - 200]LOG]!><time="17:14:20.187+480" date="05-04-2011" component="TSMBootstrap" context="" type="0" thread="1112" file="libsmsmessaging.cpp:9046">

<![LOG[reply from server is 'NoReply']LOG]!><time="17:14:20.187+480" date="05-04-2011" component="TSMBootstrap" context="" type="3" thread="1112" file="libsmsmessaging.cpp:2108">

<![LOG[DoRequest (sReply, true), HRESULT=80004005 (e:\nts_sccm_retail\sms\framework\osdmessaging\libsmsmessaging.cpp,5798)]LOG]!><time="17:14:20.187+480" date="05-04-2011" component="TSMBootstrap" context="" type="0" thread="1112" file="libsmsmessaging.cpp:5798">

<![LOG[Failed to get client identity (80004005)]LOG]!><time="17:14:20.187+480" date="05-04-2011" component="TSMBootstrap" context="" type="3" thread="1112" file="libsmsmessaging.cpp:6047">

 

Again there's that "NoReply" message. Now the TS i made is advertised deployed to a collection I made where I imported the computer MAC address. I even imported the GUID and no joy. I then tried deploying the TS to the Unknown Computers collection but I`m getting nowhere. I`ve come to the conclusion that SCCM just doesnt know about the target computer hence the messages even though I`ve imported it a few times (and tried a different VM to get a different MAC just in case). Oh and I made sure my boundaries included the subnet not just the AD Site just in case that made some difference to it (it didnt).

 

I`m guessing its something to do with the Management Point somewhere along the line, but I`ve made sure that has its Root CA cert imported (Certificate Services role as Enterprise Root CA on the DC) and there are no errors in the log so I`m kinda stumped. I could just rebuild the whole thing from scratch but I wondered if anyone here had any bright idea's before I have to do that as it's either a "feature" i`ve bumped into, or i`m doing something wrong somewhere and rebuilding it will just waste another day and I get the same problem again :)

 

Only thing I cant test at the moment if this is as a result of doing it in VMware - I have a fully working 2007 lab on the same VMware install which does PXE boot a VM and build it, but maybe 2012 is not quite as happy with this...

 

All suggestions welcomed!

 

Matt

Share this post


Link to post
Share on other sites

It's not needed to configure DHCP Option 66 and/or 67. Only DHCP Option 60 is needed when DHCP and WDS/PXE are on the same server...

 

 

Hi Peter,

 

The WDS/PXE is on one server (the SCCM one) and DHCP is on a different server (SQL) which is why I configured them - from what I understand you shouldnt really have to do that but I`ve found that it doesnt work properly if you dont (things like No Boot File etc).

 

 

**edit** also this isnt about PXE as such due to the same error cropping up when using TS Media - more to do with SCCM not recognising the computer - some sort of uber unknown device

 

Cheers,

 

Matt

Share this post


Link to post
Share on other sites

I`m guessing its something to do with the Management Point somewhere along the line, but I`ve made sure that has its Root CA cert imported (Certificate Services role as Enterprise Root CA on the DC) and there are no errors in the log so I`m kinda stumped. I could just rebuild the whole thing from scratch but I wondered if anyone here had any bright idea's before I have to do that as it's either a "feature" i`ve bumped into, or i`m doing something wrong somewhere and rebuilding it will just waste another day and I get the same problem again :)

 

I have to say that I didn't read this part the first time good :)

Does this mean that you are running in Native Mode, or that you just 'messed' with the Certificates?

Share this post


Link to post
Share on other sites

Hi Peter - definitely messed with certs. I installed SCCM in mixed mode and have configured as much as I can to use HTTP but I noticed that it seemed to require a root CA certificate so as a long shot I installed an enterprise root CA, exported the cert and imported it into SCCM. The only other certificate related work I did was installing the root CA cert and the OSD self signed cert into Trusted Root Certificate Authorities store on the SCCM server.

 

More of a blind stab in the dark rather than a calculated move but either way it hasnt made much difference!

 

matt

Share this post


Link to post
Share on other sites

Hi,

 

Just a quick (and unhelpful) update - I gave up on this in the end and reinstalled the lab from scratch (everything on a single VM this time) and OSD works flawlessly now so I can only attribute this to some sort of installation mishap or user incompetance :unsure:

 

Cheers,

 

Matt

Share this post


Link to post
Share on other sites

i want to update this post, basically the reason you had the issue was because of a bug in Beta 2 (listed on connect here) listed below.

PXE::DB_LookupDevice failed when trying PXE Boot

 

Type: Bug ID: 676428 Opened: 6/22/2011 2:43:39 AM

 

to resolve check site properties, advanced after unchecking the "This site only manages config manager 2012 clients" PXE boot started working

 

f.y.i (i saw the same bug in Beta 2 today when rebuilding a lab (cas+primary+ad1) from scratch.

Share this post


Link to post
Share on other sites

i want to update this post, basically the reason you had the issue was because of a bug in Beta 2 (listed on connect here) listed below.

PXE::DB_LookupDevice failed when trying PXE Boot

 

Type: Bug ID: 676428 Opened: 6/22/2011 2:43:39 AM

 

to resolve check site properties, advanced after unchecking the "This site only manages config manager 2012 clients" PXE boot started working

 

f.y.i (i saw the same bug in Beta 2 today when rebuilding a lab (cas+primary+ad1) from scratch.

 

Thanks. I actually checked the "This site only manages config manager 2012 clients" box while flailing helplessly trying to get my PXE boot to work. Of course after taking several baby steps forward I ran into an issue where after launching into wdsnbp.com it would say "No response from Windows Deployment Services server" and then try to force run pxeboot.com. After that it would come up with the following error:

 

Windows Failed to start. A recent hardware or software change might be the
cause. To fix the problem:
1. Insert your Windows installation disc and restart your computer.
2. Choose your language settings, and then click "Next."
3. Click "Repair your computer."
If you do not have this disc, contact your system administrator or computer
manufacturer for assistance
File: \Boot\BCD
Status: 0xc000000f
Info: An error occurred while attempting to read the boot configuration
data.

 

I checked the SMSPXE.log, copied the error into the google, and made it here and unchecked the box.

Share this post


Link to post
Share on other sites

 

Thanks. I actually checked the "This site only manages config manager 2012 clients" box while flailing helplessly trying to get my PXE boot to work. Of course after taking several baby steps forward I ran into an issue where after launching into wdsnbp.com it would say "No response from Windows Deployment Services server" and then try to force run pxeboot.com. After that it would come up with the following error:

 

Windows Failed to start. A recent hardware or software change might be the
cause. To fix the problem:
1. Insert your Windows installation disc and restart your computer.
2. Choose your language settings, and then click "Next."
3. Click "Repair your computer."
If you do not have this disc, contact your system administrator or computer
manufacturer for assistance
File: \Boot\BCD
Status: 0xc000000f
Info: An error occurred while attempting to read the boot configuration
data.

 

I checked the SMSPXE.log, copied the error into the google, and made it here and unchecked the box.

 

I have the same problem. Does anyone have a solution for this problem?

Share this post


Link to post
Share on other sites

Hi all,

 

I'm running into the same issue with the RC version of SCCM 2012.

Since the "site properties, advanced after unchecking the "This site only manages config manager 2012 clients"" apparently has been (re)moved, how do I fix this problem?

 

Regards.

Share this post


Link to post
Share on other sites

It is currently in the Site Properties of your site, under the Signing and Encryption tab, It was re-worded and now says: Require SHA-256.

 

require SHA-256.png

Share this post


Link to post
Share on other sites

Have you checked you BIOS settings of the machine you're trying to build to ensure the date and time is correct? If this is wrong, the OSD certificates that need to be downloaded cannot be authenticated hence the auto reboot each time.

Share this post


Link to post
Share on other sites

So just something that I've recently found out about this... is that the 0xc0000000f error is coming from the fact that the box was at some point PXE'd before and got to the WinPE, but the WinPE or imaging never was completed. SCCM then creates a computer account called "Unknown" in the assets database. Do a search of all assets for the word "unknown" and you'll see a CRAPLOAD of computers in there if you do a bunch of PXE boots. Once you delete those, (NOT the 2 that say "unknown computer (x86)" and "unknown computer (x64)") and re-pxe the box, it works fine.

 

Bug in SCCM 2012?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...