Jump to content


ashridge uk

Require administrator approval if users request this - greyed out?

Recommended Posts

Hi,

 

Every time I create an application using the msi method as instructed, when deploying I cannot use the "require administrator approval if user's request this application" tick box.

 

It is always greyed out?

 

I would really like to see the work flow for requests/approval

 

Is there a setting I need to enable somewhere?

 

Everything else is working well ;-)

Share this post


Link to post
Share on other sites


Do you installed the following Roles:

  1. Application Catalog web service point
  2. Application Catalog website point

When you want to have a Approval it is necessary (from my point of view) to have this!

Share this post


Link to post
Share on other sites

show me a screenshot of what you are seeing

Share this post


Link to post
Share on other sites

post-15045-0-45142100-1331217806_thumb.jpg

 

Hi Guys,

 

Thanks for coming back! Yes I have both roles installed and working with no error messages, here is a screenshot of the deploy application wizard that always 'greys' out the option to require administrator approval.

Share this post


Link to post
Share on other sites

what collection is it Deployed to ?

Share this post


Link to post
Share on other sites

correct, you must deploy it to a User collection :)

try it and see

Share this post


Link to post
Share on other sites

well it's not that obvious and I just checked the Docs, they state

 

Require administrator approval if users request this application – If this option is selected, the administrator must approve any user requests for the application before it can be installed. This option is unavailable when the deployment purpose is Required.

 

 

030c41d9079671d09a62d8e2c1db6973.gifNote Application approval requests are displayed in the Approval Requests node, under Application Management in the Software Library workspace. If an approval request is not approved within 45 days, it will be removed. Additionally, reinstalling the Configuration Manager client might cancel any pending approval requests.

 

which still doesn't reveal that you must Deploy to a User collection in order for this option to be valid, however the actual option "Require administrator approval if users request this application" does mention users specifically and not Systems/Devices so hopefully that clears it up

 

cheers

niall

Share this post


Link to post
Share on other sites

i've alerted the DOCS team and they will change the wording to spell this out clearly during the next scheduled Documentation Update

Share this post


Link to post
Share on other sites

you can't it's a one time deal, you can however delete the application deployment and start again

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...