Jump to content

  • 0

Trying to deploy Win 8 ENT to HP Elitepad 900




Short version:

Tried deploying win 8 to HP Elitepad tablet computers.


When trying to deploy over PXE, I encountered some issues (more here http://www.windows-noob.com/forums/index.php?/topic/8045-trying-to-deploy-over-pxe-uefi-x86-with-wds-2012/), I think they're related to pxe booting a x86 uefi machine, which my wds 2012 doesn't seem to like...


After a couple of days I thought why not try to deploy it over USB, created a task sequence, configured media on the WDS and tried deploying it. At first I hit some issues related to disk partitioning, that seemed to be resolved, but maybe it isn't entirely.


What happens now is:

- Elitepad boots on USB

- Task sequence performs a few tasks

- prepares

- formats the disk (uefi)

- injects drivers

- uses imagex to expand the previously captured .wim

- reboots


Then when rebooting I get a new style of blue screen.

This shows:



the operating system couldn't be loaded because a critical system
driver is missing or contains errors
file: \windows\system32\drivers\megasas2.sys
Error Code: 0xc000035e
I suppose it has something to do with drivers for the storage controller, but I don't quite get what's wrong, the drivers are installed correctly in the .wim, so after restoring that should be ok, and also they are injected during the earlier phases.
I think it may have something to do with which partition is active, but I can't seem to get it resolved.
Any thoughts/ideas/... ?


Share this post

Link to post
Share on other sites

Recommended Posts

  • 0

Ok nevermind that, seems I needed to add some generic drivers to the .wim file

Installation does proceed now but seems to be stuck at the Welcome / Login screen


You see


Circle thing turning Welcome


Then after a long time, you get:

Unable to find litetouch.wsf needed to continue this deployment


Any thoughts ?

Share this post

Link to post
Share on other sites

  • 0

Just started this partcular model and so far it has been very painful to say the least. I eventually got it PXEing by installing SCCM 2012 sp1 CU1 to my site server, there is additional functionality within this update that allows you to PXE boot this type of device. Have to say once installed it PXE'd as it should...bit slow though.


Next barrier was the famous restart after the boot.wim has been downloaded(even after injecting the winPE4.0 into the new boot.wim). I had to also inject the management pack into the wim file which contains network drivers and storage drivers. Now my task sequence is selectable.(Eventually)


After a few attempts the partioning did'nt seem to be right, it bombed out when trying to apply the OS. A few tweeks to the partitions and I have it just imaging now,(applying OS as i write).....I am doubtful for a successful OSD as there are a couple of other steps that HP reccommend after the winPE enviornment, it consists of 2 seperate packages, a root certificate update and a BIOS firmware update.


Time will tell.


EDIT: Well it finished but failed at the root certificate installation ( I see why...a typo mistake on my behalf).....Other than this the device is functional bar a few drivers missing which are hopefully contained within the 2 extra packages that HP recommend.


goudviske If you need to get PXE working you will have to install CU1.

Share this post

Link to post
Share on other sites

  • 0

Just after successfully imaging 5 HP elitepad 900s' (UEFI) via PXE with windows 8 x86, all drivers and other software installed also with task sequence.

Will try and post a basic guide of steps required if time is on my side...


Rocket Man

Share this post

Link to post
Share on other sites

  • 0

Well it definitely shows an EFI partition in disk management on my imaged ElitePads with windows 8 x86

Partition1: 300mb (Recovery)

Partition2: 500mb (EFI)

Partition3: xxGB Windows ©


Would I be right in saying that this is an EFI build?


Have been busy creating images for other new devices this week so have not had a chance to get this basic guide done.

Niall gave a good post on the windows surface pro, it is very similar to this but obviously drivers are different and a few other steps that HP recommend(1 of which needed to be altered to suit my enviornment).


EDIT: And just to add HP dont supply drivers for windows8 x64 for these systems!

Share this post

Link to post
Share on other sites

  • 0



For those of you who are eager to get PXE working with this type of device you will have install CU1 on your SCCM server. It is a relatively easy install. Once installed you can deploy the client/console updates as you wish (I haven’t done either as of yet).


The first thing to do is get the HP drivers for this device from here

Basically I just downloaded the Manageability Packs (WinPE4.0 and x86 Driver Pack).

I created a driver pack out of the following folders that were extracted from the driver pack sp61365

  • Software - System Management
  • Driver – Storage
  • Driver – Network

DO NOT leave the Driver - Firmware and Chipset folder in this driver package. A package has to be created out of this and deployed with the task sequence after WinPE environment. (There is a pdf file contained within this folder and a driver file which needs to be extracted).


DO NOT leave the Operating System – Enhancement folder in the driver package either as this empty anyway and gives guidance on another task that has to be carried out after WinPE environment also. (Will cover this in the Task sequence explanation in a bit.)


For testing purposes I created a new x86 boot.wim specifically for Win8 deployment and injected the HP WinPE4.0 driver pack into it and I also added the drivers from the previously created driver pack also.

With this now done your HP ElitePad should be booting now and picking up any available task sequences!!

Now to the good part of getting ready the extra packages needed to successfully deploy these devices.


Download the following update Windows8-RT-KB2756872-x86.msu from here and create a package out of it with a command line as so wusa.exe Windows8-RT-KB2756872-x86.msu /quiet /norestart.


From the Driver - Firmware and Chipset folder that was downloaded with the driver pack, extract the sp60725 file. This will have quite a few folders and files all of which are needed and a package created from, there is no need to create a program for this package as HP recommend a run command line to initiate the installation according to the PDF file that comes accompanied with it. (I changed this as you will see, for my own purposes).


It is also recommended that you create a package out of the root cert update that can be got from here http://support.microsoft.com/kb/931125. Create another package out of it with a program command line like this rootsupd.exe /Q.

Distribute all of these packages out to your DPs.


If you haven’t already done so, which I can assume you already have is create a windows8 x86 image from the media and import it into SCCM. I did not use the standard install.wim from the media but instead built an image on a Hyper-V VM via the OEM media and installed .net3.5 features (for my own needs) before capturing it again.


Now create your windows 8 Task sequence and select the appropriate wim image. You should have a Task sequence that looks like so:


Sorry for the bad images!!


Attach your driver package and appropriate query. And now attach the extra packages in the order seen below:




The first step after setup operating system is to install the KB update. This will take a while and will restart your system even though the norestart switch has been specified in the command line. The second step which I altered for my own purposes was to copy the contents of the BIOS Update package which we created from the sp60725 file. This is a run command line like so

xcopy “.\*.*” “C:\BiosUpdate” /D /E /C /I /Q /H /R /Y /S

Don’t forget to reference the BIOS update package within the run command line task!!


Next step is attach the root cert update package. Now we have to install the Bios Update that we copied to the local system in the previous step. This is done with a run command line step and a command like so:

C:\BiosUpdate\FDSetup.exe –s –f


This will execute the Bios Update locally on the system and it will take a while. It is recommended to place a restart command after this task also which I have done. And then after this I created a script that will delete the BiosUpdate folder from the C:\ drive because space is already problem with my devices…… 32GB!!!

NB* The reason as to why I copied the Bios update folder locally and then executed it with a run command line is because I access content directly from the DP. Doing these steps allowed me to continue my OSD task sequence via accessing the DP instead of downloading all content locally first(which is slow), but if you go by HP guides from within the accompanied pdf this is how you have to deploy your Task sequence(download all content locally) otherwise it will fail at the BIOS update installation!





Share this post

Link to post
Share on other sites

  • 0

Will check this out when I am back in the office later on today and get back.


Seems to be everyone was having problems imaging these devices, I even had our HP supplier making enquiries to my superior yesterday asking to give details on how I imaged it. Well there it is, hopefully it will help others out!!

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.