Jump to content


Sign in to follow this  
mose@CP

\boot\bcd error

Recommended Posts

I am on a deadline and desperately needs some experienced help.

 

We have a Windows Server 2003 R2 w/ SP2 that we installed WDS on. This server is on a virtual machine and DHCP is on a seperate server.

 

DHCP options 66 and 67 have been set.

Option 67 is set to: \boot\x86\pxeboot.com

 

I had to set the options otherwise my client system would not obtain an ip address.

 

I opened the TFTP ports on the WDS server and the Server is running in native mode.

 

I used the boot.wim from AIK and we are trying to deploy a XP pro image. The image was captured using imagex.

 

When I boot my client system, I get the ip address from DHCP, I press F12 to network boot, and then I get this errror:

 

File: \boot\BCD

Status: 0xc000000f

Info: An error occurred while attempting to read the boot configuration data.

 

I have been stuck on this for a week and desperately need some insight.

 

I have viewed my default.BCD file and this is what is shows:

 

Windows Boot Manager

---------------------------

identifier {bootmgr}

inherit {dbgsettings}

timeout 30

 

Debugger Settings

---------------------

identifier {dbgsettings}

debugtype Serial

debugport 1

baudrate 115200

 

Device options

-----------------

identifier {68d9e51c-a129-4ee1-9725-2ab00a957daf}

ramdisksdidevice boot

ramdisksdipath \boot\boot.sdi

 

 

Is there something missing and how do I correct it?

Share this post


Link to post
Share on other sites


is there a switch of any sort in between the server and client ? if so try removing it to rule out the switch...

 

secondly is the client also virtual or is it real, if it's real is it 32bit or 64bit ?

Share this post


Link to post
Share on other sites
is there a switch of any sort in between the server and client ? if so try removing it to rule out the switch...

 

secondly is the client also virtual or is it real, if it's real is it 32bit or 64bit ?

 

Yes there are multiple cisco switches between the client and the server. The client is real and I am trying to load 32bit XP.

Share this post


Link to post
Share on other sites

is option 66 pointing to the ip of the WDS server ?

 

have you tried setting option 67 to boot\x86\wdsnbp.com instead of your current value =?

Share this post


Link to post
Share on other sites
is option 66 pointing to the ip of the WDS server ?

 

have you tried setting option 67 to boot\x86\wdsnbp.com instead of your current value =?

 

 

Option 66 does point to the wds server.

I did try pointing option 67 to wdsnbp.com however it kept searching for x64 instead of x86.

Share this post


Link to post
Share on other sites

as a test point it to the X64 boot file

 

could be that the bios is reporting 64bit capable...

Share this post


Link to post
Share on other sites
as a test point it to the X64 boot file

 

could be that the bios is reporting 64bit capable...

 

I changed Option 67 to \boot\x86\wdsnbp.com and then added a 64-bit boot.wim.

 

So far everything is looking good. Thank you so much for the added insight.

Share this post


Link to post
Share on other sites
I changed Option 67 to \boot\x86\wdsnbp.com and then added a 64-bit boot.wim.

 

So far everything is looking good. Thank you so much for the added insight.

 

I'm having the same exact issue on an older computer. I have my PXE service roll to except unknown computers and i've placed my task sequence in the 'unknown computers' collection.

 

At first I was getting the same error about \boot\bcd error so I tried your recommendation on adding 64bit drivers for testing. And now i'm getting an whole new error:

 

File: \WINDOWS\system32\boot\winload.exe

Status: 0x000035a

Info: Attempting to load a 64-bit application, however the CPU is not compatible with 64-bit mode.

 

I've tried every possible driver for this machine. Not sure if it's a driver related issue or a hardware issue with this computer.

 

any help with be appreciated.

 

Thanks again.

Share this post


Link to post
Share on other sites

try setting Option 67 to \boot\x64\wdsnbp.com instead, does it work ?

Share this post


Link to post
Share on other sites

I actually came across the \boot\bcd error today myself on my home lab, restarting the Windows Deployment Service resolved it

Share this post


Link to post
Share on other sites

Hello,

 

I'm trying to do a Windows XP deploy through WDS as above. Unfortunately my dhcp server is separate, but I have configured the 66 and 67 options in there. The boot file "\boot\x86\wdsnbp.com" and I've tried 32 bit and 64 bit boot.wims and can get it to "expanding files" to install the OS. Once that finishes it restarts and gives this ****in boot\bcd error. I've tried everything I can find and I'm not sure if the problem exists in my boot.wims or what but it just seems weird that it doesn't work. Do I have to PXE boot again when the files are done expanding or should it boot into the xp installation screen?

 

Oh forgot to note:

2008 Server R2

Laptop is Dell Latitude E6410

Image is xp from dell with some slight customizations made.

 

Interestingly enough, rather than "copying files" "expanding files" "installing features" etc. and then restarting it restarts immediately after installing features.

ALSO: Copying files seems to occur near instantly which seems wrong as the file is 2.5gb lol.

Share this post


Link to post
Share on other sites

try setting Option 67 to \boot\x64\wdsnbp.com instead, does it work ?

 

Hi Anyweb, we have smsboot\x86\wdsnbp.com instead of your \boot\x86\wdsnbp.com, normal?

Share this post


Link to post
Share on other sites

I've configured a WDS server on Server 2008 R2. I've set the response policy to respond to all, I've configured DHCP correctly but when I do a PXE boot from some clients PC `s get the Following error,

 

PXE-T04: Access Violation

PXE-E36: Error received from TFTP server

PXE-M0F: Exiting PXE ROM

Share this post


Link to post
Share on other sites

here's something interesting and i need help with.

 

In the reg, under HKLM\SOFTWARE\Microsoft\CCM\Logging\SMSPXE the key 'LogPath' is set to 'SMSPXE.log'

 

No full path, and no file can be located.

 

If I change the path, say, to 'C:\Logs\SMSPXE.log', and then reboot the server OR simply restart the WDS service, it changes the path back to the original key.

 

So, i cannot troubleshoot my Boot\BCD error because I have to log to reference. Any ideas?

Share this post


Link to post
Share on other sites

We hit this issue recently when we went from a setup where the WDS server and clients were on the same subnet to one where they are on separate subnets. As our set had a Cisco router between the two subnets we resolved the issue by also adding the WDS server IP to the Cisco IP Helper-Address (in addition to MS's recommendations)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...