Jump to content


learningmode

Configuration Manager Client Package keeps updating

Recommended Posts

Hi guys,

 

I have come up with another issue that I have discovered and I have no Idea how this happen or how to resolve it. I actually have a case open with MSFT and it has been two days and they seem to be stuck on this. I notice that the Client Package that was created during the SCCM build is constantly updating. I have image of what i'm talking about below:

 

post-20082-0-19721600-1383614335_thumb.png

 

I know the source version should not be that high and the client should not be updating constantly, seem to be every 4hrs or less its updating.

 

post-20082-0-65996200-1383614558_thumb.png

 

What I have highlighted is the original package that was created during the SCCM build and the one below "SCCM 2012 Configuration Manager Client" is what I created manually which is working and not having a constant update.

 

 

 

Thanks,

Share this post


Link to post
Share on other sites


As it's the build in package, there is not much configuration possible... The only thing I can think of is the content validation on the DP(s) and otherwise a database thing in which case your good with a case by MSFT. Let us know what they find!

Share this post


Link to post
Share on other sites

As it's the build in package, there is not much configuration possible... The only thing I can think of is the content validation on the DP(s) and otherwise a database thing in which case your good with a case by MSFT. Let us know what they find!

 

They are still working on the case... I will give update once we or they figure it out.

Share this post


Link to post
Share on other sites

Okay, resolution to this was to basically create a new Configuration Manager Package which I did do, but what Microsoft did was basically Re-Create the Client Package as if we built in the CAS. Since my Client package was created in the Stand Alone initially and was Expanded to the CAS it might have caused some issues??? I don't really totally agree with that, but oh well.

 

Here are the Resolution they did:

 

1. Create a new ConfigMgr client package with any name and no programs (Source: \\server\SMS_Site\Client)

2. Create a new ConfigMgr client upgrade package with any name and no programs (Source: \\server\SMS_Site\Client Upgrade)

 

The packages you created manually will be automatically deleted; no need to remove them later.

New default packages will be automatically created.

 

3. run the following queries in the CAS site database – change the old and new package Ids accordingly:

 

update ClientDeploymentSettings set FullPackageID = 'new Client PkgID' where FullPackageID ='old Client PkgID'

update ClientDeploymentSettings set UpgradePackageID = 'new Upgrade PkgID' where UpgradePackageID ='old Upgrade PkgID'

 

4. Restart SMS_Executive and SMS_Site_Component Services

5. Delete the problematic package after distributing the new default client package to the desired DPs.

 

This is how it looks now: (You will see WFT000D2 is the new Client Package)

 

post-20082-0-49573500-1384472578_thumb.png

  • Like 1

Share this post


Link to post
Share on other sites

Hi there.

Sorry about the well.. maybe a little dumb question. I've got the exact same problem here, but don't know where to enter these update commands. Could you please give me a little hint on this.

Tahnk you in advance.

Share this post


Link to post
Share on other sites

They're SQL queries. Given the fact that you had to ask that, I would strongly suggest to contact Microsoft before making that change. Another reason is that it's simply not supported to edit the database.

Share this post


Link to post
Share on other sites

Hi,

 

I have the same situation, package is recreating without end. My question is-

when i create empty package with new ID, CM will rebuild both packages, but all my task sequences knows that ConfigMgrClientPackage have old ID - they will be know new package ID?

I suppose yes, if they ask database about ID everytime, not only in creating sequence.

I am right?

Share this post


Link to post
Share on other sites
On 11/14/2013 at 6:44 PM, learningmode said:

Okay, resolution to this was to basically create a new Configuration Manager Package which I did do, but what Microsoft did was basically Re-Create the Client Package as if we built in the CAS. Since my Client package was created in the Stand Alone initially and was Expanded to the CAS it might have caused some issues??? I don't really totally agree with that, but oh well.

I did this for a problem I had and it worked great. Thanks for your help!

Share this post


Link to post
Share on other sites

I completed all the steps outlined, however the newly created client package and the update package continues to update.

 

There are no client.acu file within Program Files\Microsoft Configuration Manager\inboxes\hman.box .
But two files are constantly being created and disappeared and created again: <sitecode>.ITC and <sitecode>.SCU

 

This is 1706 with hotfix installed.

 

Help!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...