Jump to content


WinPE with an onscreen keyboard

Recommended Posts

Hello everyone,


I have been referencing this site for quite a while now and I appreciate all the information here. I hope to give back to it from time to time so I created an account.


That being said, has anyone tried to add an on screen keyboard to the WinPE startup? I have a lot of tablets to image and there are a couple places that we need to be able to type in some information.


I am working with SCCM 2012 R2 and the latest ADK. I mount the boot image using imagex, add the keyboard exe that I would like, add the line to run it in winpeshl.ini. Then i unmount, commit, and yadda yadda. When booting to this new winpe boot image the keyboard was not coming up on startup. So at this point i plug in a usb keyboard and hit F8 for the command prompt then try to run the keyboard exe from there.


It tells me: "the subsystem needed to support the image is not present".


I have tried running imagex from c:\program files (x86)\windows kits\8.1\assessment and deployment kit\deployment tools\amd64\dism. Searches via the google have been hit and miss.


Thanks in advance for any thoughts you have on this.

Share this post

Link to post
Share on other sites

Its a Panasonic FZ-G1 and touch screen works in WinPE, so I think the BIOS is ok. I do have a dock, for me, but there will be places where a dock(s) will not be available. We are pxe booting via usb to ethernet adapter (which has worked) as our tablets are configured with 1 usb port. If i had the on screen keyboard we'd be able to get multiple $20-40 usb to ethernet adapers instead of the really expensive docks. Ultimately it is going to be used by the person loading the image to put in the task sequence password and system name.


After some more digging I think my issue is that the on screen keyboards I have found are 32 bit. I need to find a 64 bit version and give that a shot. If it works I will post up what i did to get it to work.

Share this post

Link to post
Share on other sites

Got you. Touch works but you need the keyboard to pop up to enter the computer name and password. We don't use a password on PXE and pre-populate SCCM with the computer name vs MAC address so don't enter anything. We use cheap Belkin USB 4 port unpowered adapters as well as the dock and they have worked with everything.

I built a similar Panasonic toughbook and it was 64 bit drivers only so yes that might be worth a shot.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...