Jump to content


mpicollet

Impossible to deploy Windows 7 on disk 1 for a Dell models with SCCM 2012 R2 CU3

Recommended Posts

Hello,

 

We have a big problem for Dell Precision M6x00 models with two discs.

We try to apply Windows OS on Disk 1 (mSATA) with the task sequence SCCM, but impossible!

We have upgraded the BIOS version, same result !

 

A priori, the Disk 0 has priority over the Disk 1 in all cases

Nothing in the BIOS proposes to change this state.

 

Topics similary

http://www.windows-noob.com/forums/index.php?/topic/10561-sccm-2012-r2-osd-fails-with-error-80070032/

https://social.technet.microsoft.com/Forums/en-US/297f9adb-d71d-445b-8fdf-9776b70c7b98/multiple-harddisks-and-apply-operating-system-image-failure?forum=configmgrosd

 

have you got a idea ?

 

Regards,

 

MP.

 

The volume E:\ exists and is a local hard drive.

The volume E:\ is using a valid file system.

Windows target partition is 1-2, driver letter is E:\

!sSystemPart.empty(), HRESULT=80004005 (e:\qfe\nts\sms\framework\tscore\diskvolume.cpp,131)

System partition not set

Unable to locate a bootable volume. Attempting to make E:\ bootable.

volume.getDisk() == iBootDisk, HRESULT=80070032 (e:\nts_sccm_release\sms\client\osdeployment\applyos\installcommon.cpp,693)

Volume E:\ is not on the boot disk and cannot be made bootable.

MakeVolumeBootable( pszVolume ), HRESULT=80070032 (e:\nts_sccm_release\sms\client\osdeployment\applyos\installcommon.cpp,772)

Failed to make volume E:\ bootable. Please ensure that you have set an active partition on the boot disk before installing the operating system.

The request is not supported. (Error: 80070032; Source: Windows)

ConfigureBootVolume(targetVolume), HRESULT=80070032 (e:\nts_sccm_release\sms\client\osdeployment\applyos\applyos.cpp,499)

Process completed with exit code 2147942450

!--------------------------------------------------------------------------------------------!

Failed to run the action: Apply Operating System Image Windows 7 SP1.

The request is not supported. (Error: 80070032; Source: Windows)

Share this post


Link to post
Share on other sites


Here all the log files in attachment !

 

At the beginning of the task sequence, we use a PS script to determine the smallest disk.In order to ensure the correct disk format and then make the windows installation - In this case, find the disk1 (mSATA) for models with multiple disks. It is always that which must contain Windows. The goal is to use the same sequence of tasks for all Dell models. Some PCs do possess one disc. The script allows managing PC with 2 discs when currently detected... Also, at the beginning of the task sequence, for new computer scenario, we try to prepare a disks with diskpart commands following (diskpart /s PreparediskpartCmds.txt):

 

Select disk 0

Clean

Convert mbr

Create partition primary

Format fs=ntfs quick

Select disk 1

Clean

Convert mbr

Create partition primary

Format fs=ntfs quick

 

But process failed to apply OS to disk 1 !

 

Just for information, we use the MDT solution before 2012. We did not have this problem. SCCM seems to be an additional check ...
Apparently step Apply Operating System in a sequence of tasks SCCM does not look like the one used by the MDT solution 2012

 

Thank for you help !

 

Regards,

 

MP.

logmdtsccm.zip

Share this post


Link to post
Share on other sites

This morning, we have seen that the command did not work "Convert MBR" for Disk 1, but only on disk 0.

The disk 1 (mSATA) is not recognized as drive but more like a media type DVD or CDROM.

We do not know how to change this state, the BIOS remaining silent about it.

Share this post


Link to post
Share on other sites

first things first can you read the disc fine in WinPE ? so no drivers needed in your boot wim ?

secondly, if you have just one disc, does it work ok ?

Share this post


Link to post
Share on other sites

Yes ! I can see both drives
I have not tried to remove the disk to test

 

so, FYI

 

mSATA (Disk 1) model

  • Samsung SSD PM830 mSATA (MiniSATA) 128 Go (The problem)

Other HDD (Disk 0) model

  • Samsung SSD PM830 2.5 7mm 256 Go

BIOS mode (UEFI/RAID/AHCI)

  • AHCI (Down)
  • UEFI (Down)

Have you injected latest WinPE drivers into boot image?

  • No, none drivers injected in WinPE

Have you mentioned any specific disk/drive letter in task sequence to install the OS ?

  • I use OSDisk variable in OSD

We use a Dell M6700 model with BIOS version A14

M.

Share this post


Link to post
Share on other sites

Ok we removed disk 0 that was the problem. The mSATA drive was awarded "Disk 0" and that to work. We were able for the first time to install Windows on the mSATA SSD by removing disk (Disk 0 at the origin).

The hardware detection dynamically attibut tags Disk 0, 1, 2, etc. The problem when you install Windows on the mSATA then considered Disk 1. SCCM, does not support installing Windows on a disk 1, only on a disk 0 - Unlike the 2012 MDT solution.

 

Conclusion The problem is not hardware, but software. Including SCCM bug! We are opening an incident at Microsoft

But have you ever encountered this problem ?? :angry:

 

Regards,

 

M.

Share this post


Link to post
Share on other sites

no I have not seen this problem before as I don't install an os to computers with more than one disk, did the dell ship from the factory with these disks or did you add one after recieving it ?

Share this post


Link to post
Share on other sites

Hey there. I know your pain. I had issues with the Dell M6600 with trying to image a system with SCCM. Dell and/or Microsoft was unable to help me back then. So, I came up with a way to get it to work. It is a little involved, but works on any M6600 system we deploy (if they are still in service). Our M6600 had three drives. Two HDD in a RAID 0 configuration (for storage) and a M.2. SSD.

 

An Important note is that our deployment techs would setup the RAID array manually before kicking off the image job. Thus the two drives in a RAID array report as HDD1 and the SSD reports as HDD2. Also, while some of this may seam redundant, the Task Sequence handles both bare metal and in-place refreshing of the machine.

 

*UPDATE* I've Uploaded pictures of several of these steps to a shared folder on Drop Box: https://www.dropbox.com/sh/6gu9guh9qvjkad1/AABTjOb1Pf4PRtu9olwTrAhKa?dl=0

 

First, I use the Dell CCTK to set the BIOS options. The important lines are:

bootorder=-hdd.1,+hdd.2,+usbdev,+cdrom,+embnic,-floppy

embsataraid=raid

 

This makes it so hdd.2 is the first boot device and removes hdd.1

 

After this, there is a "Run Command Line" referencing the Dell CCTK x86 2.1 package:

cctk.exe bootorder --enabledevice=hdd.1

 

The next step reboots the machine. This enables the RAID array as a bootable device.

 

Now, I made a special Format Disk and Apply OS steps for the M6600. I used normal WMI Queries to detect model.

 

Partition Disk 1 Step

Disk Number: 1

Disk Type: Standard(MBR)

 

100% Partition named OSDisk

NTFS Quick Format

Drive Letter Saved to Variable: OSPART

 

Apply Operating System

Standard OS Wim and Unattend file as all other models

Destination: Logical drive letter stored in a variable

Variable Name: OSPART

 

And then we start some of the BIOS magic:

 

Fix Boot Drive (Run Command Line)

 

Command Line: cmd /c bcdboot.exe %OSPART%\Windows /s %OSPART%\ /l en-US /v

 

Disable RAID array as boot device (Run Command Line (NEWCOMPUTER ONLY))

 

Options Tab: Task Sequence Variable - DeploymentType equals "NEWCOMPUTER"

 

Command Line: cctk.exe bootorder --disabledevice=hdd.1

Package: Dell CCTK x86 2.1

 

Delete old boot files (Run Command Line)

 

Command Line: cmd /c rmdir /S /Q C:\boot

 

Delete old bootmgr (Run Command Line)

 

Command Line: cmd /c del /F /A:H C:\bootmgr

 

Following that the job continues on with all of my normal steps.

Share this post


Link to post
Share on other sites

Hi ArmitageID,

 

I tried all your steps on 6600 and 6700 with 2 hard disk drives but It doesn't work.

SCCM generate an error when trying to apply image because disk 1 (hdd.2) does'nt contain bootable partition...

It works when apply on Disk 0 but it's not what we want :(

Share this post


Link to post
Share on other sites

It is possible to apply the OS to disk one with some workarounds, we instruct our engineers to diasble sata 0 and 1 before a build and we have a dell bios exe in the task sequence to switch sata 0 and 1 back on later in the TS after the image apply section, we also run bcdedit commands to fix the boot manager, a further VB script sorts out the drive letters as we prefer the second drive as D: but that is niether here nor there. Works on M6800 and M4800's.

 

We are also working on the Dell CCTK commands to do this automatically without any manual intervention, but I'm struggling with the flakey way this happens in WinPE.

Share this post


Link to post
Share on other sites

It might be better to call Dell. On systems with M.2 or mSATA the drive order (not boot order) perhaps should be handled by boot priority or CMOS settings instead of hard sata port #. On my system M.2 uses SATA port 5 and 6. I don't know what order they are presented to the OS, or if it can be changed via CMOS. I only have the one M.2 drive but it is in interesting question.

 

Also some systems allow you to disable individual SATA ports in CMOS which could temporarily shift the remaining drive to drive 0 from the OS perspective.

Share this post


Link to post
Share on other sites

Hi,

 

I figured I'd create an account and reply to this as I found this forum whilst trying to solve a similar problem myself.

 

Through a process of 18% trial and 82% error, I have a working solution to my problem. I thought I would share as it may work with others.

 

 

My task sequence begins with a command line which cleans the partitions on disk 0 and disk 1 using diskpart.

 

I then proceed to partition and format disk 1 (an MSATA disk).

 

Next comes the installation of Windows (7, 8.1 or 10) on disk 1. I've used this method with all 3.

 

Apply Windows settings.

 

Apply Network settings.

 

ONLY THEN:

 

Partition and format disk 0.

 

Apply image to disk 0 (in my case, this is just the program files folders as I need a lot of software in these images).

 

Finally, set up configuration manager client.

 

 

 

This has worked consistently on around 50 machines with this stupid MSATA set as disk 1 configuration. Sometimes I need to put stuff on disk 0 with the TS, sometimes I don't. Works either way.

 

By the time you create a partition on disk 0, the computer recognises disk 1 as the boot disk with the OS on it.

 

Hope this helped at least someone. It gave me a headache for two days...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...