Jump to content


1606 -- 1610 Upgrade High CPU on DP

Recommended Posts

Hi All


I have now built 2 labs over Christmas period, both labs were 4 box solutions which work perfectly on 1606 from baseline media. Got them all working. deployments of software, osd patches everything I needed.


Initial lab was on server 2012 r2 and sql 2012 - all service packed and patched up.

Worked fine on 1606 - upgraded to 1610 and I get high CPU on smsexec on the box which functions as a DP (role)


2012 r2 lab

Domain controller (test.local) DNS DHCP AD

PRI - ADK 10.1.14393.0

DP (dp,pxe,fsp,scp,sup)

MP (mp,appcatalogue,reporting services)

SQL 2012


Didn't take snapshots so couldn't go back. The funny thing is I have high CPU but it still works fine on 1610 - all functionality is still working...


Have recently (today) applied the hotfix for 1610 from servicing, and this has not cured the high cpu on the dp.


So - I read the fantastic guide on building with server 2016, sql 2016 guide and built a second lab using all 2016 products.


2016 lab

Domain controller (lab.local) dns, DHCP, AD

PRI - ADK 10.1.14393.0

DP (dp,pxe,fsp,scp,sup)

MP (mp,appcatalogue,reporting services)

SQL 2016



Again this worked fine on 1606, everything doing what it should, osd, patching, deploy software. Then took this 2016 lab from 1606 to 1610 and again getting high cpu on my DP.


I have 2 labs, both on 1610, both working, but the high cpu on my dp is present on both...

Is this a known issue, or part of the 1610 additional functionality that I will admit I am unaware of ?


If I add another CPU to the DP, then 1 cpu goes 50% usage - this is consistent on both labs.


Any information or thoughts on where to look appreciated.



Share this post

Link to post
Share on other sites

i've just turned on that lab again (SQL 2016/Server 2016/SCCM 1610CB) and will let it 'catch up' with itself for a bit and then check the cpu usage, right now it's high but that's expected when resuming a vm from a saved state.....


i'm using hyperv are you too ?

Share this post

Link to post
Share on other sites

Hi Anyweb,


Thanks for getting back to me on this.


Yes hyper V host server 2012 r2 - fully patched.


I will leave the 2012 r2 lab on for the next 8 hours and see what occurs. give it more time to settle.


Thanks anyweb - Your the boss.



Share this post

Link to post
Share on other sites

Hi All,


First apologise for the delay in updating.

I have had the lab on all day today (the 2012 R2 lab) and been building / patching and generally POC'ing some stuff.


The DP has been at 100 CPU all day, however still works fine.


I will rebuild the whole lab from DC to SCCM, and position the roles on different servers and keep you posted if I can get the CPU on the DP to not be 100% all the time.


Thanks guys - more soon.




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.