Jump to content


Recommended Posts

Hi,

 

We have tried to install KB4019926 in our SCCM environment (Server 2012 R2, Current Branch SCCM 2012), but it has failed at the "Upgrade ConfigMgr database" step. All pre-requisites passed OK before installing. We have attempted one retry after a reboot of the server, which has failed at the same point. I can find plenty of threads to other issues with the upgrade ConfigMgr Database, but not that exactly match my situation. Can anyone help if I can provide the cmupdate.log?

*** EXEC sp_addrolemember 'db_datareader', 'smsdbuser_ReadOnly';EXEC sp_addrolemember 'db_datareader', 'smsdbuser_ReadWrite';EXEC sp_addrolemember 'db_datawriter', 'smsdbuser_ReadWrite';EXEC sp_addrolemember 'smsschm_users', 'smsdbuser_ReportSchema'; CONFIGURATION_MANAGER_UPDATE 04/07/2017 09:44:03 1344 (0x0540)
*** [42000][15410][Microsoft]

[SQL Server]User or role 'smsdbuser_ReadOnly' does not exist in this database. : sp_addrolemember CONFIGURATION_MANAGER_UPDATE 04/07/2017 09:44:03 1344 (0x0540)
INFO: Executing SQL Server command: <EXEC sp_addrolemember 'db_datareader', 'smsdbuser_ReadOnly';EXEC sp_addrolemember 'db_datareader', 'smsdbuser_ReadWrite';EXEC sp_addrolemember 'db_datawriter', 'smsdbuser_ReadWrite';EXEC sp_addrolemember 'smsschm_users', 'smsdbuser_ReportSchema';> CONFIGURATION_MANAGER_UPDATE 04/07/2017 09:44:03 1344 (0x0540)
Failed to update database. CONFIGURATION_MANAGER_UPDATE 04/07/2017 09:44:03 1344 (0x0540)
 

Many thanks,

Martin

Share this post


Link to post
Share on other sites

Hi Anyweb,

 

I have attached the full CMupdate logs for reference. Any help you can provide would be greatly appreciated.

 

Many thanks,

 

Martin

 

Edited by 19martin75
Removed attached logs now case resolved.

Share this post


Link to post
Share on other sites

Hi,

 

I think I've resolved this. The SQL user accounts below did not exist, but these should be created as part of the initial SCCM installation. Not sure why these did not exist in our DB:

- smsdbuser_readonly

- smsdbuser_readwrite

- smsdbuser_reportScheme

 

So I manually created these as users without a login, and re-ran the updater which has now run.

Will quiz our DBA's to see if there has been any over-zealous cleaning of logins from the DB...

 

Thanks for your time - posted my fix should anyone else have the same issue.

Martin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...