Jump to content


Sign in to follow this  
anyweb

Fixing an evaluation version of SSRS with "HTTP Error 503. The Service is unavailable"

Recommended Posts

Introduction

I was writing a blog post about Troubleshooting BitLocker Management in ConfigMgr 2002 Current Branch and one of the things I was trying to do was install the web portals, but I was seeing errors shown below.

Get-ReportServiceUri : Caught exception querying report service at http://cm01.windowsnoob.lab.local/Reportserver

installing the portals SSRS error.png

I assumed this was because SSRS was not installed or configured but after checking the lab, I could see it was indeed installed and configured. However when I browsed the http://cm01.windowsnoob.lab.local/ReportServer URL in Internet Explorer it produced a  HTTP Error 503. The Service is unavailable.

error 503.png

A quick search gave some clues and things to try but in reality the reason it was not working was because:

  • SSRS was installed in evaluation mode
  • SSRS evaluation had expired

This was revealed in the logs stored at C:\Program Files\Microsoft SQL Server Reporting Services\SSRS\Logfiles

installation has expired.png

To upgrade the evaluation version you'd normally just need to upgrade the edition of SSRS from Evaluation to Production via change/uninstall in Control Panel, however the way this installation was packaged (WIX bundle) meant that it retained the original download link in a bundled file called state.rsm

state rsm.png

and that was looking in the IE cache as you can see in the SSRS installation log files

failed to resolve source path.png

That path no longer existed. Manually recreating that path and copying the SQLServerReportingServices.exe file to that path did not help, it reported another error.

bundle action failed.png

I could keep trying to hack my way around these errors or fix it once and for all.

Fixing the evaluation version

As this is just a lab I decided to rip SSRS out completely and then add it back.

Note: If you are doing this in production then make sure to backup all your custom reports first and if necessary backup the reporting databases also.

I decided to try the following:

  • uninstall reporting from ConfigMgr
  • delete the 2 reporting db's in SQL
  • uninstall SQL Reporting Services in control panel
  • restart server
  • reinstall SSRS
  • reconfigure SSRS

Keep in mind that unless you want the same problem occurring in 180 days or so, you'll need the key that was used when installing SQL. If this process doesn't pick it up from your installed instance of SQL, you can find that key in the installation media.

Using the product key from DefaultSetup.ini

To find the product key in your installation media, you should know that the PID is more than likely contained within the DefaultSetup.ini file located under Root\X86 or Root\x64 folder. Open that file with notepad and copy the product key for later use.

 

Let's get started. In ConfigMgr remove the SSRS role.

remove ssrs role.png

Confirm that it's removed successfully via the SRSRPSetup.log.

srsrpsetup log.png

Next, in Sql Server Management studio, find the 2 reporting services databases and remove them, if you are doing this in Production, read my NOTE at the top of this section as deleting the two Reporting databases will result in the following: Reporting services will not work (it's broken already...), all your reports will have been lost (you did back them up didn't you ?), schedules, permissions, etc.

delete reporting databases.png

And now they are gone.

dbs gone.png

Next in Control Panel, locate SQL Server Reporting Services and uninstall it.

uninstall ssrs.png

Once uninstalled, close the wizard.

close wizard.png

restart the ConfigMgr server.

restarting cm.png

 

After the server has restarted, reinstall SSRS by launching SQLServerReportingServices.exe available for download here for SQL Server 2017 or here for SQL Server 2019. After downloading it, copy it to a safe location outside of the browsers cache, eg: C:\SSRSSource.

ssrs source.png

Run the executable and choose Install Reporting Services.

install reporting services.png

Paste in your SQL License key from the SQL Server media, look in ..\x64\DefaultSetup.ini and your SQL license key will be in there.

enter product key.png

Accept the license terms

accept license terms.png

Install the database engine.

install database engine.png

Pick the path and click next, after a while it's completed. Click on Configure Report Server.

configure report server.png

Select Connect when prompted. The report server configuration manager wizard will appear, notice how it states the version is Standard (and not evaluation).

report server configuration manager.png

 

In Web Service URL, click Apply.

Note: This is assuming you want to configure SSRS in HTTP mode, if you'd like to use HTTPS mode please review this blog post.

web service url.png

For Database, choose Change Database.

change database.png

Choose create a new report server database from the options

create a new report server database.png

Decide if you are going to use the current logged on user or a SQL server account to setup this new database

connect to database server.png

Select the database name.

select database name.png

continue through that wizard until completion. Make sure it's all successful before clicking on Finish.

success finish.png

Next, click on Web Portal, and choose Apply.

web portal apply.png

And you can configure other options or simply select Exit.

In the ConfigMgr console, add back the reporting services role

add reporting services.png

Configure the account...

reporting services account.png

And confirm that it was successfully installed in the SRSPSetup.log.

ssrs role added.png

At this point you can go back into your web browser and confirm that reporting is indeed responding without the initial error.

Tada !

report server working.png

and via the Reports web portal.

sql server reporting services.png

And finally, verify that the reports are present and working in the ConfigMgr console

verify reports present.png

And that's it ! Once again I started one blog post only to hit an issue that threw me a wobbler. But thanks to that you have this blog post 🙂

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...