Jump to content


Office 365 issues after Windows Autopilot

Recommended Posts


I'm writing this post to catalog problems I recently faced while doing Windows Autopilot installations, we use a very slim enrollment Status Page (ESP) configuration with only one app marked as required (Microsoft Edge Chromium). The remaining applications are a mix of Win32 apps and the all important Microsoft Office 365 suite. This suite was configured with the following apps.

Excel, OneDrive Desktop, OneNote, Outlook, PowerPoint, Teams, Word

This worked well since about mid-February 2020. However, starting week 46, I started noticing the following error on newly delivered HP computers with Windows 10 version 1909 (and some office components preinstalled) after clicking the Microsoft Outlook icon soon after Windows Autopilot had completed.

cannot start outlook.png

It looks ominous. Clicking OK and trying again, the problem looked even worse, you'd see something like this, outlook prompting you to choose a Profile.

second outlook start.png

followed by a Script error, stating Class not registered on Line 278.

class not registered.PNG

Choose Yes or No had pretty much the same effect, Outlook was well and truly broken. If you clicked on the Account Information in Outlook you'd see something like this. A Metered connection warning followed by a Upgrade in Progress warning.

metered connection warning.png

The first is definitely a red-herring as the Network card was not in a state that was metered.



When checking the version of office installed on affected machines I could see it was as shown below, Office version 2011.

Office after autopilot.PNG

The interesting thing to note is that Computers that had a clean image of Windows 10 version 1909 with no Office installed previously did not exhibit this problem, it only affected factory image(s) of HP computers with Windows 10 version 1909 factory image and those images come with a version of Microsoft Office installed (in the Nordics), namely Microsoft Office 365 ProPlus version 1908 (Build 11929.20394).


Based on the above I knew that clean installs of Windows 10 1909 did not have the issue (even though they subsequently got the Office 2011 version installed before the user logged on). I initially suspected that security software or a device configuration profile were to blame, and went through the time consuming task of excluding a computer from each profile, and then resetting it to verify the behavior.

Excluding a device from an assignment takes precedence over including a device so it was a good way of testing Windows Autopilot without certain settings or configurations, to rule them out.

Below you can see I've excluded a group (containing my test device) from a Device Configuration profile, to verify if that was the issue.

excluded groups.PNG

trying this didn't help, but it at least ruled out the following from being part of the problem.

  • Device Configuration Profiles
  • Win32 based Security based apps

      (such as Azure Information protection, Crowdstrike, Symantec DLP)

Armed with that knowledge I recreated the Office Suite settings in my own test tenant, and ran a Windows Autopilot build, to my surprise the HP failed starting outlook the exact same way as in Production, so that completely ruled out everything other than the version of Office installed on the HP.

Next I turned to logging options within Office/Outlook to see if that would help, but in reality it just generated .ETL files that I'm still analyzing in order to root-cause this issue.

The breakthrough came when looking at the settings of the Office suite in Endpoint Manager. The version of Office that gets installed is based on your settings in the Office Suite, and we had been using these settings without problem since February 2020. The really important bit was the update channel, shown below.

office suite.png


The update channel we were using was Current Channel (Preview). You can get details of the update channels here.

According to Microsoft:

... three primary update channels:

We recommend Current Channel, because it provides your users with the newest Office features as soon as they are ready.

But what is the difference between Current Channel and Current Channel (Preview).

According to Microsoft:

To become familiar with the new features coming in the next feature release of Current Channel, we recommend that you use Current Channel (Preview).

There isn’t a set release schedule for Current Channel (Preview). In general, a new version of Current Channel (Preview) with new features is released at least a week or more before that new version is released to Current Channel. There might be several releases of Current Channel (Preview), with non-security updates, before that version is released to Current Channel.

You should deploy Current Channel (Preview) to a small, representative sample of users in your organization. This can help you identify any possible issues for your organization before those new features are released more broadly to your users that have Current Channel.

We also encourage you to use Current Channel (Preview) so that you can identify any possible issues that you want us to fix before that version is released to Current Channel. This can help reduce the number of non-security updates that are needed for Current Channel.

And this pretty much matched what we were doing, so now that we had this knowledge, but still had no root-cause for the Outlook (and Word/Excel issues).


The Resolution

I decided to change the Update Channel from Current Channel (Preview) to Current Channel. This decision was based on the fact that the Preview channel may contain changes that are incompatible with our image in some way, which is odd because we are using the factory installed HP image.

Once I made the change, and re-tested Windows Autopilot the difference was clear. Now Outlook worked as expected without issue (and Word/Excel issues disappeared also), however the version of Office installed was Version 2010 instead of Version 2011 that we got in the Current Channel (Preview). This didn't matter too much but of course it meant that some cool new cloud friendly features in Version 2011 were now no longer available on newly installed Windows Autopilot machines.

The versioning used by Microsoft for Office is somewhat confusing, in the Office Account screen you'll see the version info, here you can see it's listed as Current Channel, Version 2010 (the version without the problem).

about outlook.png

So version 2010 relates to year 20, month 10, or the October release of Office 365. That would of course mean that version 2011 is the November release.

Note: we've noticed that HP's corporate ready image includes an office version that is released before the OS version was released, so for example if you get Windows 10 version 1909, then you'll get the Office version released approximately one month before that (Office version 1908). Likewise if you got Windows 10 version 2004, you should get Office version 2003.


Sometimes living on the edge means you will fall over. I know that changing from Current Channel (Preview) to Current Channel might only delay the problem until the Current Channel update channel migrates to the new version of office next month, so we may actually encounter this problem again, and soon.

So to conclude,  if any of you have come across this exact issue (I have searched and found similar problems with "Library not registered", but the advice within them didn't apply here), then please get in touch with me. In the meantime I will look through the gathered ETL traces to see if they provide any clue as to why Office was so broken on these new devices in order to root-cause the problem.

Links used in this blog post

Github script, Metered - https://gist.github.com/nijave/d657fb4cdb518286942f6c2dd933b472

Update Channels - https://docs.microsoft.com/en-us/deployoffice/overview-update-channels

Office Versions - https://docs.microsoft.com/en-us/officeupdates/current-channel



  • Like 1

Share this post

Link to post
Share on other sites

Just found this post as we have randomly hit this issue on HP devices but specifically the G7 variety - we have many G6 devices in place and they are fine.  I checked the update channel and we are current channel but we found the issue on machines that had Visio installed strangely only.  I am also digging and if find anything will post on here

Share this post

Link to post
Share on other sites

in investigation so far appears to be the embedded office and removing all traces of office then adding seems to work. 

I had to move away from the native intune package as when it failed was never any useful information as to why or how in logs.  Using PSappdeploy also gives feedback on progress and additional logging using the xml creator in Apps Admin Center (office.com)

Share this post

Link to post
Share on other sites

Just to add to our troubleshooting I learned something new today in that when Office is removed completely from a device the Outlook profile still hangs about.  We were re-installing and it wasnt fixing for the user.  I had to manually go in and purge some Outlook folders in local/roaming %appdata%

We also noticed that the broken profile created a .pst in the documents folder - as we had OneDrive configured in Known Folder Move it was constantly trying to replicate changes and it cant.  Part of reasons .pst files arent supported within OneDrive


Share this post

Link to post
Share on other sites

interesting,  it also seems that Microsoft is recommending the Monthly Enterprise Channel for office (while at the same time recommending Current Channel, see above...), which of course solves the problem but lacks features,

another approach is to pay HP more money to ship devices without Office in the Corporate Image, that works too



Share this post

Link to post
Share on other sites

Yeh whilst an option i just decided to go the destroy way so we have packages to remove all the unneeded software and as mentioned above modified the office install to attempt to remove office whilst also supressing error codes.  PSAPPDEPLOY code is


        Execute-Process -Path "$dirFiles\setup.exe" -Parameters "/CONFIGURE remove.xml" -ContinueOnError $true -IgnoreExitCodes '*'


and remove xml is below - not sure i need the remove all true whilst also calling out products but the reality sometimes doesnt match the documentation with Microsoft

<?xml version="1.0"?>


<Display AcceptEULA="True" Level="None"/>

<Property Value="TRUE" Name="FORCEAPPSHUTDOWN"/>

-<Remove All="TRUE">

-<Product ID="O365ProPlusRetail">

<Language ID="en-us"/>


-<Product ID="VisioProRetail">

<Language ID="en-us"/>


-<Product ID="ProjectProRetail">

<Language ID="en-us"/>




  • Like 1

Share this post

Link to post
Share on other sites

interesting, can you go into more detail of how you are doing this, we might go this route (maybe), but for now are forcing the version via the suite method.

Share this post

Link to post
Share on other sites

Sure so we use a wrapper called psappdeploy which for intune is invaluable (intune logs are really painful to go through) PSAppDeployToolkit.  It has some additional functions so all we have for installing office is below lines:

        # Try to remove any existing office install
        write-log "Trying to remove old versions of Office staged on build"
        Execute-Process -Path "$dirFiles\setup.exe" -Parameters "/CONFIGURE remove.xml" -ContinueOnError $true -IgnoreExitCodes '*'

        # Install fresh office 
        write-log "Installing Office"
        Execute-Process -Path "$dirFiles\setup.exe" -Parameters "/CONFIGURE Office64.xml


Have to make sure you ignoreexitcodes for removal as for example base windows ISO from Microsoft wouldnt have it in place - and without ignoring error codes it would just fail before trying to install office.

Share this post

Link to post
Share on other sites

We’re on the Semi Annual Channel, and not using Intune to deploy Office (traditional imaging) and this bug has plagued us since January 2021. After every Patch Tuesday, random computers with Outlook simply break with “metered connection warning”, “upgrade in progress” and user can’t send email. It’s Computer-based, no one can use Outlook on a bugged PC. HP and Lenovo.

Reinstalling Office is the only fix we’ve found (changing channels is essentially reinstall) none of the registry hacks have worked. Sometimes it hits the same machine multiple times so it’s not a one-and-done.

Microsoft Support says reinstalling is an acceptable fix in their eyes and won’t pursue it further. We’ve rebuilt our system image from scratch and it’s still happened. Helpdesk is fed up with reinstalling Office for a dozen people the morning after every Office update, but we’re out of ideas.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.