Jump to content




Sign in to follow this  
Chris Zeigler

SMS Distribution Manager failed to process package



Recommended Posts

Hey all, I've setup SCCM 2007 SP2 based on the install instructions on this forum. We have a single domain, single site setup. I'm trying to get software distribution to work - I have a collection with a single machine to test pushing software to. I followed the instructions for pushing Firefox (also based off the thread: http://www.windows-noob.com/forums/index.php?/topic/499-how-can-i-deploy-an-application-in-sccm-2007-sp1/) but it doesn't seem to be working. I created a folder on the root of the SCCM server which contains the Firefox.exe. The Package Status is in State: Install Retrying. The desktop computer in the collection never gets the "Advertised Programs Available" pop (and yes, the client is installed on the desktop). When trying to show error messages for the site, it's filled with "SMS Distribution Manager failed to process package" Error 2302. The SCCM server is itself the distribution point, why does it seem that despite the .exe file already being in a folder that it's trying to make a new folder on the server itself and push the executable to it?

 

Also, we have NOT extended schema, but have a WINS service locator setup.

 

As I'm sure is evident, I'm very new to SCCM, so any help, as descriptive as possible, is greatly appreciated.

 

Quick log info:

distmgr.log:

~Established connection to ["Display=\\<ourserver>\"]MSWNET:["SMS_SITE=<oursitecode>"]\\<ourserver>\ $$<SMS_DISTRIBUTION_MANAGER><Thu Aug 12 13:13:56.763 2010 Eastern Daylight Time><thread=2596 (0xA24)>

~Signature share exists on distribution point path MSWNET:["SMS_SITE=<oursitecode>"]\\<ourserver>\SMSSIG$\ $$<SMS_DISTRIBUTION_MANAGER><Thu Aug 12 13:13:56.779 2010 Eastern Daylight Time><thread=2596 (0xA24)>

~Found the existing package path on MSWNET:["SMS_SITE=<oursitecode>"]\\<ourserver>\SMSPKGC$\<oursitecode>00007\ $$<SMS_DISTRIBUTION_MANAGER><Thu Aug 12 13:13:56.779 2010 Eastern Daylight Time><thread=2596 (0xA24)>

for ["Display=\\<ourserver>\"]MSWNET:["SMS_SITE=<oursitecode>"]\\<ourserver>\, machine account is to be used~ $$<SMS_DISTRIBUTION_MANAGER><Thu Aug 12 13:13:56.795 2010 Eastern Daylight Time><thread=2596 (0xA24)>

CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100e~ $$<SMS_DISTRIBUTION_MANAGER><Thu Aug 12 13:13:56.795 2010 Eastern Daylight Time><thread=2596 (0xA24)>

CWmi::Connect() could not connect to \\["Display=\\<ourserver>M\"]MSWNET:["SMS_SITE=<oursitecode>"]\\<ourserver>\\root\MicrosoftIISv2. error = The operation completed successfully.. Will try FQDN~ $$<SMS_DISTRIBUTION_MANAGER><Thu Aug 12 13:13:56.810 2010 Eastern Daylight Time><thread=2596 (0xA24)>

Share this post


Link to post
Share on other sites


anyweb    399

hi Chris and welcome

 

once you create a package and distribute it to a distribution point (dp) configmgr will create a 'copy' of that package in it's own special folders such as smspkgd$ and so on (changes name depending on the drive)

 

if it's not even getting that far then nothing else will work so you need to fix it, does your computer account (machine account) have administrative access of your configmgr server ?

 

check this snippet from your posted log

 

machine account is to be used~ $$<SMS_DISTRIBUTION_MANAGER><Thu Aug 12 13:13:56.795 2010 Eastern Daylight Time><thread=2596 (0xA24)>

CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100e~

 

try doing that and see do things change

Share this post


Link to post
Share on other sites

hi Chris and welcome

 

once you create a package and distribute it to a distribution point (dp) configmgr will create a 'copy' of that package in it's own special folders such as smspkgd$ and so on (changes name depending on the drive)

 

if it's not even getting that far then nothing else will work so you need to fix it, does your computer account (machine account) have administrative access of your configmgr server ?

 

check this snippet from your posted log

 

 

 

try doing that and see do things change

 

So I should give the SCCM server computer account administrative access to itself? Just wanted to clarify that since the configmgr server is the distribution point.

 

Edit: I did at the server$ account with admin permissions to itself, but that didn't help :(

Share this post


Link to post
Share on other sites

So I should give the SCCM server computer account administrative access to itself? Just wanted to clarify that since the configmgr server is the distribution point.

 

Edit: I did at the server$ account with admin permissions to itself, but that didn't help :(

 

Got it working actually. Ultimately, I went to Site Settings, Site Systems and went to the distribution point settings for the SCCM server. I then unchecked "Allow clients to transfer...etc using BITS" and the package copied just fine. So I'm all set now, but would someone mind explaining why this might be the case as I have BITS installed on the SCCM server?

  • Like 1

Share this post


Link to post
Share on other sites
Babs    1

I'm experiencing the same issues in the 2012 RTM environment. Content status states "Distribution Manager failed to access the source directory..."

 

Additionally I am receiving a Critial SMS_DISTRIBUTION_MANAGER (2302) error in Component Status.

 

Please advise! :wacko:

Share this post


Link to post
Share on other sites
tedcbe    0

I had exactly the same issue on 5 out of the 6 DP's in our estate. Removing the tick from the "Allow clients to transfer...etc using BITS" did the job for me.

But what I am trying to find out is that the one DP that had it installed at first still has this option ticked - not sure why it is working on this DP with the above option checked and not on any of the other DPs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×