Jump to content


Sign in to follow this  
anyweb

how can I setup ISS for SCCM 2007 in Windows Server 2008

Recommended Posts

thanks for the link, and you are right, that is for basic authentication, I'll add that to my documentation

 

Note: If you choose to use Basic Authentication with the WebDAV redirector, you must connect to your server using HTTPS.

 

* The WebDAV Redirector must be installed:

o You must use Server Manager to install the Desktop Experience feature before you can use the WebDAV redirector.

 

cheers

anyweb

Share this post


Link to post
Share on other sites


Here is a jpg of my desktop on the server. I am a Domain Administrator.

 

Cheers

 

 

I am having the exact issue. Did you get any resolution on this?

Share this post


Link to post
Share on other sites

install the desktop experience feature, and it should resolve.

Share this post


Link to post
Share on other sites

I followed this when setting up a win 2008, sql 2008, SCCM 2007. I got one problem after installing, my Management Point dident install properly.

 

To get MP to install properly i allso had to change these WebDAV settings:

post-2500-1239296814_thumb.jpg

 

To do this:

1. Open IIS Manager (located under administrative tools)

2. Expand your site

3. Doubbleclick WebDAV Authoring Rules

4. Click WebDAV settings in the right column

5. Change according to my picture above

6. Click OK everywhere

 

Done

 

To se if your MP is installed correctly you can watch the log: <SCCM install dir>\logs\MPSetup.log

Share this post


Link to post
Share on other sites

well spotted, and p.s. that info is already in part 2 of setting up SCCM 2007 right here ;-)

 

cheers

anyweb

Share this post


Link to post
Share on other sites
Hi Anyweb and professor

 

I had the same problem I solved this with the following maybe this also helps you

 

 

If you are using Windows Server 2008, you need to install the Desktop Experience feature. To do so, use the following steps:

 

Start the Windows Server Manager.

In the tree view, highlight the Features node.

In the details pane, click Add Features.

In the Add Features Wizard, check the Desktop Experience box, and then click Next.

Click Install.

When the Add Features Wizard has finished, click Close.

Click Yes when promoted to restart the computer

 

Regards,

 

J

 

 

Hi,

 

First off all the steps posted in this thread for configuring pre-requisite of SCCM is simply very nice presentation. I really appreciate the Author.

 

I am setting everything (AD, DHCP, IIS, SQL Server 2008 and SCCM 2007 SP1) on "ONE" Test Server and so far I completed the following:

 

- Windows 2008 Server SP2

- Configuring Active Directory Domain Service

- Adding DHCP Role

- Adding IIS Webserver Role

- Download and installing WebDAV for IIS 7

- Enabling WebDAV Publishing using the IIS Manager

- Verify that you have Authorization and Authentication Configured

- Tested with net use *http://localhost// or 127.0.0.1, but getting the same "System error 67 has occured. The network name cannot be found."

- Then applied the above suggestion "Installing Desktop Experience Feature using Server Manager".

 

But I am getting the same result for "net use" command and stopped here. Could someone help me to resolve this.

 

Thanks,

Torpedo

Share this post


Link to post
Share on other sites

what type of user are you logging on to the server as ?

Share this post


Link to post
Share on other sites
what type of user are you logging on to the server as ?

 

Hi,

 

administrator is the user. And I am installing everything as administrator.

 

Thanks,

Share this post


Link to post
Share on other sites

have you tried an old fashioned reboot ?

Share this post


Link to post
Share on other sites
have you tried an old fashioned reboot ?

 

I think once Destop Experience Feature is installed, it prompted me reboot. Hence I ran the reboot. And I am trying net use command after reboot. I'm going to reboot again and see if it helps.

 

Thanks

Share this post


Link to post
Share on other sites
I think once Destop Experience Feature is installed, it prompted me reboot. Hence I ran the reboot. And I am trying net use command after reboot. I'm going to reboot again and see if it helps.

 

Thanks

 

Could you let me know how to run "old fashioned reboot". Is it from DOS prompt?

 

Thanks

Share this post


Link to post
Share on other sites

no it's just a regular reboot,

 

so a reboot didn't help and you still have the same problem ? are you absolutely sure you have applied the webdav settings as detailed in the guide ?

Share this post


Link to post
Share on other sites

Yes. I did apply all of the WenDAV settings by following the screenshots in this thread. I may need to point you my ip settings so that you may understand what would be the issue.

 

Hostname: <given hostname>

Primary Dns Suffix: <domainame.corp.com>

Node Type: Hybrid

IP Routing Enabled: No

WINS Proxy Enabled: No

DNS Suffix Search List..: <domainname.corp.com>

<corp.com>

Ethernet Adaptor Local Aread Connection 4:

Connection-specifix DNS Suffix..: <domainname.corp.com>

Description: Broadcom NetXtreme ...

Physical Address: 00-1B..........-81

DHCP enabled: Yes

Autoconfiguration Enabled: Yes

IPv4 Address: <ip address>(Preferred)

Subnet Mask: 255.255.255.0

Default Gateway: <gateway address with .1 at the end>

DHCP Server: <DHCP server IP>

DNS Servers: 127.0.0.1

NetBIOS over Tcpip: Enabled

 

Ethernet adapter Local Area Connection 3:

Connection-specifix DNS Suffix..:

Description: Broadcom NetXtreme ...

Physical Address: 00-1B.................-82

DHCP enabled: Yes

Autoconfiguration Enabled: Yes

 

IPv4 Address: <ip address>(Preferred) <<---- This is he address that I entered for DHCP Server Role and same for DNS Servers address while setting up DHCP Server Role. I am not sure whether these settings are correct for my server. But the DHCP Server Role setup is successful.

 

Subnet Mask: 255.255.255.0

Default Gateway: <gateway address with .1 at the end>

DHCP Server: <DHCP server IP>

DNS Servers: 127.0.0.1

NetBIOS over Tcpip: Enabled

 

 

I appreciate your timely help. I am basically stopped here because "net use" command is not working for me. Could you let me know what would the issue. Do you think I can continue with the remaining steps and then modify any setting to make "net use" command working.

 

Thanks

Share this post


Link to post
Share on other sites

if you are in a rush, you can continue without net use working

 

we can always come back to it later.

Share this post


Link to post
Share on other sites

As you mentioned in your steps, I did only enable Windows Authentication but not Basic Authentication. I believe it is ok for my setup.

 

Thanks

Share this post


Link to post
Share on other sites

Hello...

 

I am in a very strange situation. Help me plz!

 

I followed this fantastic guide and now when i run the System Center Configuration Manager 2007 prerequisite check. I get the following Error

 

 

post-2659-12531951428004_thumb.jpg

 

I have installed IIS

IIS is enabled.

Webdev is enabled and configured.

I turned off the firewall

I can use net * http//localhost/ without any prob.

 

 

My lab:

 

Server1 - DNS, DHCP, DC, SCCM (windows 2008 std)

Server2 - SQL 2008 (windows 2008 std)

Share this post


Link to post
Share on other sites

which server did you run that on ?

Share this post


Link to post
Share on other sites

well i think all the errors are because of where your SQL server is, ie: it's remote...

 

so, why did you set it up with sql on another box ? and have you made sure the firewall is not blocking any sql traffic and..... have you added the SCCM computer account as a local administrator of the SQL box ?

Share this post


Link to post
Share on other sites

well i think all the errors are because of where your SQL server is, ie: it's remote...

 

so, why did you set it up with sql on another box ? and have you made sure the firewall is not blocking any sql traffic and..... have you added the SCCM computer account as a local administrator of the SQL box ?

 

tnx anyweb

 

i did everything from scratch and this time it worked fine!

Share this post


Link to post
Share on other sites

I had another issue when using Server 2008 R2 x64, and I hope this will help others.

 

After following the first 6 steps in the top post, SCCM would install, but would not create the necessary virtual directories in IIS. After going through logs, here is what I found you have to do.

 

1. Change a few WebDAV settings (refresher: WebDAV, as explained previously, is a part of IIS 7.5, so no download is needed). Go to IIS Manager, Default Web Site, WebDAV, then select "WebDAV Settings..."

  • Allow property queries with infinite depth - TRUE
  • Allow Custom Properties - FALSE
  • Allow anonymous property queries - TRUE

2. Go back to WebDAV authoring rules. Add a new rule: All content - All Users - Read

3. This next step is an installer hack. The installer seems to have permissions issues with the SCCM folder. Go to your Program Files (or Program Files x86 for 64-bit users) and select the SMS_CCM folder's security properties. TEMPORARILY (important this is temporary because we are reducing security here) add Everyone - Full Control.

4. Back in SCCM management console, remove the Management Point role and then add it back.

5. Remove the Everyone group from the folder to restore security.

 

Now you will have IIS virtual directories!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...