Jump to content


Search the Community

Showing results for tags 'batch'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Cloud
    • Azure
    • Microsoft Intune
    • Office 365
  • General Stuff
    • General Chat
    • Events
    • Site News
    • Windows News
    • Suggestion box
    • Jobs
  • MDT, SMS, SCCM, Current Branch &Technical Preview
    • How do I ?
    • Microsoft Deployment Toolkit (MDT)
    • Official Forum Supporters
    • SMS 2003
    • Configuration Manager 2007
    • Configuration Manager 2012
    • System Center Configuration Manager (Current Branch)
    • Packaging
    • scripting
    • Endpoint Protection
  • Windows Client
    • how do I ?
    • Windows 10
    • Windows 8
    • Windows 7
    • Windows Vista
    • Windows XP
    • windows screenshots
  • Windows Server
    • Active Directory
    • Microsoft SQL Server
    • System Center Operations Manager
    • KMS
    • Windows Deployment Services
    • NAP
    • Failover Clustering
    • PKI
    • Windows Server 2008
    • Windows Server 2012
    • Windows Server 2016
    • Windows Server 2019
    • Hyper V
    • Exchange
    • IIS/apache/web server
    • System Center Data Protection Manager
    • System Center Service Manager
    • System Center App Controller
    • System Center Virtual Machine Manager
    • System Center Orchestrator
    • Lync
    • Application Virtualization
    • Sharepoint
    • WSUS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 8 results

  1. Hey all, First, I posted this in a thread I started about a different batch file. I figure this one warrants its own thread. Hopefully that is ok! Anyway, I worked on this all day yesterday and I still can't get it to run. I have changed it to run locally instead of from the dp. I moved the batch file to the folder containing all the contents. Here is a look at the folder... You can ignore the "Batch for SCCM" folder as that was my testing folder for awhile. I'm now trying to run sccm_remove2010_install_2013.bat. The contents are... echo cd %~dp0 setlocal :DeployOffice call cscript OffScrub10.vbs ProPlus /bypass 1 /q /s /NoCancel start /wait setup.exe /configure proplus.xml :End Endlocal When I manually run this from c:\windows\syswow64\ccm\cached\packagefolder, it runs fine. However, I cannot get SCCM to run it. When I run it manually it changes the directory to the package folder located in c:\windows\syswow64\ccm\cached so it is able to run the files in the batch. I cannot figure out for the life of me why it doesn't run in SCCM... and I've looked at execmgr.log and it appears to call it fine, but nothing ever happens on the machine. Any ideas? Thanks, Doug
  2. Hey all, I'm trying to run a batch file that will uninstall Ultra VNC. When I run it from the computer locally or even from a server location, it works fine. I created the package in SCCM like I would for just about any other install package, but it doesn't work. I have tried several settings... drive letter, unc path, run from distribution point, run locally, etc... and several combinations of those settings. I have read quite a bit on the net, but I'm still at a loss. I think I need to be using %~dp0 Here is what the batch looks like now... if exist "C:\Program Files (x86)" goto 64bit goto 32bit :32bit c: cd \program files\ultravnc unins000.exe /VERYSILENT /NORESTART cd \program files\uvnc bvba\ultravnc unins000.exe /VERYSILENT /NORESTART taskkill /F /IM winvnc.exe :64bit c: cd \program files (x86)\ultravnc unins000.exe /VERYSILENT /NORESTART cd \program files (x86)\uvnc bvba\ultravnc unins000.exe /VERYSILENT /NORESTART taskkill /F /IM winvnc.exe Basically it goes to 2 possible locations and runs the uninstall. Then I added a taskkill because in one test, winvnc.exe was still running even after it uninstalled. Anyway, that's not what this about. I'm just trying to get this batch to run via SCCM 2007. If I do need to use %~dp0, how would I do that with this batch file? I don't understand why that would be needed though... especially if I say to download the batch and run locally. Thanks, Doug
  3. Hi, how can i copy two .jar files into a local directory. The Problem: Standard User have read permission. only admin have read write permission. Maybe with a xcopy Batch file? but how did i have to configure the sccm. what did i have to do? Iam a newbi in the sccm world and i hope to get help at this forum. Thanks for all help
  4. Hi, my intention is to copy 2 files into a folder, where only the admin own full permissions. Normal user have only read permissions. The destination directory is: C:\Program Files\Java\jdk1.8.0_45\jre\lib\security The new two files are: jocal_policy.jar and us_export_policy.jar i have to overwrite two files in destination folder, because they are to old. (or first, i delete the old two files and then copy the new two files) Here is my Batchfile, but i dont understand why nothing changes, if i send the batch file to a client: del "C:\Program Files\Java\jdk1.8.0_45\jre\lib\security\*.jar" copy %~dp0local_policy.jar "C:\Program Files\Java\jdk1.8.0_45\jre\lib\security" copy %~dp0US_export_policy.jar "C:\Program Files\Java\jdk1.8.0_45\jre\lib\security" first i generate a application (at sccm12) an configured the following: i told sccm to store the files permanent into Clientcache and to download all files if you need more details, please ask me! I dont know how to go on for fixing the problem thanks
  5. Hi there, i'm in desperate need of help regarding a command line issue I am having. I am trying to run a command line that calls on an .exe in program files and also uses an .xml file to configure an installation of BizTalk 2013R2. Method 1 - Task Sequence command line SCCM Task Sequence Command Line: "C:\Program Files (x86)\Microsoft BizTalk Server 2013 R2\configuration.exe" /s "C:\Program Files (x86)\Microsoft BizTalk Server 2013 R2\BizTalkDomainExport.xml" Method 2 - Task Sequence batch file SCCM Task Sequence Command Line: "C:\Program Files (x86)\Microsoft BizTalk Server 2013 R2\ConfigureBIzTalkCMD.bat" Content of batch file runas /profile /user:domain\administrator /password:##### cmd cd "C:\Program Files (x86)\Microsoft BizTalk Server 2013 R2\" Configuration.exe /s BizTalkExportConfiguration.xml Both above command lines work fine when manually run on the server and completes a silent configuration of BizTalk 2013R2 - but once it is run through a task sequence it fails. NOTE: The BizTalk installation creates an SQL DB. I have set the account that runs the SCCM task sequence as a sysadmin in SQL. ERRORS (Both logs attached; cmdSCCM.log and batchSCCM.log) Both command line and batch file start with the same errors (below) but have different errors later in the log files. Error getting system isolation info. Code 8027000C Remediation failed. Code 8027000C Remediation failed with error code 8027000C I have attempted to run the above commands and configuraton files through an SCCM package/application with the same results. It can't be this hard to run a command line through SCCM can it? I have run other command lines before with no issue. I am lost, can anyone help? Thank you in advance. batchSCCM.log cmdSCCM.log
  6. Hi guys, so this is my first post on the forum and I am hoping you guru's can help me. I will try to describe my problem as accurately as I can. So I will be taking over SCCM 2007 in my company and I am completely new to this so please forgive for the stuff that might seem ordinary to you. We got deployment enviroment setup for cca 200 Users, couple of departments, we use Windows 7 x64 Enterprise SP1. We also use the HTA script in the process, I hope it goes away in the new SCCM 2012 that we have plans to upgrade to. I am supposed to make a very simple think but it does not work for me: install a small 3MB .exe application to program files, and then make a shortcut on desktop for every user that logs into Windows. The batch script looks like this: @echo off msiexec /i "D:\packages\Support Tools 4.1.0\SupportTools.msi"/qb ping -n 11 127.0.0.1 > nul xcopy /s "C:\Program Files (x86)\SupportTools\SupportTools.exe" "C:\Users\Public\Desktop" The file is located on the D: drive of the server on which SCCM 2007 is installed in the "packages" directory. ping is here to give the app 10 sec time to install althought the .exe is a application that is ready to run as soon as you double click it, no install procedure. With the 3rd line of the script I want that same .exe to copy to public desktop folder so all users have instant access to that application. The app was originally exe, but I have made .msi with advanced installer software, and it did work for couple of times but only installation to the program files (x86) folder, but no shortcut on desktop(since I have added ping, the copying to program files does not work anymore). I have ran the app every time with the admin priviliges, maybe that is the issue. But I must emphasize that the script works when I start it manually, it does everything what I want to do with the app. Thank you for your answers,
  7. Hi guys. I have been working on deploying bitlocker on running windows 7 machines using a task sequence. I have only found guides showing how to do this via scripts, or how to do this when deploying a computer. Not how to push this on active running windows 7 machines. Im hoping that this thread could help me with some issues i have, and hopefully assist others. Im using scripts from here: http://archive.msdn.microsoft.com/bdedeploy/Release/ProjectReleases.aspx?ReleaseId=3205 So there are a couple of Scenarios i have to consider when deploying bitlocker: * Computers with a bitlocker partition, but not active TPM chip * Computer with active TPM chip but no partition * Computers that does not have active TPM chip or a bitlocker partition (would be most common) Im running allot of batch files, this is because it gives me better logging possibilities. I want to store what happens on a network drive so in case of problems we can easy find out what have happened. Plus, i just like batch files. Outline of the current tasksequence (all steps have continue on error) Connect to network folder (maps a network folder, in my case W: in order to later copy log files to network share). Create a folder. Command line, that runs a .bat with a service account that´s local admin on machine folder.bat :md c:\Bitlockertemp Create partition (have issues with this step). Command line: Partition.bat >>c:\Bitlockertemp\DOSpartition.txt Disable 64-bit file system redirection, running with service account. Partition.bat: PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1;C:\WINDOWS\system32\en-us; bdehdcfg.exe -target default This should either create a bitlocker partiotion, or say that you already have one Enable TPM (and bitlocker if possible), command line: enable.bat >>c:\Bitlockertemp\DOSLogEnable.txt . Running with service account This will either enable TPM and require a restart, or enable bitlocker Enable.bat: cscript.exe %~dp0EnableBitLocker.vbs /on:tpm /l:C:\bitlockertemp\BitLocker.log echo off if EXIST w:\%computername%\bitlocker-backup-key-package1 (echo "Already done") ELSE ( %~dp0keyupload.bat>>c:\Bitlockertemp\DOSLogKeyupload.txt) echo on Net use w: /delete /y rd c:\bitlockertemp /s /q Keyupload.bat: echo off md w:\%computername% cscript %~dp0GetBitLockerKeyPackage.vbs C:\Bitlockertemp\bitlocker-backup-key-package >> c:\Bitlockertemp\BitLockerKey.txt copy c:\Bitlockertemp\BitLockerKey.txt w:\%computername% copy c:\Bitlockertemp\DOSpartition.txt w:\%computername% copy c:\Bitlockertemp\DOSLogEnable.txt w:\%computername% copy c:\Bitlockertemp\DOSLogKeyupload.txt w:\%computername% copy c:\Bitlockertemp\bitlocker-backup-key-package1 w:\%computername% copy c:\Bitlockertemp\BitLocker.log w:\%computername% copy c:\Bitlockertemp\ADupload.log w:\%computername% rd c:\bitlockertemp /s /q The get GetBitLockerKeyPackage.vbs is for checking if AD have recived the bitlocker key 5. Restart computer, set to " The currently installed defualt operating system" Notify the user before restarting "Your computer is being restarted, if prompted to press F1, please do so" 6.Connect to Network Folder again 7. Enable bitlocker, runs enable.bat again, same as step 4 8. Disconnect network drive, simple command: Net use w: /delete /y My current issue: It´s with creating a bitlocker partition, Running just "bdehdcfg.exe -target default" , fails. I had to add PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1;C:\WINDOWS\system32\en-us; In order to get it to actually run. But the issue im seeing is that when running this the computer stops at creating partition. Nothing happens, the tasksequence does not stop. Not sure if the whole tasksequence is fubar or if I am on the right track. Running the scrips by double clicking on them works like a charm. And the rest of the steps seems to work fine. Any assistance or input would be appreciated. Edit: Im running SCCM 2007
  8. Hi, I try to distribute a start script via tasksequence. It works great, all pcs run daily the startscript. but there is one thing, that is very annoying: on each client there comes a popup with the "program countdown status" that counts down and the users can choose between running now and hiding the popup. How can I define a totally stealth tasksequence that runs a script without letting the user know, that something happened? Thanks in advance. Markus
×
×
  • Create New...