Jump to content




AmrelMahdy

Last Logged User



Recommended Posts

Dears,

Am having a collection with certain computers

there is a way so i can get the users who logged on those computers ???

regards,

Share this post


Link to post
Share on other sites


Just right click on system and edit primary users of the system it should show you the users that operate the PC...

Share this post


Link to post
Share on other sites

OK I need to do that in the form of a report , the collection have more than 200 PC

Share this post


Link to post
Share on other sites

But i See there is a report named "Computers for users in a specific domain" and that report generated for the whole users in the domain , so why they dont make a report "Compters for users in specific collection" ???

Share this post


Link to post
Share on other sites

MS could make a 1 million reports and still there would be reports missing. They is why you have the option to create the report that you want.

Share this post


Link to post
Share on other sites

Yeah u r Right ,, anyway thanks for your quick responses , I really like your forums :))))

Share this post


Link to post
Share on other sites

GarthMJ's report gives a nice list of machines and their last logon user.

Here is one that will give the machine, all logged on users, and when they logged on.

 

Select

V_GS_SYSTEM.Name0 as [ComputerName],

V_GS_NETWORK_LOGIN_PROFILE.LastLogon0 as [Last Login Time],

V_GS_NETWORK_LOGIN_PROFILE.Name0 as [Logon User],

V_GS_SYSTEM.Domain0 as [Logon Domain],

V_GS_SYSTEM.SystemRole0 as [system Role],

V_GS_SYSTEM.SystemType0 as [system Type]

from V_GS_NETWORK_LOGIN_PROFILE

left JOIN v_GS_SYSTEM ON V_GS_NETWORK_LOGIN_PROFILE.ResourceID =

v_GS_SYSTEM.ResourceID

where V_GS_NETWORK_LOGIN_PROFILE.LastLogon0 is not NULL

AND

V_GS_SYSTEM.SystemRole0='Workstation'

Order by V_GS_SYSTEM.Name0

Share this post


Link to post
Share on other sites

Hello,

I checked the view v_GS_NETWORK_LOGIN_PROFILE and it is empty!!!

Any setting to enable to get this information?

Thanks,
Dom

Share this post


Link to post
Share on other sites
20 hours ago, Dom said:

I checked the view v_GS_NETWORK_LOGIN_PROFILE and it is empty!!!

Any setting to enable to get this information?

 

 

This WMI class is not enabled by default within hardware inventory. You would enable it as you would any other class. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×