Jump to content


anyweb

using Offline Mode in Windows PE using USMT 4 via a task sequence in SCCM 2007 SP2

Recommended Posts

hi rudi, can you confirm if the advertisement properties of the your task sequence are set to run from dp or access content directly ?

 

 

 

Hi,

 

i think you mean with dp the deployment point, right? Sorry but i am a beginner in SCCM.

I have attached the screenshot, it is in german but i think the properties are at the same location in all lanuages.

 

Best regards.

 

Rudi

 

post-6011-12828171252299_thumb.jpg

Share this post


Link to post
Share on other sites


select the third option instead of the first, does it work then ?

Share this post


Link to post
Share on other sites

Hi there,

 

I try to reinstall a Windows 7 computer using hardlink(Windows 7 to Windows 7 using Offline mode in Windows PE). The system cannot delete a file (c:\windows\system32\config\SOFTWARE° are not delete and after i have an error.Can you help me please. (Sorry for my English).

 

Thanks in advance.

 

Best Regards

 

Jo

Share this post


Link to post
Share on other sites

This Task Sequence is all well and good but what if I wanna use MDT 2010 Update 1 ? The TS are different than the ones in SCCM. We are eventually looking at moving to SCCM but at the moment our solution is to use MDT. I can get the ScanState to work when logged in as a domain user but it doesn't accept the arguments from the CustomSettings.ini. Have any suggestions? In the meantime, I will try to modify your TS for MDT and see if it works.

 

thanks,

Terry

 

I am in the same boat have you been able to edit the TS to make it work in MDT 2010 with hardlinks, offline and install OS then loadstate?

Share this post


Link to post
Share on other sites

select the third option instead of the first, does it work then ?

 

Hi there,

 

i set the option like you said (see the picture below)

 

The sequence crashes with the error "The order "runscanstat-offlinewindir.bat" could not be found or is written wrong.

Also all the packages in the "SMSPKGC$" share is copied on the client again.

 

If i set the previous setting the sequence runs but don´t copy the profiels back.

 

Do you have an idea what i made wrong?

 

Thanks in advance.

 

Best regards.

 

Rudi

Unbenannt.bmp

Share this post


Link to post
Share on other sites

I am in the same boat have you been able to edit the TS to make it work in MDT 2010 with hardlinks, offline and install OS then loadstate?

 

Yes I did !! Works perfect except it seems to miss some desktop icons. I think I need to create a Custom.xml file. You can use this task sequence as is, works quite well. I've attached my Task Sequence, you just need to fix the OS info and the servername(MDT).

ts.xml

Share this post


Link to post
Share on other sites

good work Terry, and thanks for sharing, Offline mode in WinPE rocks doesn't it :)

Share this post


Link to post
Share on other sites

good work Terry, and thanks for sharing, Offline mode in WinPE rocks doesn't it :)

 

 

Hello,

 

can you give me a hand to find a solution for my problem? I posted 2 articles above.

 

Thanks in advance.

 

Rudi

Share this post


Link to post
Share on other sites

the wiping of the drive is handled by magic or rather by the Apply Operating Image step, try it and see :)

Share this post


Link to post
Share on other sites

Much thanks for this TS as USMT as been a pita for me -

 

Question:

 

I am at the Task "xcopy x86 USMT to USMTbits\x86"

 

pressed f8 to check folder status:

 

under c:\usmtbits\x86 I am seeing a bunch of packages being downloaded...

 

Did I do something wrong...

 

TS is still running/sitting at that point

Share this post


Link to post
Share on other sites

I have USMT offline working with SCCM 2007 R2 but I have a problem if I do not delete the computer from Active Directory before the build. I am using the Unknown Computers collection to assign the Computer Name during the Task Sequence. The OS build works correctly when I delete the compueter name from AD before the build. If I do not remove the computer account the process assigns a MININT-xxxxx and joins that name to the domain. What can I do to fix this issue.

 

Thanks.

Share this post


Link to post
Share on other sites

Hello all.Maybe a silly question.The runscanstate-offlinewindir.bat do i have to create a TS to import it or do i hav to copy it to the xp machine?

Thank you.

Share this post


Link to post
Share on other sites

you can use the supplied task sequence and download the supplied batch file (which will be used in a separate package)

 

cheers

niall

Share this post


Link to post
Share on other sites

copy the batch file to a folder, in configmgr software distribution, select packages right click, choose new package, point to the folder, done. Distribute it to a dp. thats it

Share this post


Link to post
Share on other sites

Thank you very much!one more question...I take an error when running ofline task sequence from last step x86 do runscanstate(0x00000001) and it stops.Also i can see in log an error runscanstate-offlinewindir.bat is not recognized as an internal or external command.That error is when i take the steps online.When i do it from pxe boot i take a error 0x80004005!Any help for both problems?

Share this post


Link to post
Share on other sites

Also i can see some failed point to my logs

SMSTS.LOG

 

Failed to run the action: do X86 scanstate.

Incorrect function. (Error: 00000001; Source: Windows)

 

The execution of the group (Run) has failed and the execution has been aborted. An action failed.

Operation aborted (Error: 80004004; Source: Windows)

 

Task Sequence Engine failed! Code: enExecutionFail

 

 

 

smsts-20101112-021854.log

 

Failed to connect to "\\LAB-SCCM-01.DOMAIN.LOCAL\SMSPXEIMAGES$\SMSPKG\ABC00005"

 

 

Any help appreciated

Share this post


Link to post
Share on other sites

It is hard to say with these failed sentances direclly.There should be other information after and before task action failed. It would be easier for us if you post smsts.log for other info as well.

 

Failed to run the action: do X86 scanstate.

Incorrect function. (Error: 00000001; Source: Windows)

 

The execution of the group (Run) has failed and the execution has been aborted. An action failed.

Operation aborted (Error: 80004004; Source: Windows)

 

Task Sequence Engine failed! Code: enExecutionFail

 

this could be because of command line syntax errors for do X86 scanstate or not having the required USMT package?

 

smsts-20101112-021854.log

 

Failed to connect to "\\LAB-SCCM-01.DOMAIN.LOCAL\SMSPXEIMAGES$\SMSPKG\ABC00005"

 

it is failed to connect to ABC00005(might be boot image),also problem could be network breakdown issues or secury rights(may be NAAccount ) while connecting to PXE DP package but after this messgege ,client should have tried connecting again to this package successfully i think.

 

 

Share this post


Link to post
Share on other sites

This guide is excellent. My question is do the default .xml files need to modified (Miguser.xml, MigDocs.xml, MigApp.xml) and if so what are the changes for offline USMT to work?

Share this post


Link to post
Share on other sites

Thanks for your answer.I have attached the 2 logs i mention.Please have a look any comment appreciated.smsts.logsmsts-20101112-021854.log

 

 

the bat file package is download and saved to 'c:\USMTbits\ but failed to execute. There is something wrong with your batch file creation .Check if you have created the correct bat file or not ? like cmd.exe /c batfilename.bat also ensure you have created package with correct files into it.

 

Set command line: Run command line

Working dir 'c:\USMTbits\'

Executing command line: Run command line

Process completed with exit code 1

'runscanstate-offlinewindir.bat' is not recognized as an internal or external command,

operable program or batch file.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...